LucMtl

VC Gauges too bright now.

Recommended Posts

Hi,

 

I've managed to get the default C172 VC in FSX to look like this at night, which I think is pretty nice :

https://goo.gl/photos/SzL6BubXKg9qTCdHA

But I still have a problem with the gauges being a bit too bright to my taste.  Is there a sweet single command I can write down somewhere to dim then all at once ?

Thanks. :)

Luc

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

In case someone asks me how I did that, here it is :

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

1- Deactivating the VC night textures:

I went to the folder:  *FSX*\SimObjects\Airplanes\C172\Texture

…and changed the names of the night textures to deactivate them.  So…

C172_1_night_C.dds
C172_2_night_C.dds
C172_3_night_C.dds
C172_4_night_C.dds

Became:

C172_1_night_C.dds.STOP
C172_2_night_C.dds.STOP
C172_3_night_C.dds.STOP
C172_4_night_C.dds.STOP

The idea behind this is that, doing this is going to force FSX to use the daytime textures during nighttime, which is exactly what we’ll want it to do.  The problem with the default C172 nighttime textures is that they have a blindingly bright (and ugly!) lighting drawn directly into the texture images.  No configuration of any sort can get us rid of that lighting, it’s *drawn* on the pictures themselves.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

2- Editing aircraft.cfg:

In the folder: *FSX*\SimObjects\Airplanes\C172

In the [LIGHTS] section, I left the line:
;/light.5 = 4,  -2.27,   0.00, 1.45, fx_vclight

…commented out as it was originally by Microsoft.  It’s ok that it’s commented out, if it wasn’t, we’d end up with excess lighting in the VC.  So don’t change it.

BUT I added:
light.6=10, -2.27,   0.00, 1.45, fx_vclight_low

And that one is NOT commented out!  The type 10 light is the “dome light” in the VC, and this is exactly the type of light we are going to use to create this dim ambient light.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

3- Creating and editing fx_vclight_low.fx:

In the folder:  *FSX*\Effects

I made a copy of the file fx_vclight.fx, and named it fx_vclight_low.fx

And in the [ParticleAttributes.0] section of fx_vclight_low.fx, I changed:
Color Start=100, 100, 100, 1
Color End=180, 140, 100, 0

To:
Color Start=30, 30, 30, 1
Color End=30, 30, 30, 0

This is the new effect file that will create the dim ambient light.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

4- Restart FSX, and it should work.

The funny trick that’s being exploited here is to use a very dim dome light (type 10 light at COLOR=30,30,30) to make the VC look as if it was being illuminated solely by the light from the gauges themselves.   It’s an illusion of course, but a nice one!

One point: this trick doesn’t work with all default FSX aircrafts, only with those that use night textures.

Share this post


Link to post
Share on other sites

Down at the bottom of the panel.cfg are some texture numbers that may help to change the brightness.  Isn't there a panel light brightness knob to adjust?

Share this post


Link to post
Share on other sites
8 minutes ago, charliearon said:

Down at the bottom of the panel.cfg are some texture numbers that may help to change the brightness.  Isn't there a panel light brightness knob to adjust?

Let me try again if it works. :)

Luc

Edit : no, the default C172 doesnt have any working knob of that kind. It is there, but it's only decoration, not functional.

 

Share this post


Link to post
Share on other sites
16 minutes ago, charliearon said:

Down at the bottom of the panel.cfg are some texture numbers that may help to change the brightness.

Unfortunately it doesn't work.  The three values are:

1- Day: That changes the 2D panel at daytime, not the VC.

2- Night: That changes the 2D panel at nighttime, not the VC.

3- Luminous: changing the values here didn't change anything, neither with VC nor with the 2D panel.

 

Share this post


Link to post
Share on other sites
1 hour ago, charliearon said:

This is the dimmer knob in the C-172 panel that I mentioned.

Lightdimmer.jpg

Hi ! :)  Yep, I know. It actually works only as an on-off button.You can't change it incrementally,

Thanks for the effort ! :)

Luc

 

Share this post


Link to post
Share on other sites

After more analysis, I think the color of the gauges at night is decided somewhere inside the gauges dll (see *FSX*\Gauges, the files Cessna.dll, Cessna172.dll and Bendix_King_Radio.dll.  

So there is no way to change this as fas as I am concerned, but it's ok, it's not unlivable like that. :)

 

Good day,

Luc

Share this post


Link to post
Share on other sites

Luc, you are quite correct as far as that goes. The compiled .gau or .dll files contain 'flags' for lighting that is either 'bright' or 'luminous', hence the color options at the bottom of the panel.cfg file, but only for 2D panels, but also the compiled .mdl file has set options for lighting, using either Additive (always active with switch on) or more commonly "Multiply Blend" or "Blend" that only works with switch on at night time.

Share this post


Link to post
Share on other sites
36 minutes ago, n4gix said:

Luc, you are quite correct as far as that goes. The compiled .gau or .dll files contain 'flags' for lighting that is either 'bright' or 'luminous', hence the color options at the bottom of the panel.cfg file, but only for 2D panels, but also the compiled .mdl file has set options for lighting, using either Additive (always active with switch on) or more commonly "Multiply Blend" or "Blend" that only works with switch on at night time.

So now I know for sure, thanks for your reply. :)

 

I did some experiment with values of the start/end colors in the effect file, and I found that putting COLOR=50, 50, 50 creates the best visual result:

https://goo.gl/photos/aGiacwctv1KQhpSc6

 

This is entirely empirical, but I think that lower than that (dome light dimmer), and the contrast between the gauges and the dark ambiant light make them appear more blinding, where as higher than 50,50,50, then it is the dome lighting itself that start to make the gauges appear brighter.  At 50, 50, 50, it almost perfect.

 

Luc

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now