Sign in to follow this  
MikeKirda

Issues with CH Eclipse yoke not being recognized

Recommended Posts

A quick google search shows nothing seemingly relevant and IPACS doesn't appear to have a support email. Yikes.

I had gotten FS2 a while back and never really used it much. My CH Eclipse yoke arrived yesterday.

Windows 10 recognizes it just fine. FS2 does not. Have tried with different USB ports and rebooting several times but the controller still does not show up in FS2.

 

Any ideas what I should try?

 

Regards.

Mike Kirda

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

 

That is not great....

I have that yoke and I'm have been using it for over a year in AFS2 and win7.  I never had any issues.  Just plug and play anytime. I think it has something to do with win 10. Do you have another pc to plug it in.. the yoke should work without problems.

 

Good luck. I'll try to think about your problem and who knows we can fix the issue

 

Jozeff

Share this post


Link to post
Share on other sites
On 9/21/2017 at 7:06 PM, MikeKirda said:

Anyone have a support contact for Aerofly?

Why not go to the sims website? 

Share this post


Link to post
Share on other sites

Tried. Twice. Still no response after more than 10 days. Was hoping someone might have an email address rather than a form that provides no feedback.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this