Sign in to follow this  
ahuimanu

777F saved flight did not save panel/aircraft state

Recommended Posts

A recent saved flight - I save on account of crashing consistently when flying into certain airports - did not reload successfully when I reloaded the sim.  The initialization routine (the 19sec countdown) did not appear and the plane was dead (unclickable VC, etc.).  Anyone experience that before?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

2 hours ago, ahuimanu said:

A recent saved flight - I save on account of crashing consistently when flying into certain airports - did not reload successfully when I reloaded the sim.  The initialization routine (the 19sec countdown) did not appear and the plane was dead (unclickable VC, etc.).  Anyone experience that before?

I load saved flights routinely, almost daily. I had one problem a couple of months ago that appeared to be a corrupted panel state but that was one isolated incident.  I am more interested in why you are consistently crashing.... say type simulator?

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Jeff... P3Dv4 is a very stable platform.  If you have frequent crashes then there is a reason for it that I suggest you may want to spend the time pursuing. Describe the events (does P3D close without warning or do you get an application stopped working message?), and what you are doing with the simulation when it occurs. What do the crash reports indicate as the faulting module?  Have you tried to isolate it by removing other addons?  Can you create a "vanilla" P3D configuration that runs reliably?  See also the AVSIM CTD guide for assistance.

Share this post


Link to post
Share on other sites

Dan,

In cruise with the 777F.

Usually nt.dll

I had stability in 4.0 (with the exception of FSDT KMEM).

I ran the "delete generated files" script today, so I'll see what happens as I add things back in.

I had recently attempted to use MyTraffic 6a again, but I've removed it just now.

Setting another flight to see how I fare.

Share this post


Link to post
Share on other sites
13 hours ago, ahuimanu said:

Dan,

In cruise with the 777F.

Usually nt.dll

I had stability in 4.0 (with the exception of FSDT KMEM).

I ran the "delete generated files" script today, so I'll see what happens as I add things back in.

I had recently attempted to use MyTraffic 6a again, but I've removed it just now.

Setting another flight to see how I fare.

My problems with ntdll.dll events were always associated with an FSDT module and seemed to be related to updates. However, this only plagued me for a few months early this year and their new updater seems to be pretty solid.  Their KMEM is a new version adapted to P3Dv4.  When was the last time you ran the FSDT updater?

See also the AVSIM CTD Guide:

 

Share this post


Link to post
Share on other sites

Thanks Dan.

Flight from UUEE to KSDF completed yesterday.  I had put many of my add-on.xml-style addons back in and did not have MyTraffic installed either. Something about KMEM has made me CTD there in 4.0 and 4.1 with the PMDG 747 or the 777 since 4.0 came out.  I've posted at their forums, but no dice thus far.

Thank you for linking the CTD guide, I've reviewed it in the past. In the end, it is the gumbo of add-ons that ultimately makes things a crapshoot.  Whereas OOM is not the issue now in 64-bit P3D, other inconsistencies are.  For instance, I wish that this new add-on system was universally adhered to, but it is not.

Thank you.

Share this post


Link to post
Share on other sites
3 hours ago, ahuimanu said:

Something about KMEM has made me CTD there in 4.0 and 4.1 with the PMDG 747 or the 777 since 4.0 came out.  I've posted at their forums, but no dice thus far.

Yeah, Umbreto will provide assist with his products but if it is anything else his attitude is 'please don't bother me with your problems.' There was a new Memphis pushed out not too long ago that was compiled for P3Dv4, make sure you have that version, which is why I asked about the last time you ran the FSDT Updater.

It matters little to me how the developer publishes their installers because one it is installed I go through it and make changes to conform to my way of using addons.  All my scenery addons are added with add-on.xml files (Except Orbx because FTXCentral3 works and I don't want to break it), and all products from one developer are in the same xml file.  Just my OCD kicking in but I keep track of that stuff and it makes it easy to isolate problems when they inevitably happen.

Share this post


Link to post
Share on other sites
13 hours ago, ahuimanu said:

how do you trap when these installers put things into the p3d directory?

There are a few developers that do this, and it annoys the cr*p out of me.  The solution is to create a zero sized prepar3d.exe file in the addon root directory.  I forget who does this, FlyTampa maybe?  Doesn't matter, the zero sized file is always there.

To create just create new text file and rename it and don't enter anything in the file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this