Wody

F1 Mustang Module AFCS usage problem

Recommended Posts

Hi,

recently I added a self made AFCS unit to my cockpit. Nearly all is working great with the Mustang module.

Only the FLC function is not working ok. In this mode you change the desired speed with the VS wheel. Unfortunately this is not possible with the LINDA Mustang module functions using the HW AFCS. Mouse clicking work as usual.
The same applies to the SPD function (switch to Mach).

Is there any chance to change the Mustang module?

 

Thanks,
Peter

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If I recall, it's mapped to the VS knob.  If VS is pushed it changes the rate of climb and descent.  If FLC is pressed, it changes the speed.  Pretty sure that's how I have it configured in my module.

Share this post


Link to post
Share on other sites

Hi Gregg,

you described how it should work. I could also see it in the actions.lua file. The normal VS operation is ok, the VS is indicated at the top of the ALT tape in the PFD.

Selecting FLC (VNAV LED is out, FLC LED in on), the present speed is indicated in the Airspeed tape. When I rotate the VS wheel, the speed indicated in the top of the Airspeed tape should change. But there is no change indicated. It looks like the VS wheel input is not "changed over" to the FLC function.

I have mapped the VS wheel to inc and dec, not fastinc and fastdec. All dials in the AFCS are single encoders, so no possibility for normal inc/dec and fastin/fastdec. But this is another subject/problem with ALT and HDG.

I have to check if the plane is at least doing a speed change, even if not indicated in the PFD.

I'v still no idea. Thanks
Peter

Share this post


Link to post
Share on other sites

Here's an extract out of my module that shows each function.  It's been a long time since I wrote this so my memory isn't the greatest on it.

function F1Must_VS_inc ()

ipc.control(65894)
F1VS = ipc.readLvar("VsWheel")

F1VS = F1VS + 5
if F1VS >= 100 then
F1VS = 0
end
ipc.writeLvar("VsWheel", F1VS)
ipc.control(65823, 11) -- knob sound
ipc.control(65823, 0) -- knob sound
end

 

function F1Must_VS_dec ()

ipc.control(65895)
F1VS = ipc.readLvar("VsWheel")

F1VS = F1VS - 5
if F1VS <= 0 then
F1VS = 100
end
ipc.writeLvar("VsWheel", F1VS)
ipc.control(65823, 11) -- knob sound
ipc.control(65823, 0) -- knob sound
end

 

function F1Must_SPD_inc()
ipc.control(65896)
F1VS = ipc.readLvar("VsWheel")

F1VS = F1VS + 5
if F1VS >= 100 then
F1VS = 0
end
ipc.writeLvar("VsWheel", F1VS)
ipc.control(65823, 11) -- knob sound
ipc.control(65823, 0) -- knob sound
end

function F1Must_SPD_dec()
ipc.control(65897)
F1VS = ipc.readLvar("VsWheel")

F1VS = F1VS - 5
if F1VS <= 0 then
F1VS = 100
end
ipc.writeLvar("VsWheel", F1VS)

ipc.control(65823, 11) -- knob sound
ipc.control(65823, 0) -- knob sound
end

 

Share this post


Link to post
Share on other sites

That is the code I also have. It is your Mustang Module V1.2. So I have everything.

Just checked in the sim. If turning VS when in FLC mode the FD is commanding up/down, but the blue airspeed reference bug is not moving to the dialed speed, nor the airspeed reference above the speed indicator is changing.

There is also another problem: When intercepting a ILS in HDG mode and then activating APR mode, the APR light (next to the button) goes on and the HDG light goes off. Both lights should be on until LOC capture. The plane is behaving right, but just the indications are not refreshed, like the speed bug and the lights

I will investigate a little bit more. Probably Flight 1 has some own internal gauge programming and is not using standard Lvars and the like.

Thanks,
Peter

 

Share this post


Link to post
Share on other sites
2 minutes ago, Wody said:

That is the code I also have. It is your Mustang Module V1.2. So I have everything.

Just checked in the sim. If turning VS when in FLC mode the FD is commanding up/down, but the blue airspeed reference bug is not moving to the dialed speed, nor the airspeed reference above the speed indicator is changing.

There is also another problem: When intercepting a ILS in HDG mode and then activating APR mode, the APR light (next to the button) goes on and the HDG light goes off. Both lights should be on until LOC capture. The plane is behaving right, but just the indications are not refreshed, like the speed bug and the lights

I will investigate a little bit more. Probably Flight 1 has some own internal gauge programming and is not using standard Lvars and the like.

Thanks,
Peter

 

Those are interesting.  I'll have a look at my module to see what's happening. 

Share this post


Link to post
Share on other sites
On 10/23/2017 at 4:46 PM, Wody said:

Just checked in the sim. If turning VS when in FLC mode the FD is commanding up/down, but the blue airspeed reference bug is not moving to the dialed speed, nor the airspeed reference above the speed indicator is changing.

Haven't forgotten about you Peter.  Just to clarify, you want the same control (wheel or knob) to control speed if FLC is pressed, vertical speed if VS is pressed, correct?

On 10/23/2017 at 4:46 PM, Wody said:

There is also another problem: When intercepting a ILS in HDG mode and then activating APR mode, the APR light (next to the button) goes on and the HDG light goes off. Both lights should be on until LOC capture. The plane is behaving right, but just the indications are not refreshed, like the speed bug and the lights

That'd be a bug, I think. 

Share this post


Link to post
Share on other sites
20 hours ago, Gregg_Seipp said:

Haven't forgotten about you Peter.  Just to clarify, you want the same control (wheel or knob) to control speed if FLC is pressed, vertical speed if VS is pressed, correct?

Hi Gregg,

Yes, exactly. The VS wheel is also used in FLC mode to change the speed. That is how it works in real with the GMC710 mode controller. It works when I just use the mouse in the 2D window.

Just another question: The FADEC mod works well regarding TQ indication and flaps reaction. But it seems the capture of LOC and GS is very "lazy". The bank angle is max 15° usually 10° and the GS captures to late, so it is always >1 dot to high. It becomes better along the approach, but never follows on spot. Speed to intercept is 160 to 180 kts and angle is 30°.
This was better before, at least I think so. Did the mod dampen bank and pitch?

Thanks for all your help!

Peter

Share this post


Link to post
Share on other sites
19 minutes ago, Wody said:

This was better before, at least I think so. Did the mod dampen bank and pitch?

Which mod are you referring to?  My Mustang LINDA module or my Mustang FDE mod?  BTW, which version of FSX/P3D are you running?

Share this post


Link to post
Share on other sites
On 10/31/2017 at 2:11 PM, Wody said:

Yes, exactly. The VS wheel is also used in FLC mode to change the speed.

Hi Peter,

I've added the new functions to my LINDA Mustang module which allow you to use one knob to control both VS and FLC from the same knob based upon whether VS or FLC are selected. 

F1Must_VS_SPD_inc
F1Must_VS_SPD_dec
F1Must_VS_SPD_fastinc
F1Must_VS_SPD_fastdec

You can get the module from here...

https://www.dropbox.com/s/nmedhk20fs7r1q1/Mustang Linda.zip?dl=0

The only file you should need out of the bundle is the linda/aircrafts/F1 Cessna Mustang/actions.lua.

I do also have an FDE mod for the Mustang that fixes/improves quite a few things...power settings up and down the throttle, flaps, ILS hold, etc.  PM me if you want that.

Gregg

Share this post


Link to post
Share on other sites

Hi Gregg,

thanks for the LINDA file. Will install this evening.

The mod I refered to in my previous post is the FDE mod (I called it FADEC Mod) I got from you in August. It was a aircraft.cfg and the air file. As mentioned already the ILS tracking is worse than with the original files. All other changes like idle power, climb speed, flaps liftz, fuel burn... are ok and more to the numbers. Just the ITT seems higher than I observed in several YouTube vids (real Mustang!).

I'm quite happy just the lazy ILS tracking is bothering me.

I'm using P3D V3, FSUIPC 4.968 and LINDA 2.9.5.542. all on WIN 100.
Should have said that earlier, sorry!
 

Peter

Share this post


Link to post
Share on other sites
58 minutes ago, Wody said:

Hi Gregg,

thanks for the LINDA file. Will install this evening.

The mod I refered to in my previous post is the FDE mod (I called it FADEC Mod) I got from you in August. It was a aircraft.cfg and the air file. As mentioned already the ILS tracking is worse than with the original files. All other changes like idle power, climb speed, flaps liftz, fuel burn... are ok and more to the numbers. Just the ITT seems higher than I observed in several YouTube vids (real Mustang!).

I'm quite happy just the lazy ILS tracking is bothering me.

I'm using P3D V3, FSUIPC 4.968 and LINDA 2.9.5.542. all on WIN 100.
Should have said that earlier, sorry!
 

Peter

Yeah, it was worse, I think.  I've made some improvement to it since then.  Still, hoping to get more improvements to it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now