Brendan1231

Airspeed indicator glitch

Recommended Posts

Ok so I am flying from Detroit to Vancouver and my airspeed indicator is glitched or something it goes from like 160 knots to like 330 knots in about a second and I can’t find anyone else having this problem does anyone know what is happening

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Also it only seems to be at one part of the flight I don’t know if that makes any difference. Also I am sorry if I did anything wrong with this forum idk any of the rules I just really needed help and I looked up the problem and could not find the solution anywhere

Share this post


Link to post
Share on other sites

The forum rules are pinned in the general forum and every subforum and include the request that we sign our full name on all posts.

Not much info here..., I assume it is the NGX aircraft. What part of the flight does the airspeed 'glitch' occur? What are you using for a weather engine or addon?

Share this post


Link to post
Share on other sites

Using active sky? Make sure your turbulence settings are not higher than 30... 

Share this post


Link to post
Share on other sites

So, you prefer to not use your full name in this forum.  You can ask for support directly from PMDG at PMDG Product Support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now