Sign in to follow this  
Branimir

Prepar3D v4.1 input delay

Recommended Posts

Hi!

I have a problem in Prepar3D V4. When I turn on dynamic lightning and at the night time I get 30-40FPS but I have half a second (sometimes 1 second) input delay when I click on a switch in cockpit, when I move my flight controls (pedals yoke..) or when I pan my view. Everything has a delay.

Do you know what migh cause this problem?

 

Specs:

i7 7700 (running at 4.2 GHz, HT enabled)

8x2 GB DDR4

KFA2 GTX 1060

240GB SSD, 1TB HDD, 2TB HDD

 

Thank you!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I'm sure you have already figured out that Dynamic Lighting is the culprit. I don't think anything other than top tier equipment can handle that bit of eye-candy. The only thing that I can think of to alleviate the fps drop is lower sliders across the board and trying to find best performance difference between locked and unlocked frames. Myself, running a 7700K @ 4.6 ghz (simple overclock ) and GTX 1060, unlimited frames don't even attempt Dynamic Lighting, and I don't miss it. 

  • Upvote 1

Share this post


Link to post

Thank you! Now I know that these problems are something normal, I though I had too weak PC to handle dynamic lightning. Is Lockheed Martin planning to optimise lightning in next updates?

Share this post


Link to post

Not that I'm aware of. It's normal for flight sims (if publishers are really serious about their product) to constantly enhance  with more possibilities, which of course raises the need for more capable computer components. Just preparation for future "goodies". The good part is that these new pieces of eye candy are optional (in order to widen usability to all) 

  • Upvote 1

Share this post


Link to post

I just found out what was causing these problems. I have 4xMSAA in sim, but I had 8x sparse grid supersampling in nVidia inspector. I lowered this setting to 4x supersampling. I used to haver horrible delay with aircraft lights (taxi, runway turnoff lights, especially landing lights) and my FPS dropped to 20FPS. Now, with this setting lowered I have almost no FPS drop at night, with landing lights ON and no input delay. :biggrin:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this