Sign in to follow this  
Mike T

No PMDG Aircraft loading in P3D v4.1

Recommended Posts

I'm going to assume that its just me having this issue since I don't see anyone else having this problem.  P3D v4.1 with Windows 10 (all patches).  I re-installed all PMDG products recently and this is the first time I was going to use them.  The registration screen popped up as usual when trying to load the 737-700, I put in the code and then P3D gets locked up at a black screen.  No error, just P3D at at black screen.  I checked the event viewer and don't see an error.  However, I have to go manually close P3D because it is locked up at black screen.  

I reloaded P3D but same error.  I can select the PMDG aircraft - they are there in the menu but they don't load.  Rebooted, and uninstalled, and reinstalled.  Same issue except that there is not even a registration screen that pops up when trying to load the 737-800 for the first time.  I have FSL A320 and Q400 and both load - as well as all default aircraft,  but no PMDG products load.  Is this part of the Creator's update issue?  Anything else I can try?  Any logs I can pull?

Thanks,

Michael P. Toussaint

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have the 1709 update?  That seems to be the problem, but I cannot directly speak to it because I do not have that update.  There are several threads here, in the AVSIM P3D forum and in the LM forum regarding this update.

In general, I always recommend anyone with authentication issues contact PMDG Product Support directly, there is little that a user forum can offer to resolve such an issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this