C130FE

Still Can't get MCE to work

Recommended Posts

In a previous post I was told because I downloaded FSX:SE after MCE, that I needed to update MCE to the latest version.  I did exactly as the reply stated, but still can't get MCE to work.  I continually get the pop up box telling me I need to click on fsx.exe and give administrator privileges.  I have done that box 20 times.  The box was originally checked to begin with.  So I uncheck it and start all over again.  But I cannot get past this step.  I am totally frustrated because I have administrative privileges, I keep giving administrative privileges and still cannot get it to work.  Worked fine until going to Steam Edition.  What am I doing wrong?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

37 minutes ago, C130FE said:

In a previous post I was told because I downloaded FSX:SE after MCE, that I needed to update MCE to the latest version.  I did exactly as the reply stated, but still can't get MCE to work.  I continually get the pop up box telling me I need to click on fsx.exe and give administrator privileges.  I have done that box 20 times.  The box was originally checked to begin with.  So I uncheck it and start all over again.  But I cannot get past this step.  I am totally frustrated because I have administrative privileges, I keep giving administrative privileges and still cannot get it to work.  Worked fine until going to Steam Edition.  What am I doing wrong?

Strange, because with Steam Edition you don't even need to set "fsx.exe" to run as admin. Unlike the boxed edition, Dovetail has already compiled "fsx.exe" to always ask for elevation. I mean it will always run as admin, with or without the box ticked in file properties. Same with "mce.exe".

Shouldn't have waited that long.

For MCE to connect to FSX (boxed or Steam), you need the following.

fsInsider.dll in main FSX installation folder

fsInsider.ini in main FSX installation folder.

A folder named <MCE dlls>, with about 40 dlls inside it.

For fsInsider.dll to load, FSX Steam Edition has to have a reference to it in "dll.xml"

Go to C:\Userrs\your_user_Name\AppData\Roaming\Microsoft\FSX\ folder.

NOTE: if you have both boxed and Steam installed, you may have 2 separate folders

C:\Userrs\your_user_Name\AppData\Roaming\Microsoft\FSX\ folder.

AND

C:\Userrs\your_user_Name\AppData\Roaming\Microsoft\FSX-SE\ folder.

Open dll.xml in Notepad and check you have these lines somewhere

<Launch.Addon>
        <Name>Multi Crew Experience</Name>
        <Disabled>False</Disabled>
        <ManualLoad>False</ManualLoad>
        <Path>fsInsider.dll</Path>
    </Launch.Addon>

If missing, either re-run the app wizard or manually add them.

Suggest you temporarily change <ManualLoad>False</ManualLoad> to <ManualLoad>True</ManualLoad>

Start FSX, and it should definitely prompt for permission to run the dll.

If it doesn't maybe you didn't have the correct "dll.xml" file edited.

Once you have agreed for it to run, the only thing that may prevent MCE connecting is if you have Windows UAC enabled and didn't install MCE to default C:\Program Files (x86)\ folder.

We don't recommend disabling Windows UAC, therefore, just install to default path and you should be fine.

Confirm up and running.

 

 

Share this post


Link to post
Share on other sites

Gerald, The following file was in as you said.

<Launch.Addon>
        <Name>Multi Crew Experience</Name>
        <Disabled>False</Disabled>
        <ManualLoad>False</ManualLoad>
        <Path>fsInsider.dll</Path>
    </Launch.Addon>

I changed the <ManualLoad>False<?ManualLoad> to True and it appears its going to work.  Now I need to reregister and it says that I need to put the license key file into MCE installation folder. I can't seem to find that file.  So when I go to fill out the registration I need a serial number and I don't know what that is or where to find it.  So sorry for the hassle.  Could you tell me what I need to do?  Thanks

Rodger

Share this post


Link to post
Share on other sites
33 minutes ago, C130FE said:

Gerald, The following file was in as you said.

<Launch.Addon>
        <Name>Multi Crew Experience</Name>
        <Disabled>False</Disabled>
        <ManualLoad>False</ManualLoad>
        <Path>fsInsider.dll</Path>
    </Launch.Addon>

I changed the <ManualLoad>False<?ManualLoad> to True and it appears its going to work.  Now I need to reregister and it says that I need to put the license key file into MCE installation folder. I can't seem to find that file.  So when I go to fill out the registration I need a serial number and I don't know what that is or where to find it.  So sorry for the hassle.  Could you tell me what I need to do?  Thanks

Rodger

It's OK.

Serial number is found in your original invoice when you bought MCE, under "delivered codes" or "registration code".

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now