flytriman

Keeps asking me to uninstall old version even though it has already been uninstalled

Recommended Posts

Tried to update to 2.7.4.2. in FSX/P3D.  Did the uninstall from the control panel...did not remove anything manually.  Now I try to install the new version by clicking on "InstallMCE.exe" and it keeps telling me it finds an older version and I need to uninstall it.  Looked again in Control Panel, Uninstall Programs...no MCE is shown.

How can I fix?  Thanks,

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

2 hours ago, flytriman said:

Tried to update to 2.7.4.2. in FSX/P3D.  Did the uninstall from the control panel...did not remove anything manually.  Now I try to install the new version by clicking on "InstallMCE.exe" and it keeps telling me it finds an older version and I need to uninstall it.  Looked again in Control Panel, Uninstall Programs...no MCE is shown.

How can I fix?  Thanks,

Seen it happen a couple of times on Windows 10, with the latter not letting Microsoft older installer (which we always used) remove a particular entry in registry.

If you know about "regedit" Windows tool, run it and search for key "FS++"

It should find it. And you may see a subkey named <Multi Crew Experience>

Delete the subkey and exit regedit.

Should be able to install after that.

The alternative, is to proceed as follows.

Instead of running "InstallMCE", open "Resources" folder (in unzipped downloaded file) and run "xPack.msi" instead.

It will install MCE for sure, but you would be missing the copying of the files to various simulators folders (which can be done manually).

InstallMCE does the copying bit automatically before firing xPack.msi

 

 

Share this post


Link to post
Share on other sites

Thanks Gerald.  I will try as soon as I finish the flight I'm on...11hrs from PHNL to KSFO in 1947 with the Flight Replicas DC-4...boy they were slow back then.

I was able to recover the old version using Windows Restore so I could finish this flight.

Share this post


Link to post
Share on other sites

As I said I was able to use Windows Restore to get the previous version back.  This time, when I uninstalled it and did the install of the 2.7.4.2 version, it worked as it should and everything is fine.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now