algy10

Latesr version(s)

6 posts in this topic

Hi

All of a sudden I find that I am unable to run any version of 'Organizer' higher than version 1.10 (just won't start up).

I have no idea why this should be!

Anyone else have similar problem?

Thanks

Alastair

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

usually there should be some error message in the Windows Events log as to why the program is failing.

Maybe something broke your Microsoft .Net installation (4.6.2 is required) or your AntiVirus is blocking the other versions?

Best regards

Share this post


Link to post
Share on other sites

Hi Oliver

Thanks for the reply.

Yes, I appear to have the latest version of .Net (earlier versions of Organizer run ok.)

Here is a summary of event viewer. (I hope it makes sense to you.

Faulting application name: P3DV4AddonOrganizer.exe, version: 0.95.0.0, time stamp: 0x5a2043a1
Faulting module name: KERNELBASE.dll, version: 10.0.16299.15, time stamp: 0x4736733c
Exception code: 0xe0434352
Fault offset: 0x0000000000013fb8
Faulting process id: 0x2260
Faulting application start time: 0x01d374ce63139d44
Faulting application path: G:\Users\Alastair\Documents\Prepar3D v4 Add-ons\Lorby-SI AddonOrganizer_P3D_V4\P3DV4AddonOrganizer.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 48afc357-8a1c-4f83-8dee-60c424d607fc
Faulting package full name: 
Faulting package-relative application ID: 

Also

 

Application: P3DV4AddonOrganizer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Xml.XmlException
   at System.Xml.XmlTextReaderImpl.Throw(System.Exception)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlReader.MoveToContent()
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderSceneryGroupDatabase.Read5_SceneryGroupDatabase()

Exception Info: System.InvalidOperationException
   at System.Xml.Serialization.XmlSerializer.Deserialize(System.Xml.XmlReader, System.String, System.Xml.Serialization.XmlDeserializationEvents)
   at System.Xml.Serialization.XmlSerializer.Deserialize(System.IO.TextReader)
   at P3DV4AddonOrganizer.Definitions.ReadXML()
   at P3DV4AddonOrganizer.MainDialog..ctor()
   at P3DV4AddonOrganizer.MainDialog.get_Instance()
   at P3DV4AddonOrganizer.Program.Main()

Thanks again

Alastair

Share this post


Link to post
Share on other sites

Hi,

this looks like your scenery group database is broken.

Look for this file:

C:\Users\...\AppData\Local\LORBY_SI\P4AO\P4AO_Scenery_Groups.xml

and send it to me via email. I am pretty sure that there is an invalid tag in there, cause by a weird scenery name.

If you don't mind losing the grouping infomation, you can just rename or delete that file, then the app should be working again.

Best regards

Share this post


Link to post
Share on other sites

Hi Oliver

There was another folder within AppData\Local\....    namely Lorbi-Si\ with subfolders.

I deleted  that folder.....   and all is well.:biggrin:

Since running 'Organizer' I see that a new folder "Lorbi-Si" has been created.

The other folder that you mentioned "LORBI_SI" had a "Scenery_Groups.xml" file, but it was 'empty'

Thanks again for your help.

Alastair

 

Share this post


Link to post
Share on other sites

Hi,

the other "folder" is created by the .Net framework automatically to store the local settings of the app. These settings have changed over time, and it is entirely possible that an old config would trip up the program. Strange though that a problem there should result in the error message that you saw - ??? But at least you got it working again.

Best regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now