Polymerman

Updated to 3.4 And cant save cfg error 5

Recommended Posts

I received this error when trying to apply settings in fsx.cfg:

"Cannt create backupo of fsx.cfg. (0)

System Error was 5 "

I reinstalled new version 3.4 and must have made some error.  

The correct folder for the cfg file is shown in the app.  I tried uninstalling and reinstalling texture to no avail.

Any help is appreciated in fixing this.

Thanks.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sorry to hear that.  Error code 5 is windows reporting no permission.  

The fsx.cfg editor dialog tries to copy fsx.cfg to fsx.cfg.backup  before applying the updates that you have made.   It is this copy that is failing - there are several possibilities for this in no particular order:

The problem is either to do with permissions to an existing  backup file or permission to update the directory

Possible causes:

1)  there are some odd permissions against the fsx.cfg.backup file - delete the  existing one and try again

2)  Fsx has been reinstalled and windows has created the appdata fsx directory containing fsx.cfg with different permissions - running the controller as administrator just to edit fsx.cfg might get around this.

3) You normally run fsx as administrator and the files in the appdata directory are owned by your admin user - running dx10 controller  - running the controller as administrator just to edit fsx.cfg might get around this

4)  Antivirus preventing the controller from updating the directory.  Perhaps 3.3 was installed before the latest AV version and so was left alone so to speak?  If this is the case you need to add an exclusion for the Dx10 controller in the AV

So I would suggest

a) delete the existing backup if there is one and try again.

b) try running the controller as administrator

c) fiddle with AV

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Wow! Great customer service.  Thanks for the quick reply.  Deleting the existing backup did the trick.

Thanks again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now