Sign in to follow this  
Daedalus

Flysimware L35A strobe lights

Recommended Posts

Hi all,

I just bought the Flysimware L35A along with the Lear35 Immersion from FSFX packages. While everything loads fine in P3Dv4.1, I get a weird problem where the strobe lights reflect on the cockpit, something very unpleasant to look at. 

I also get this on the default F22, but not in other payware airplanes. Anyone maybe knows how this can be solved? I would be really pleased to know..

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

2 hours ago, Daedalus said:

Hi all,

I just bought the Flysimware L35A along with the Lear35 Immersion from FSFX packages. While everything loads fine in P3Dv4.1, I get a weird problem where the strobe lights reflect on the cockpit, something very unpleasant to look at. 

I also get this on the default F22, but not in other payware airplanes. Anyone maybe knows how this can be solved? I would be really pleased to know..

Are you using my freeware? If you are it is because these planes are using the default strobe effects and my effects have taken over.

The F22 cannot be corrected but perhaps the lear35 can.

If you post the lights section inside the Aircraft.cfg of the Lear35 I can help you to see what we can do.

Simbol 

  • Upvote 1

Share this post


Link to post
6 minutes ago, Daedalus said:

Hi Simbol,

Yes, this passed through my mind..It should be it. I use your freeware lights for AI, its great! :)

I'd be very glad if you could help me.

Here is my aircraft.cfg:

https://1drv.ms/u/s!AuObjEUAoTSTgfhWVR_PaE25Y-D1pA

 

Ok,

I am out now without access to my PC but you should hear from me in a couple of hours with suggestions or a solution.

Simbol 

  • Upvote 1

Share this post


Link to post
Just now, simbol said:

Ok,

I am out now without access to my PC but you should hear from me in a couple of hours with suggestions or a solution.

Simbol 

Thank you very much Simbol. No rush at all. I'll be looking forward :) 

Share this post


Link to post
1 hour ago, Daedalus said:

Thank you very much Simbol. No rush at all. I'll be looking forward :) 

Daedalus,

Unfortunately I have bad news, this plane didn't declare any strobe effects on the Aircraft config file:

[LIGHTS]
//Types: 1=beacon, 2=strobe, 3=navigation, 4=cockpit, 5=landing, 6=taxi, 7=recognition, 8=wing, 9=logo, 10=cabin       

light.1 = 10,  10.80,  0.00,  1.4, fx_vclight
light.2 = 10,  6.80,  0.00,  1.4, fx_vclight
light.3 = 10,  3.00,  0.00,  1.4, fx_vclight
light.4 = 8,  -1.00,  0.00,  1.4, fx_vclight
light.5 = 9,  11.70,  -3.70,  -0.9, fx_vclight

light.6 = 1,  0.0,  0.0,  0.0, fx_NONE
light.7 = 2,  0.0,  0.0,  0.0, fx_NONE
light.8 = 3,  0.0,  0.0,  0.0, fx_NONE
light.9 = 4,  0.0,  0.0,  0.0, fx_NONE

//(Disabled by FSFX_L35_Effect)light.10 = 5, -0.00,   3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.11 = 5, -0.00,  -3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.12 = 6, -0.00,   3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.13 = 6, -0.00,  -3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.14 = 7,  6.00,   17.80,  0.4, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.15 = 7,  6.00,  -17.80,  0.4, fx_landing_3D_FSW

This means the developer embedded the effects inside the aircraft model using the default system effects names instead of developing it own effects af most aircraft developers do.

You have the following options:

1) Disable my freeware to restore the default system effects, the downside is this will affect all your AI traffic lights.

2) Contact the original developer to see if he/she is willing to recompile the aircraft model with different attached effects names as most payware developers do.

3) HEX edit the Aircraft model to alter the strobe effect name to bypass the problem.

If you wish help with option 3, contact me privately.

Best Regards,
Simbol

  • Upvote 1

Share this post


Link to post
41 minutes ago, simbol said:

Daedalus,

Unfortunately I have bad news, this plane didn't declare any strobe effects on the Aircraft config file:

[LIGHTS]
//Types: 1=beacon, 2=strobe, 3=navigation, 4=cockpit, 5=landing, 6=taxi, 7=recognition, 8=wing, 9=logo, 10=cabin       

light.1 = 10,  10.80,  0.00,  1.4, fx_vclight
light.2 = 10,  6.80,  0.00,  1.4, fx_vclight
light.3 = 10,  3.00,  0.00,  1.4, fx_vclight
light.4 = 8,  -1.00,  0.00,  1.4, fx_vclight
light.5 = 9,  11.70,  -3.70,  -0.9, fx_vclight

light.6 = 1,  0.0,  0.0,  0.0, fx_NONE
light.7 = 2,  0.0,  0.0,  0.0, fx_NONE
light.8 = 3,  0.0,  0.0,  0.0, fx_NONE
light.9 = 4,  0.0,  0.0,  0.0, fx_NONE

//(Disabled by FSFX_L35_Effect)light.10 = 5, -0.00,   3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.11 = 5, -0.00,  -3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.12 = 6, -0.00,   3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.13 = 6, -0.00,  -3.95,  -1.2, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.14 = 7,  6.00,   17.80,  0.4, fx_landing_3D_FSW
//(Disabled by FSFX_L35_Effect)light.15 = 7,  6.00,  -17.80,  0.4, fx_landing_3D_FSW

This means the developer embedded the effects inside the aircraft model using the default system effects names instead of developing it own effects af most aircraft developers do.

You have the following options:

1) Disable my freeware to restore the default system effects, the downside is this will affect all your AI traffic lights.

2) Contact the original developer to see if he/she is willing to recompile the aircraft model with different attached effects names as most payware developers do.

3) HEX edit the Aircraft model to alter the strobe effect name to bypass the problem.

If you wish help with option 3, contact me privately.

Best Regards,
Simbol

 

Thank you very much for the reply Simbol. I think I'll choose option 1) and at the same time contact the developer to ask if his is willing to find a solution for this issue. However, I now face another problem. When I originally installed your AI lights reborn freeware, I mistakenly copy-pasted the files to my P3D directory, and as a result I believe my original default lights has been lost? Is there any way to restore the original P3D v4.1 lights? :/ 

Share this post


Link to post
1 minute ago, Daedalus said:

 

Thank you very much for the reply Simbol. I think I'll choose option 1) and at the same time contact the developer to ask if his is willing to find a solution for this issue. However, I now face another problem. When I originally installed your AI lights reborn freeware, I mistakenly copy-pasted the files to my P3D directory, and as a result I believe my original default lights has been lost? Is there any way to restore the original P3D v4.1 lights? :/ 

I have been warning people about such things, what is the point asking developers to create proper instalation files to them override it?

Sigh.. Send me your email privately and I will email you the default effects.

If you use my instalation file it uses the Add-on xml method and you can disable my effects temporally via the PD3V4 add-on menu without uninstalling them, so you could disable them, fly your lear and re-enable the effects when you fly another plane.

I can also do option 3 for you if you get a negative from the developer, it takes 5 seconds.

Simbol 

  • Upvote 1

Share this post


Link to post
Just now, simbol said:

I have been warning people about such things, what is the point asking developers to create proper instalation files to them override it?

Sigh.. Send me your email privately and I will email you the default effects.

If you use my instalation file it uses the Add-on xml method and you can disable my effects temporally via the PD3V4 add-on menu without uninstalling them, so you could disable them, fly your lear and re-enable the effects when you fly another plane.

I can also do option 3 for you if you get a negative from the developer, it takes 5 seconds.

Simbol 

Dear Simbol,

First of all again thank you very much for your amazing support. I should have missed the readme file when I installed your amazing freeware. Because right after I realised what I done I installed it correctly as an add-on.xml but the override was already done...mea culpa. All my fault.

Thank you very much for the offer. I will send you my email and I will do as you suggested. Disable the effects when flying the L35A. I'll send to the developer and let you know if I get a negative answer in order to implement your option 3.

Again, thank you for your amazing support.

Share this post


Link to post

Dear Simbol,

Thank you so much again. It works perfect now :) I'm quoting again your last message for the rest of the users:

8 minutes ago, simbol said:

To the rest of users reading this and that use my freeware please be aware you don't need to override your default effects, please leave them intact, for more information please read this: https://www.avsim.com/forums/topic/525971-installation-procedures-ai-lights-reborn/

Best Regards,
Simbol

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this