Sign in to follow this  
Robinf

Screen change affecting FPS? (Resolved)

Recommended Posts

4770K @ 4.2Ghz with GTX 1080 and 32GB Ram. (P3D V4)

 

Guys, I replaced my 24" monitor with a 43" 4K TV. After the change, my FPS dropped from 50 to about 20. I then changed my GTX970 to a GTX1080 thinking this was the issue. FPS increased slightly (Now at about 25fps). This is ok and I can live with it, but has anyone else got any ideas? Is it my processor that is not coping with the bigger screen or is there a setting I can change? I have dialed back my sliders and not much changed. Yes, I get brilliant imagery, but at a cost. I tried to fix this myself, but no matter what I do, I am stuck at 15-30fps. The TV is running at 60Hz. Am I missing something here or is this something i have to live with?

 

(I use PMDG B777 and B737, AS16, Immersion, REX, PTA - some add-on scenery, however Aerosoft EDDF kills my FPS to 10)

 

Thanks in advance

Robin

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I dropped the shadows and that has helped a lot. Now fluctuating 30-60FPS. Question still stands, is there any way with my setup that I can get similar FPS on the bigger screen with the same settings?

 

Share this post


Link to post

1080p vs 4k, your card now has to produce 4x as many pixels per frame

Share this post


Link to post
9 minutes ago, kcgb said:

1080p vs 4k, your card now has to produce 4x as many pixels per frame

Thanks for the reply.

 

GTX970 (4GB) on 24" monitor was 50FPS.

GTX 1080 (8GB) on 43" TV @ 4k is just over 20FPS.

 

Doubled the VRAM, but lost more than half my FPS in the move to the 4K TV. This is such an awesome sim and I know I will find a workable solution, just keen to hear if anyone else has been on this path before.

 

Share this post


Link to post

Drop the tv to 30hz in the NCP and watch how smooth it gets. Also make sure your set to maximum power in the performance option in NCP.

Share this post


Link to post
5 minutes ago, Wise87 said:

Drop the tv to 30hz in the NCP and watch how smooth it gets. Also make sure your set to maximum power in the performance option in NCP.

Thank you Dan, apologies for my noobiness, what is NCP stand for? (Nvidia Control Panel?)

Share this post


Link to post
5 minutes ago, Robinf said:

Thank you Dan, apologies for my noobiness, what is NCP stand for? (Nvidia Control Panel?)

Yes, also search 30hz in the forums. Plenty of topics on the subject.

  • Upvote 1

Share this post


Link to post
3 minutes ago, Wise87 said:

Yes, also search 30hz in the forums. Plenty of topics on the subject.

Will do the search now. Thank you for the help, it has made an improvement.

Share this post


Link to post

In P3D make sure your set to Unlimited FPS, Tripple Buffering Checked, and vsynch enable.

Share this post


Link to post
7 minutes ago, Wise87 said:

In P3D make sure your set to Unlimited FPS, Tripple Buffering Checked, and vsynch enable.

Thanks Dan, already had this running like you said.

Share this post


Link to post

Marking this as resolved. Thanks for the help!

 

What I did:

 

1) Disabled shadows for the time being - will slowly introduce them after some more testing.

2) Changed to 30Hz

3) Unlimited FPS in P3D (although from what I see, Rob indicated that this need only be 30FPS due to 30Hz)

4) As per Dan, set max power in NCP

5) VSync and Triple Buffering both ON.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this