Captaiwolf2002

Pilot2ATC Interface Window

Recommended Posts

I just installed the program last night, and I already have my first question:

When Pilot to ATC is open, it takes up a lot of the screen. It also seems to disable certain functions on my keyboard. When it is open, I cannot use keyboard shortcut keys like "c" for free view and "b" for brakes. When I minimize Pilot2ATC, these functions work again.

How do you manage this? Is there a shortcut to min / max the screen or disable / enable ATC on the fly? Do you keep the program screen open through the whole flight?

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Check page 119 of the User's Guide for the Minimize Button/HotKey settings.

ATC will continue working with the program minimized.

A lot of single screen users will size the P2A screen to just fit the Flight Plan Window.  Then toggle the FPL button to toggle between the map and the flight plan.

Dave

  • Upvote 1

Share this post


Link to post
Share on other sites

I mapped minimize (to taskbar) to my joystick.  When I hit the assigned button, P2A minimized, but now I can't find the program on the taskbar or anywhere else.  When I try to relaunch it, it said I couldn't because another instance was already opened and it needed to be closed.  How do I reopen it now?

Share this post


Link to post
Share on other sites

Also, my main issue is that I cannot use my keyboard commands with your app running.  

 

1) When I hit the normal window minimize button, I regain control of my keyboard commands.

2) When I use the down arrow (I guess that's the minimize button in your app), this does not help--still not control.

3) Resizing the window does not give me back control of my keyboard commands either.

Share this post


Link to post
Share on other sites
Posted (edited)

That is likely because the SIM does not have focus when you are working with Pilot2ATC.  P2A does not do anything to override other program's hot keys.

If you are minimizing to Task Bar, be sure to Uncheck the Hot Key Setting to Require P2A or SIM Focus.  That should allow the hot key to bring P2A back after it is minimized.

 

Edited by Dave-Pilot2ATC

Share this post


Link to post
Share on other sites

That box ix s unchecked by default, so it was never checked.

Plus, the hot keys do not work on my keyboard when your app is open.  I'm not having this problem when minimized.  Your last reply does not even address this issue.

Share this post


Link to post
Share on other sites
1 hour ago, Dave-Pilot2ATC said:

That is likely because the SIM does not have focus when you are working with Pilot2ATC.  P2A does not do anything to override other program's hot keys.

The above part of my reply was referring to the problem of the hot keys not working. 

What SIM are you using?  Any other programs running when P2A and the SIM are running? 

If the key that you mapped in P2A to minimize/maximize the program is in use by another program, then that would also explain why it won't work when P2A is minimized.  The other program is capturing it.

Share this post


Link to post
Share on other sites

Again, my hot keys do not work when your app is open You keep giving me instructions on how to get the hotkeys to work when P2A is minimized which is not what I am asking.  To be clear...

a) When your window is open (P2A) = none of my hotkeys work on my computer

b) When I minimize this your P2A window (push the button with the horizontal line in the top right corner of the P2A window) = everything in the sim works again.

Naturally, I would like to be able to leave P2A open in the corner of my screen and still have control of the plane.

It is XP-11 and Windows 10.

I'm sorry to be a pain.  I'm really trying to get this to work.  

 

Share this post


Link to post
Share on other sites

I understood you had 2 issues,

1) Your SIM hotkeys don't work when you have P2A showing

2) When you minimize P2A using the P2A Minimize HotKey, you cannot get it to open again by pressing the Hot Key.

On #1, You must give X-Plane the focus (click on X-Plane) for its hot keys to work.  That is an X-Plane limitation.  I have just tested 2 or three of my X-Plane 11.20 hot keys and they all work when X-Plane has the focus and do not work when any other program, including the browser I working on now, has the focus.  That is to prevent a multitasker from accidentally pressing a bunch of Hot Keys while flying the SIM. 

2121  I just tried to raise and lower my flaps and it typed here instead.  Clicked on X-Plane and hit the same keys and the flaps worked.

Hope that helps.

Dave

Share this post


Link to post
Share on other sites

Dave, thank you.  We are getting very near a final answer.  Your answer makes sense too, but it leads to the next two questions:

 

3) after I "give x plane focus" by clicking on the screen, is there an easy way to bring the P2A window back up again?  I find hitting the windows key to bring up the taskbar and then mouse clicking your P2A in the taskbar the bring the P2A window back to be too intrusive during flight.  

4) This also means that resizing the P2A screen and leaving it open in the corner somewhere is not really an option with XP--11 because I would have to give focus to XP - 11 and thus lose the ability to see your Interface in the process?

Share this post


Link to post
Share on other sites

and also 5) This would be tough with a clickable cockpit, wouldn't it?  Every time you clicked on an instrument, one would lose his or her P2A window?  I'm not complaining--I'm trying to figure out what's going on here?

Share this post


Link to post
Share on other sites

In XP11.20 it appears that the "On Top" mode of P2A does not work in a single screen environment.  I have no idea why that would be.  I tested with using XP11 in Multi-screen mode and it does work just fine.

Assuming you only have one screen, then the easiest way to "toggle" P2A is going to be using  the "Alt-Tab" key combination to bring it back after you click on X-Plane.  If you have more than one screen, then it should work like it used to.  This is not something that I can fix with P2A.  It seems something may have changed in XP 11.20 that prevents normal Windows interactions.

Dave

Share this post


Link to post
Share on other sites
Posted (edited)

Ahh, wait a minute.

Now in XP11.20 you can select Windowed Simulator Mode in the Main monitor....just like back in XP10 days.  So if you only have 1 monitor, run XPlane in WIndowed Mode and the OnTop function will work correctly, as will the P2A hot keys.

Dave

Edited by Dave-Pilot2ATC

Share this post


Link to post
Share on other sites

This looks like it completely solved all four issues all at once.  I can now use the software as intended.  I think I'll try that San Jose to Oakland Flight you wrote about.  If I have any more questions, I'll start a new thread.  Thanks for the help. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now