Sign in to follow this  
Shinx13

Peformance + Stutter Since V4.2 - Onward

Recommended Posts

Hello Everyone,

I would like to know if anyone has been suffering performance drop and stutter in the latest versions of P3D. I get FPS around 20-29 and stutter when I move the camera. It's something that I've never seen before because in V4.1 I got 60fps no matter what. I would like to know if anyone has this issue and if there's any preferred settings for my simulator? Thanks and any advice would be appreciated!

System:
I7-7700k 4.8ghz
GTX1080FTW2
16GB DDR4 RAM
SSD + SDHD + HD

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

6 hours ago, Shinx13 said:

Hello Everyone,

I would like to know if anyone has been suffering performance drop and stutter in the latest versions of P3D. I get FPS around 20-29 and stutter when I move the camera. It's something that I've never seen before because in V4.1 I got 60fps no matter what. I would like to know if anyone has this issue and if there's any preferred settings for my simulator? Thanks and any advice would be appreciated!

System:
I7-7700k 4.8ghz
GTX1080FTW2
16GB DDR4 RAM
SSD + SDHD + HD

With the latest new version had very bad stutters and my FPS was about 60-90 without any cfg tweaks..After my nerves were broken trying to find a solution to my problem ,I redownloaded the old GPU graphic driver 397.64 ,and the NVI limiter and P3D v4.3 and the problems were gone,now works very well, with ZERO STUTTERS...

My System:

I7-6700K 4.00 GHz

EVGA GeForce GTX 1060 Superclocked 6GB GDDR5

8GB DDR4 RAM

HDD 

Share this post


Link to post
6 hours ago, Shinx13 said:

Hello Everyone,

I would like to know if anyone has been suffering performance drop and stutter in the latest versions of P3D. I get FPS around 20-29 and stutter when I move the camera. It's something that I've never seen before because in V4.1 I got 60fps no matter what. I would like to know if anyone has this issue and if there's any preferred settings for my simulator? Thanks and any advice would be appreciated!

System:
I7-7700k 4.8ghz
GTX1080FTW2
16GB DDR4 RAM
SSD + SDHD + HD

 

What is your monitor's refresh rate?  Is it fixed at 60 mhz by chance?

Share this post


Link to post
2 hours ago, Mace said:

 

What is your monitor's refresh rate?  Is it fixed at 60 mhz by chance?

Its 60mhz 1080p.

Share this post


Link to post
2 hours ago, georgio1952 said:

With the latest new version had very bad stutters and my FPS was about 60-90 without any cfg tweaks..After my nerves were broken trying to find a solution to my problem ,I redownloaded the old GPU graphic driver 397.64 ,and the NVI limiter and P3D v4.3 and the problems were gone,now works very well, with ZERO STUTTERS...

My System:

I7-6700K 4.00 GHz

EVGA GeForce GTX 1060 Superclocked 6GB GDDR5

8GB DDR4 RAM

HDD 

What is NVI limiter? Nvidia Inspector? If so, what are your settings in there?

Share this post


Link to post
On 7/4/2018 at 5:46 PM, Shinx13 said:

Its 60mhz 1080p.


Ok, in that case this may help you -- and this is an old trick, but it has worked for me again with P3D in 2018.   On my rig, my monitor is fixed at 60 mhz with no possibility to change it to 30 mhz.   I had really high fps, but long frames/stutters using unlimited/vsync.  A lot of variability in frames.  And if I locked frames in the sim, it was still stuttering, just at the lower locked framerate.

With P3D I am normally not a fan of overtweaking using nvidia inspector, BUT in this case I did use two settings in it -- the driver-level vsync at 1/2 the refresh rate, and locking frames to 31 fps.

The result on my 60 mhz screen is wonderful.  I never thought 30 fps could be so fluid.  And with my rig overclocked at 5 ghz, the system can pretty much maintain that 30 fps even in FS-world-hellish conditions (London, New York, or Tokyo metros with add-on airports, AI, and weather). 

This may be counter to what many with G-sync or 4K at 30 mhz or similar setups need to do -- but it worked like a charm with my setup.

  • Like 1

Share this post


Link to post
16 hours ago, Mace said:


Ok, in that case this may help you -- and this is an old trick, but it has worked for me again with P3D in 2018.   On my rig, my monitor is fixed at 60 mhz with no possibility to change it to 30 mhz.   I had really high fps, but long frames/stutters using unlimited/vsync.  A lot of variability in frames.  And if I locked frames in the sim, it was still stuttering, just at the lower locked framerate.

With P3D I am normally not a fan of overtweaking using nvidia inspector, BUT in this case I did use two settings in it -- the driver-level vsync at 1/2 the refresh rate, and locking frames to 31 fps.

The result on my 60 mhz screen is wonderful.  I never thought 30 fps could be so fluid.  And with my rig overclocked at 5 ghz, the system can pretty much maintain that 30 fps even in FS-world-hellish conditions (London, New York, or Tokyo metros with add-on airports, AI, and weather). 

This may be counter to what many with G-sync or 4K at 30 mhz or similar setups need to do -- but it worked like a charm with my setup.

Thanks for the advice! I actually went to reinstall the entire sim and addons and I am getting much better frames now! I will try what you suggested, thank you!!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this