approxdec

no keyboard input in gns 530

Recommended Posts

gday all.

i have lost keyboard input for waypoints, flightplans, procedures

[rather than using the click-knobs]

it has been working fine for ages and suddenly bam! not working.

now i must use the mouse with the click-knobs.

does anyone no anything about this problem? it is not a Mindstar issue i don't think.

does anyone have any clues?

thanks

joe

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I am willing to bet you installed an addon that modifies your dll.xml file and it has killed HyperGauge.

Share this post


Link to post
Posted (edited)

thank you Ed.

the problem persists.

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">

  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>

  <Launch.Addon>
    <Name>ObjectFlow.dll</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>C:\Microsoft Flight Simulator X\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery\ObjectFlow.dll</Path>
  </Launch.Addon>

  <Launch.Addon>
    <Name>Reality XP GNS WAAS Hardware</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\rxpGnsDriver.dll</Path>
  </Launch.Addon>

  <Launch.Addon>
    <Name>CMeteoXml</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>.\CMeteoXml.dll</Path>
  </Launch.Addon>

  <Launch.Addon>
    <Name>Mindstar Hypergauge</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>C:\Microsoft Flight Simulator X\Modules\HyperGauge.dll</Path>
  </Launch.Addon>

  <Launch.Addon>
    <Name>Navigraph Simlink</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Gauges\NavigraphSimlink.dll</Path>
  </Launch.Addon>

  <Launch.Addon>
    <Name>FSUIPC 4</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\FSUIPC4.dll</Path>
  </Launch.Addon>

  <Launch.Addon>
    <Name>HttpX</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\HttpX.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>

  <Launch.Addon>
    <Name>XMLTools</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>XMLTools.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>

</SimBase.Document>

 

HyperGauge.dll is in the /Modules folder.

i have reinstalled Mindstar - which finished okay.

everything else seems to be working fine except for this keyboard input issue.

to be clear, when i type a 'Y' for example in the location field for a procedure

FSX goes into 'Skew' mode.

thanks

joe

Edited by WarpD
fixed formatting

Share this post


Link to post

Have you had all of these other addons installed with our GNS and been able to use the keyboard?

Share this post


Link to post
Posted (edited)

 it does look a bit of a mess especially since I am not using FSUIPC 4 .

Nothing is recently new as far as I know.

 I would be happy with a clean dll.xml file for Mindstar with the objectflow and orbx entry.

I can reinstall anything else if needed.

Thanks

Joe

Edited by approxdec
more info

Share this post


Link to post

Can you tell me the name of the GNS setup executable you downloaded from our web site?  It should have some numbers in the name, that's what I'm looking for.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now