Sign in to follow this  
AviatorMan

UK2000 Belfast City

Recommended Posts

Does anyone know if UK2000's Belfast City released earlier this  year is P3Dv4 compatible? There are astericks on the UK2000 website where it says "P3D Compatible" but I am not able to find an explanation on the website if it is V4 Compatible.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Yes, it is P3D v4 compatible. The latest versions of all UK2000 Xtreme airports work in P3D v4.

Edited by Christopher Low

Share this post


Link to post
21 hours ago, Christopher Low said:

Yes, it is P3D v4 compatible. The latest versions of all UK2000 Xtreme airports work in P3D v4.

Thanks Christopher, I will go ahead and add Belfast City to my UK2000 airports.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this