KL Oo

Help with Sky Texture / Color Banding

Recommended Posts

Hi Avsim,

 

I've done a bit of reading about this issue but can't find a thread that appears relevant to my circumstances or is recent. I've recently reinstalled P3D 4.3 on my new rig (details below). The only addons I'm using at this time are a couple of scenery's and Active Sky for P3D & ASCA.

 

As you can see in these images, I'm getting texture banding (for want of a better word) in the sky. All other textures look amazing, but the sky is pretty poor. It doesn't show that well in these photos because they're compressed but on the screen you can see a lot of individual colours bands in the sky. I've tried changing the sky textures with ASCA to no avail (makes no difference), neither does the time of day. I've deleted shaders but haven't tried any other textures. You can't seem to adjust texture size or quality for AS SKY textures (as opposed to cloud textures). 

T2WIwpT.jpg

 

My 2080 TI is connected to my TV via HDMI 2.0 (I've also tried a DisplayPort 1.4>HDMI without any success) and the TV is set to run in Full HDMI mode. NVIDIA Settings are set at 32bit, RGB and Full for output dynamic range (TV likewise) with refresh rate of 60HZ. At 60HZ I cannot change the BPC from 8 to 10 or 12.

S4O2X5D.jpg

If I do adjust refresh rate down to 30 HZ then I can use 12BPC for the output color depth. This does improve the banding somewhat but I don't ever recall having to do that with my previous build, and certainly didn't notice the banding on my previous rig either. 

2BXWmlh.jpg

I guess my question is, has anybody got any experience with this and know what else I might be able to try? Do you guys running 4K on TVs all use 8 BPC for Output Color depth or are you using 10 or 12? Any advice or hints would be much appreciated. I'd love to be able to get 60HZ with 10BPC but I don't think the TV will pull it off.

 

Cheers,

 

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Actually this should have been in the monitors/video card sub forum. Sorry mods, pls move

Share this post


Link to post
Share on other sites
10 hours ago, KL Oo said:

Do you guys running 4K on TVs all use 8 BPC for Output Color depth or are you using 10 or 12?

None of the flight-sim platforms I've used support 10 or 12 bit color, they're all 8 bit (XP11, P3D, AF2, etc.).

Do you see the problem with default sky textures?  I have seen this issue before and it was related to 3rd party sky textures ... so this probably does belong in the P3D forum as I don't think what you're seeing is hardware related.

EDIT: could also be a result of 3rd party shaders (ENVSHADE, PTA, etc.) ... also noted you're aircraft is "dull" which suggest changes to color saturation, and brightness and/or bloom values.

Cheers, Rob.

Share this post


Link to post
Share on other sites

Thanks Rob,

 

To be honest, I’ve had ASCA running from the word go so I’ll have I remove it and check to see if removing it’s sky textures has an effect on the banding. I don’t recall their being an uninstall option but I’ll have a look when I get home tonight.

 

i don’t use any shader mods and have deleted and regenerated the shaders folder multiple times in troubleshooting this issue. Aside from AS and ASCA and FTX Global this is a vanilla P3D.

 

anybody else see or seen what I’m seeing?

Share this post


Link to post
Share on other sites
9 minutes ago, KL Oo said:

i don’t use any shader mods and have deleted and regenerated the shaders folder multiple times

Shader products "could" modify and/or replace their own shader code which might trigger this, but my money is on sky textures used ... also, have you verified that you've got 32bit selected in sim (where you select your resolution)?

Cheers, Rob.

Share this post


Link to post
Share on other sites

I've been torturing myself with this since day one on P3D a couple of years ago, and my opinion is that some sky textures do better than others with respect to banding-- especially during dawn and dusk.  I've tried calibrating my monitor, tweaking shaders, changing resolution and playing with Nvidia settings ad-naseum, and still had problems.  For example, I've used textures from Envtex and Rex, as well as Google Earth along with other ones that came my way from various users, and the vast majority of them had this problem.  I can't even tell you, aside from the default textures, and if I recall, also produce some banding, it is just the way it is. 

The trick is to find textures through trial and error that produce the bands that are the least-noticeable.  If anyone has any other ideas, or a magic-bullet that would solve this problem, I'm open to suggestions, but I just think this is just par for the course.  

Cheers,

John

Share this post


Link to post
Share on other sites

 

2 hours ago, Rob Ainscough said:

Shader products "could" modify and/or replace their own shader code which might trigger this, but my money is on sky textures used ... also, have you verified that you've got 32bit selected in sim (where you select your resolution)?

Cheers, Rob.

 

Thanks Rob,

Yes, 4Kx32. What’s interesting, presuming P3D is only 8 bpc, is why I see an improvement if I change the NVIDIA settings to 12 bpc. Ill try reverting to the default textures tonight and see if that helps. I’m not really tempted to try using other other non default textures if the default doesn’t work. Surely the default should produce the most ‘stable’ result?

 

1 hour ago, dal330200 said:

I've been torturing myself with this since day one on P3D a couple of years ago, and my opinion is that some sky textures do better than others with respect to banding-- especially during dawn and dusk.  I've tried calibrating my monitor, tweaking shaders, changing resolution and playing with Nvidia settings ad-naseum, and still had problems.  For example, I've used textures from Envtex and Rex, as well as Google Earth along with other ones that came my way from various users, and the vast majority of them had this problem.  I can't even tell you, aside from the default textures, and if I recall, also produce some banding, it is just the way it is. 

The trick is to find textures through trial and error that produce the bands that are the least-noticeable.  If anyone has any other ideas, or a magic-bullet that would solve this problem, I'm open to suggestions, but I just think this is just par for the course.  

Cheers,

John

 

Thanks John. I never noticed it on my previous build which used the same TV but a 1080 instead....so I’m not convinced it can’t be fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now