Cruachan

RA Lancair Legacy V2, Beech Duke Turbine V2, F1GTN, P3Dv4.4

Recommended Posts

Hi,

Anyone encountering similar problems?

RealAir

Lancair Legacy V2                  (F1GTN: 750=OK, 650=OK)          (All Load OK, otherwise problematic - P3D crashes when switching to another Legacy, Exits and Resets)

Beech Duke Turbine V2        (F1GTN: 750=OK, 650=OK)          (All Load OK, otherwise problematic - P3D crashes when switching to another Duke, Exits and Resets)

New Installers: (Note: using original new installer installations rather than reinstall again with new installers)

RASDukeTv2_FSX_P3D.exe (File version 2.10.21.0, File Size: 282,201 KB)

RASLegacyV2_FSX_P3D.exe (File Version 2.10.21.0, File Size: 227,400 KB)

F1GTN Updated:  F1GTN_Complete.exe (File version 9.5.1.0, File Size: 74,180 KB)

P3D4 Config Panel run and configured successfully for both aircraft.

Regards,

Mike

Edit: Experiencing similar issues with MilViz Beaver DHC2 and DHC3 (not using WX Radar option in either case)

Shame, really, they all worked great in v4.3

Perhaps v4.4 is just a step too far for these venerable a/c.....or is it?

Edited by Cruachan

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

UPDATE (1)

Well, that was easy!

I removed the F1GTN 750/650 from the MilViz Beaver DHC2 and DHC3 and, hey presto, I can, with gay abandon, now load, switch repeatedly, reset and exit without any crashes or instabilities!

Looks like my F1GTN Complete installation is implicated in this.

**For the time being I'll have to disable same in my Lancair Legacy V2 and Beech Duke Turbine V2 installs pending an update to the F1GTN modules.

Any comments? In view of the popularity of these aircraft, along with the Garmin F1GTN 750/650, I'm quite surprised others have not posted to relate their experiences.

Do I, in fact, have the latest version, I wonder, and is it fully compatible with Prepar3D v4.4? See previous post. It does seem to work albeit suggesting some simple incompatibility.

Mike

Edit: **Yep, removed F1GTN from Lancair Legacy V2 and Beech Duke Turbine V2 and all's well. Phew, that's a relief!

Edited by Cruachan

Share this post


Link to post

UPDATE (2)

From the Flight1 GTN for P3D V4.4 forum at SimForums:

Posted 4th December

"We have made the Flight1 GTN Complete compatible with P3D V4.4.
In order to make the gauges work with P3D V4.4, you must have the latest version of the GTN installed:
GTN Complete V2.07

Download the latest wrapped version 2.07 from the main sales page."

I see my version of GTN CONFIG P3D is V2.01 so, looks like I have some work to do. Problem arose because I had not registered the product. Consequently I was unable to see/access the relevant forum.

Hopefully, should be okay now.

Mike

Share this post


Link to post

Hi, Cruachan. I thought you had the new 2.07 since you stated the file version as 9.5.1.0. Apparently the file version didn't get changed, but, you should be good to go now.

Share this post


Link to post

Hi Jim,

Yes, there are some inconsistencies that make it hard to be certain about the likely outcome. Anyway, I’ve downloaded the latest F1 installer so we’ll see what happens later this evening when I get around to running it.

Regards,

Mike

Share this post


Link to post

GTN Complete V2.07 installed.

All good now!

Mike 😀

Share this post


Link to post

My fix is to either power off the GTN before loading another version of the plane or load on the ground when powered down.

Regards
bs

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now