Jump to content

Sign in to follow this  
BerndB

PF3 can`t "hear" my FO

Recommended Posts

i still have the issue, that the PF3 ATC seems not "hearing" my FO talking.

Everything else is working. If i ask the FO to request any information from ATC he start talking in the correct way, but PF3 don´t recognize the request from MCE. When i push the right hotkey manually via keyboard ATC answers with the appropriate instructions. Once ATC finished with the instructions the MCE FO read back the given instructions in the correct way, but again PF3 can´t "hear" him though i don´t get an "readback correct" from ATC. 

I´ve set the PF3_MCE.ini to active and "close caption mode" and "Display voice set ID" are unchecked in PF3.

Any idea what could be wrong would be very welcome.

reg.

Bernd


Bernd

P3D V4.5 -  PC spec: Intel i9-9900 overclocked 5 GHz, 16 GB RAM, GPU Nvidia RTX2080, M2 SSD, Jeehell FMGS on a dedicated Server, PF3 for ATC, MCE, GSX, EFB, AS+ASCA

Share this post


Link to post
Share on other sites
23 hours ago, BerndB said:

i still have the issue, that the PF3 ATC seems not "hearing" my FO talking.

Everything else is working. If i ask the FO to request any information from ATC he start talking in the correct way, but PF3 don´t recognize the request from MCE. When i push the right hotkey manually via keyboard ATC answers with the appropriate instructions. Once ATC finished with the instructions the MCE FO read back the given instructions in the correct way, but again PF3 can´t "hear" him though i don´t get an "readback correct" from ATC. 

I´ve set the PF3_MCE.ini to active and "close caption mode" and "Display voice set ID" are unchecked in PF3.

Any idea what could be wrong would be very welcome.

reg.

Bernd

I assume you aren't using some complicated (non alphanumeric) assignments for hotkeys

Can only think of possibly this being linked to a German setup.

FO is normally able to read "pf3.ini" to workout what hotkeys he needs to send.

You definitely need to set "pf3.exe" to run as admin so it can always update "pf3.ini" with latest changes to settings and hotkeys. Otherwise, you could end-up out of synch

Try to set regional settings to English US and see if it makes a difference.

Perhaps Ralf who might be on a German setup, can give you better advice.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, FS++ said:

I assume you aren't using some complicated (non alphanumeric) assignments for hotkeys

Can only think of possibly this being linked to a German setup.

FO is normally able to read "pf3.ini" to workout what hotkeys he needs to send.

You definitely need to set "pf3.exe" to run as admin so it can always update "pf3.ini" with latest changes to settings and hotkeys. Otherwise, you could end-up out of synch

Try to set regional settings to English US and see if it makes a difference.

Perhaps Ralf who might be on a German setup, can give you better advice.

Well, that´s what my guess was too. I´ve tested it already setting WIN 10 with following options:

- language US-eng, keyboard US-eng

- language German, keyboard US-eng

- language German, keyboard German

It doesn´t made any difference. But i have changed the "ROGER" hotkey in PF3 to ctrl+shift+\ (on a german kb it´s the key left to the 1). The other ones are the defaults of PF3. Now when i´am at the gate, asking my FO for delivery clearance he tunes COM1 to the correct freq, make the request but nothing heard from atc unless i hit manually the "0" hotkey. Then the atc gives the instructions and my FO read back and now atc confirms the read back was correct. So it seems that the roger hotkey is now used by MCE. I´am not sure but i think the numbers one to zero are at the same location on a german as on an english keyboard.

I just tested to assign a new hotkey to the default "zero" like STRG+0, because i hoped that MCE will take this change into account when reading the new setting from the PF3.ini, but this didn´t worked either. Still no reaction from atc as long as i haven´t hit the STRG+0 myself. That´s weird.

PF3, P3d and MCE are all run as administrator of course. 

So the question for me is, why is MCE sending the Roger-key correctly but can´s sent the others like "0", "STRG+0" or "6" (for takeoff req.)??

Edited by BerndB
added information

Bernd

P3D V4.5 -  PC spec: Intel i9-9900 overclocked 5 GHz, 16 GB RAM, GPU Nvidia RTX2080, M2 SSD, Jeehell FMGS on a dedicated Server, PF3 for ATC, MCE, GSX, EFB, AS+ASCA

Share this post


Link to post
Share on other sites

below are the actual hotkeys set in my PF3.ini. Don´t know what the numbers tell but may be it helps to see an issue

[HotKeys]
Hotkey1=2048
Hotkey2=2049
Hotkey3=0050
Hotkey4=0051
Hotkey5=0052
Hotkey6=0053
Hotkey7=2054
Hotkey8=0055
Hotkey9=0056
Hotkey10=0057
Hotkey11=3220
Hotkey12=3069
Hotkey13=3187
Hotkey14=3087
Hotkey15=3086
Hotkey16=3067
Hotkey17=3089
Hotkey18=3078
HotKey19=3068
HotKey20=0072
HotKey21=0076
HotKey22=0027


Bernd

P3D V4.5 -  PC spec: Intel i9-9900 overclocked 5 GHz, 16 GB RAM, GPU Nvidia RTX2080, M2 SSD, Jeehell FMGS on a dedicated Server, PF3 for ATC, MCE, GSX, EFB, AS+ASCA

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/3/2019 at 4:26 PM, FS++ said:

Try to set regional settings to English US and see if it makes a difference.

Perhaps Ralf who might be on a German setup, can give you better advice.

No problems with a German setup here.

Problem must be something else.

Maybe the number keys are already assigned to another function (cameras, controls, maybe another addon), conflicting with MCE sending them?

 

Edited by RALF9636

ocs-beta-test.gif

MCE_forum_banner.jpg

FSL A319 / A320

Share this post


Link to post
Share on other sites
3 hours ago, RALF9636 said:

No problems with a German setup here.

Problem must be something else.

Maybe the number keys are already assigned to another function (cameras, controls, maybe another addon), conflicting with MCE sending them?

 

i´ve tested to change the PF3 hotkeys again. Now for the default 1 to 0 numbers i changed them to my F-keys (F1, F2, etc.). It seems MCE took these changes into account by read the new settings from the ini-file and this setup works perfectly. PF3 now hears my FO doing the initial check-in and so on. But if i change the keys back to defaults (1, 2,....0) they will not work.

In case of a conflicting issue is the case, could it be that the keys are in conflict with the GSX-app. Because GSX use the number keys for their services aswell?!

reg.


Bernd

P3D V4.5 -  PC spec: Intel i9-9900 overclocked 5 GHz, 16 GB RAM, GPU Nvidia RTX2080, M2 SSD, Jeehell FMGS on a dedicated Server, PF3 for ATC, MCE, GSX, EFB, AS+ASCA

Share this post


Link to post
Share on other sites

I did some other testflights today and now my FO works great together with PF3. I´am really happy about this great apps (both) because they just perform an immersive experience.

It seems that changing the default hotkeys of PF3 away from the numbers 1 to 0 made the trick in case you use GSX as well. 

So there is only the little issue with the readback by the TTS voices left.

reg.


Bernd

P3D V4.5 -  PC spec: Intel i9-9900 overclocked 5 GHz, 16 GB RAM, GPU Nvidia RTX2080, M2 SSD, Jeehell FMGS on a dedicated Server, PF3 for ATC, MCE, GSX, EFB, AS+ASCA

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...