Gnacino

Saitek Radio Panel Baro is stuck in hPa

Recommended Posts

Hi, can not switch the baro to inHg, no mater what is set on the aircraft.  It starts on hPg and cannot switch it.  I tried assigning a button on LINDA, but it's a no go.

I'm using P3D v4.4, LINDA version 3.0.9.809, on WIN 7 64bt.

Thanks,

Gnacino

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just a wild stab...  go into Windows Control Panel, Device Settings, Human Interface devices; located the panel, perhaps by unplugging it and replugging it; then check its properties and see if advanced power management is checked. If so uncheck it.  Also, do a web search for "SaitekUSBFix.zip" and run the small app it contains.  That will clear out any APM settings for Saitek devicesin the registry.

Hope that solves it!

Share this post


Link to post
Share on other sites
17 hours ago, Gnacino said:

Hi, can not switch the baro to inHg, no mater what is set on the aircraft.  It starts on hPg and cannot switch it.  I tried assigning a button on LINDA, but it's a no go.

I'm using P3D v4.4, LINDA version 3.0.9.809, on WIN 7 64bt.

Thanks,

Gnacino

Hi

The answer is buried in the LINDA code. The value cannot be changed by a button assignment.

You have 2 options:

  1. Go to LINDA Setup page and tick the Saitek Panels checkbox. This uses the GUI to control the Multi and Radio panels and used hPa. This is the preferred and more responsive solution. 
  2. Open the LINDA edit and open common.lua. Search for SRP_QNH_UNIT. In line 960 change ipc.set('SRP_QNH_UNIT', 0) to ,1). Click save.

In both cases you will need to Reload LUA Engine. The pressure setting will now be displayed in hPa.

Edited by ScotFlieger
  • Like 1

Share this post


Link to post
Share on other sites

Thanks Scot, but I want to change it to inHg .  What do I put in that line to accomplish that ?

Gnacino

Share this post


Link to post
Share on other sites

Why? You live is the US where they are always backups.

Sorry I misread your typo "hPg". With the Saitek Panels set in GUI that is not possible - this is hard coded. You will need to use the slower LUA implementation (Saitek Panels unticked) and edit common.lua line to ipc.set('SRP_QNH_UNIT', 0).

Edited by ScotFlieger

Share this post


Link to post
Share on other sites

Edit common.lua line 960, save and restart (option 2 above). The comments tell you what value to use (1 = inHg and 0 = hPa).

Share this post


Link to post
Share on other sites

How do I get in the editor mode?  The three items, editor, tracer, and reload LUA engine are grayed out.

Gnacino

Share this post


Link to post
Share on other sites

On LINDA Setup page tick the Developer Mode checkbox. This will enable those options. 

Edited by ScotFlieger

Share this post


Link to post
Share on other sites

Did all that, but the baro is still in stuck in hPa.

George

Share this post


Link to post
Share on other sites

 I have never used inHg so it have never been a problem before. Let me investigate further.

Share this post


Link to post
Share on other sites

That's because you blokes only fly in Europe;)  Try flying across the pond, we do things the right way here :-)

Gnacino

Share this post


Link to post
Share on other sites

I have reviewed the LUA code handling the inHg display on the Radio Panel. I have got it working with no change. However, the integer values of inHg (eg 30.00) were displaying as whole number without the decimal part (eg. 30). I have modified common.lua to correct this.

Download this version of common.lua, unzip it and save it in /modules/linda/system.

Ensure the LINDA Setup Saitek Panels checkbox is unticked and restart LINDA.

This should make the Baro Reference compatible with Trump's backward America :). ISO rules! Further work will be required to change the GUI code for a faster version.

Share this post


Link to post
Share on other sites
On 1/17/2019 at 3:45 PM, Gnacino said:

That's because you blokes only fly in Europe;)  Try flying across the pond, we do things the right way here 🙂

Gnacino

I owe you an apology. I had forgotten how I had implemented the LINDA GUI Saitek Radio Panel code. A little digging in the code today has reminded me.

You can switch between hPa and inHg barometric reference by turning either rotary selector to DME and pressing the ACT/STBY button. You then switch back to XPDR to see and adjust the pressure setting.

Remember to tick Saitek Panels in Setup LINDA and disable the Radio Panel in Setup Joysticks.

Edited by ScotFlieger

Share this post


Link to post
Share on other sites

Thank you much. All is good on my side of the pond.

Gnacino

  • Like 1

Share this post


Link to post
Share on other sites
On 1/29/2019 at 4:02 PM, Gnacino said:

Thank you much. All is good on my side of the pond.

Gnacino

This test build of LINDA 3.0.11 allows you to set the default Baro Reference (inHg or hPa) on the LINDA Setup page. It can also be changed in-flight by selecting DME on the Saitek Radio Panel and pressing Act/Stby button. This works in both the faster GUI and slower LUA implementations (LINDA Setup Saitek Panels ticked or unticked).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now