Karelpatch

RNAV approach TRK not matching DTK

Recommended Posts

Hi,

I was flying the A2A Bonanza with GTN 750 and I loaded a vector approach to RW 17 on KTHV.

As I reached the initial fix, I put my AP in approach mode. The plane aligned to the 166 degrees vector, the CDI was showing a nice full arrow and when I reached the FAF the AP catched the glideslope and started the descent. 

 But from that moment, I watched the TRK moving away from the 166 DTK by a few degrees as we were approaching. At runway level, the track was at 171 degrees, leaving the runway to my left. 

What could have caused the plane to move away from the vector track? It was supposed to track the vector since it even did catch the glide slope. Is this about settings?

Some relevant screen grabs of the track:

https://imgur.com/gallery/b294ijK

First picture, I am on 166 vector.

Second one: I have reached FAF and slowly going off track (171 degrees on the picture.) The leg was activated with the countdown confirming 166 degrees. 

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

I've seen the other discussion here:

Can you please confirm something:

  • I see the GTN shows TRK = 171, and the 'vector line' shows it is pointing out the DTK on the map page.
  • However, does the A/P fly you away from DTK or does it stay on the line?
  • Furthermore, what about deactivating the Charts overlay and see if this makes a difference?

 

Share this post


Link to post
Share on other sites
25 minutes ago, RXP said:

Hi,

I've seen the other discussion here:

Can you please confirm something:

  • I see the GTN shows TRK = 171, and the 'vector line' shows it is pointing out the DTK on the map page.
  • However, does the A/P fly you away from DTK or does it stay on the line?
  • Furthermore, what about deactivating the Charts overlay and see if this makes a difference?

 

Yes, I posted here because I figured I could get more help.

The A/P did exactly what was shown on the GTN: it flew away from DTK and TRK information seems accurate, as the course needle. 

Share this post


Link to post
Share on other sites

In addition to the other questions above, have you by any chance modified the Prepar3D navdata or are you using stock P3D?

Share this post


Link to post
Share on other sites

 

1 hour ago, Karelpatch said:

Furthermore, what about deactivating the Charts overlay and see if this makes a difference?

and what about this?

I'm also wondering if there could be a difference in the 'airac data' you're adding in the simulator which could cause this.  This kind of error is generally related to 'magvar' differences between the magnetic models embedded in the device and the simulator, and you may want to cross check what is the magvar reported by P3D and the one reported by the GTN and see if there is roughly 1.5 to 3 deg difference between the two.

Share this post


Link to post
Share on other sites

I’m going to try this when I have the time, ASAP. 

I’m curious: why would deactivating charts overlay change anything?

About the magnetic variation: if this was the case, shouldn’t it cause an issue in many other cases? Also, weirdly enough, the previous 166 degrees leg from IAF to FAF was followed with no issues.

Share this post


Link to post
Share on other sites

So that you know we're evaluating this on our end along with you. Charts or magvar could be a factor if there is a bug in the trainer, I'm just trying to check with you in eliminating layer after layer.

 

 

Share this post


Link to post
Share on other sites

You rock, thank you! 

It’s actually mostly curiosity for me at this point. I was wondering if I did something wrong in the way I setup my approach. Or maybe some settings I need to change. 

I haven’t had the time yet to try the GTN 750 in more than a few flights, nor to retry that specific flight. I definitely will. 

If I find I can’t reproduce the issue again or that it’s specific to this airport, this will add another layer of realism: never 100% rely on your avionics. 

Share this post


Link to post
Share on other sites

This might indeed be a case of database base error too. I've cross check Garmin's advisories but I've not found anything for this airport for now:

https://www.garmin.com/en-US/aviationalerts/

For example one of the latest:

16 January 2019
Subject:
Neuquen, Argentina
Presidente Peron (SAZN)
VOR Rwy 27
Cycle1901

Incorrect Fix Position

Jeppesen NavData cycle 1901, effective 3 January 2019, contains incorrect data. The position/coordinates for the fix ZN031are incorrect. The fix ZN031 should be NEUQUEN (NEU) VOR DME R-151/D13.0: coordinates S39 08 42.89 W068 0157.48

Share this post


Link to post
Share on other sites

Ok, so I did some tests this morning but I was lacking time:

I reloaded the same approach and I got the exact same behavior (change of track after the FAF to RW leg is activated and I catch the GS.) 

- I searched where the magvar was displayed on the Garmin. I only could find the one on the chart and I compared it with the most recent data and it shows the same magnetic variation. Is there a menu on the Garmin to display the magnetic variation?

- I couldn’t find where to deactivate charts overlay?

- When going through the device informations I discovered that I had corrup/unauthorized databases: Basemap and Safetaxi. Is it normal?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi,

Magvar displays in the Unit Setup page (GTN Pilot's Guide 16.7.1 - open the manual and search the PDF for "Magnetic Variation")

Charts overlay is detailed in 9.1.1.6 (search the PDF for this)

As for the database files, can you please detail how you've found out / where was it said, they were corrupted/unauthorized?

Share this post


Link to post
Share on other sites

Ok I get it. This is the "Standby" database information which is not relevant in our case (I guess).

Share this post


Link to post
Share on other sites
7 hours ago, RXP said:

Hi,

Magvar displays in the Unit Setup page (GTN Pilot's Guide 16.7.1 - open the manual and search the PDF for "Magnetic Variation")

Charts overlay is detailed in 9.1.1.6 (search the PDF for this)

As for the database files, can you please detail how you've found out / where was it said, they were corrupted/unauthorized?

So, when I go into the Unit setup, I should see the current magvar on the button for the “Magnetic variation” option?

I will definitely try everything this week. Really curious to see the cause of the issue. 

Share this post


Link to post
Share on other sites

Hi, 

I’m back and kind of losing my mind over 2 separate issues:

- I tried to redo the RNAV approach and now for no apparent reason my autopilot (KFC 200) disconnects every time it reaches the FAF from IAF. And it happens on every airport I tried. I tried staying in NAV mode or APR mode, same issue, it doesn’t catch GS anymore and it disconnects and I am unable to select NAV nor APR afterwards. 

(Just crossed my mind: I guess I should select VLOC manually because I am too close to the FAF. That could be the issue. Will try.)

 

- Second issue, certainly related to the initial topic:

I created a direct route to a VOR. And of course, the course isn’t matching the line! Once more I have something like a 2 degrees offset. Completely different region (Europe). I checked the GTN magvar and it was correct compared to recent real life charts. Could it be that my P3D magnetic variations are not correct? 

Pictures illustrating what I am talking about:

https://imgur.com/gallery/MTZ8Tgp

Share this post


Link to post
Share on other sites

Hi,

I'm not sure for the first part and this could be due to the aircraft you're using. Is this happening for example with the default Mooney or Baron 58?

As for the 2nd part, a 1deg difference is normal in my opinion. Please note the value is rounded to the nearest angle for display. So if DTK is 328.01 and TRK is 327.49, the difference is close to half a degree only yet shows 1 deg on the two values.

Now, this makes me wonder if what is happening is related to gyro drift instead. This could be a bug either in our code, using a heading source variable which is subject to drift in FltSim (which I doubt, we're careful about these things but I'll cross check), or, a bug in a recent P3D update which now 'drift' a simvar it is not supposed to. You might try 'resetting' the P3D gyro drift (there is a key shortcut for this) and see if this changes anything?

Share this post


Link to post
Share on other sites
10 hours ago, RXP said:

Now, this makes me wonder if what is happening is related to gyro drift instead. This could be a bug either in our code, using a heading source variable which is subject to drift in FltSim (which I doubt, we're careful about these things but I'll cross check), or, a bug in a recent P3D update which now 'drift' a simvar it is not supposed to. You might try 'resetting' the P3D gyro drift (there is a key shortcut for this) and see if this changes anything?

Will try! 

Share this post


Link to post
Share on other sites

Hi,

We're about to release our update either today or tomorrow.

However we've been trying to reproduce your flight and didn't experience the 'TRK drifting' you've reported in a standard P3D4.4 installation. Nor we've experienced any issue with the A/P coupling.

As far as A/P is concerned though there should be nothing in our code disconnecting any armed mode. As a matter of fact, the autopilot related code does not change any autopilot state, it just 'reads' it. Our next update introduces a change in that with AFMS.gps_selected enable, the GTN will automatically switch the A/P from NAV mode to APPR mode when required.

I'll cross check a couple additional things prior releasing the update just in case, but I think the only change which could affect the A2A aircraft might be related to something else: how do they code their A/P and what simvars are they using? v2.5.11 implements more stringent simvar overrides in relation to more precise GTN states, and it could be relying on a particular simvar (say NAV1 something) for the Autopilot code makes it disconnect based on their own A/P code logic?!

NB: these tests were conducted with the upcoming update version during its development, not with the actual release v2.5.11.

 

 

Share this post


Link to post
Share on other sites
9 hours ago, RXP said:

Our next update introduces a change in that with AFMS.gps_selected enable, the GTN will automatically switch the A/P from NAV mode to APPR mode when required.

Hasn't it already been doing that since the previous update?  2.5.11? That is what I have experienced!

Edited by fppilot

Share this post


Link to post
Share on other sites
On 2/1/2019 at 10:49 AM, Karelpatch said:

Hi! I’ve posted on A2A forums about my issue with the autopilot disconnecting, and I got an interesting reply from the devs (see last answer): 

https://a2asimulations.com/forum/viewtopic.php?f=139&t=67295&p=511964#p511964

 

Apparently something must have changed between RealityXP gauges, P3D or Garmin’s trainer. 

I've just switched from F1 to RXP after using their GTN's for the past 4 years. I have the same issue, but it happens with any departure/approach procedure I select. I have my flight plan set, FD set to NAV but as soon as I load a procedure the NAV mode disengages, APPR and CPLD start flashing and eventually turn off...I entered the SID waypoints manually and the flight went well until the same thing happened again when reaching the FAF. In the FSW Falcon 50 NAV won't disengage but the FD roll bar starts shaking out of control so this is not exclusively related to A2A.

Share this post


Link to post
Share on other sites

@fppilot Sorry for the confusion: yes it is already in v2.5.11. I should have written "our last update".

@OuterMarker thank you for the additional details. Is this when you load, or load and activate?

Can you tell me how have you set the following options:

Panel Instruments:

- Connect GPS to Autopilot
- Connect GPS to HSI
- Connect HSI/OBS (input)
- Connect GPS to VOR
- Connect CDI Mode to NAV/GPS Switch

Gauge Options | Advanced Settings:

- Auto-Update Simulator GPS Waypoints

AFMS

- GPS Selected

 

ideas:

I'd suspect you'd need maybe 'GPS to VOR' on these aircraft if they use any 'NAV' simvar.

GPS Selected is the settings which sends the command to arm APPR mode when the GTN instructs to do so. Enabled is the default and whenever using a KAP autopilot, it should be set to disabled in the real world. In this case, the GPS prompts the pilot to manually arm APPR mode instead.

It is possible we are arming the APPR mode too quickly for these aircraft which are lagging behind. In this case, prior they get the chance to 'monitor' conditions have changed, we send the command to Flight Simulator and they end up in an unknown state for them. It might be interesting we add a delay prior arming the APPR mode when the condition arises. a 1 sec delay won't change anything to the flying experience but this will let the chance to these A/P to process at least once the new conditions. I'll make sure to review the code triggering this.

Furthermore, without changing any of these settings (make a backup of the RealityXP.GTN.ini file in the aircraft folder just in case) and should you have the Garmin Trainer 6.21 still installed, can you eventually try using the environment variables to tell the RXP GTN to use the older trainer and compare how it goes?
 

Share this post


Link to post
Share on other sites

@RXP I did some brief testing and "Connect GPS to Autopilot" seems to be the issue here, at least in the A2A Bonanza. These are my settings for now (keep in mind that I'm new to the RXP GTN so let me know if I should change something else).

Share this post


Link to post
Share on other sites

@OuterMarker the problem is that you've disabled 'Connect GPS to Autopilot' therefore the GTN won't control the autopilot... However, you've enabled "Auto-Update Simulator GPS Waypoint" which makes the GTN override the default GPS flight plan.

Therefore, instead of having the GTN controlling the flight director / autopilot directly, you have the A2A aircraft autopilot following the default GPS system flight plan made of GTN emitted point to point line segments...

Try this instead:

  1. Enable Panel Instruments | Connect GPS to Autopilot
  2. Disable Gauge Options | Advanced Settings | Auto-Update Simulator GPS Waypoint
  3. Compare with or without Panel Instruments | Connect GPS to VOR
  4. Compare with or without AFMS | Main system | GPS Selected

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now