Recommended Posts

Hi everyone

Can anyone tell me if PMDG 747-400 Queen of the Skies !! - Base Package for Prepar3D  will work in Version 4.4?

This was purchased in November 2017 so I am not sure if this is the latest version ....

Thank you in advance

Paul 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

1 minute ago, Paul_ said:

Hi everyone

Can anyone tell me if PMDG 747-400 Queen of the Skies !! - Base Package for Prepar3D  will work in Version 4.4?

This was purchased in November 2017 so I am not sure if this is the latest version ....

Thank you in advance

Paul 

 

it will certainly work and it had an update to it recently, and the latest version is v3.00.0195

Share this post


Link to post
Share on other sites

Best way to be sure is to go into your shop account and download the latest installer (if you haven't updated since November of 2017, this is required). Once you do that, run the installer (assuming you uninstalled the previous version first), then go to the Operations Center and run any updates that show up. That should get you up to date.

Share this post


Link to post
Share on other sites

All sorted

Thank you Gentlemen

Kind regards

Paul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now