Sign in to follow this  
Vlaj94

Low FPS if sound is activated

Recommended Posts

So yesterday i was playing FSX:SE and (since i installed the game) i couldn't see progressive taxi. I searched about that problem to fix it and read that deactivating "Preview direct X 10" could maybe fix the problem, so i tried that and i had to restart the game to apply change (untill now FPS and sound was fine).

When i restarted FSX, i had 2.2 fps and couldn't hear any sound from the game. I tried to cancel the change and reactivated the preview then restarted the game, but the low FPS problem was still here. I have tried few other things (reset settings to default, reducing display settings to very low for example), but the problem is still there.

If i deactivate sound (with default key Q), the fps goes back to normal. So i'm looking for a way to fix that new problem (I think i found the fix  for progressive taxi, but i have a more important bug to fix now 😞 )

If i had to guess what the problem is, i would say that since i deactivated dx 10 preview, it created a new config file somewhere and it wasn't changed (because "compatible" with dx 10 preview) when i reactivated it, but i have no idea where to check that.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

The easiest test is to backup your fsx.cfg file then delete the original.  Restart FSX and it will rebuild fsx.cfg to default specs. 

A pain if you have additional SimObjects folders,etc. and you will have to reconfig your display, etc. but it will reset everything.

Besides, since you backed it up, you can always overwrite the newly created one with the backup and put yourself back where you were.

 

 

Edited by airernie

Share this post


Link to post
Share on other sites

So...

I tried to delete fsx.cfg and start the game, but i'm getting a black screen when i click on "fly now" (game doesn't load, first window's music is still playing), only way to close the game is with task manager. I have tried to make some modification, but the only way to have the game loading is to activate "direct x 10 preview", and the game run at 1 fps if sound is activated.

I've also checked task manager, when sound is deactivated, GPU usage is around 33%. if i activate sound, GPU usage drop and vary between o% and 1%

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry, was hoping that would help, but it appears that you have other issues beyond what a clean fsx.cfg can fix.

I've never used the preview DX10 option, but I'm sure someone will step in with some additional troubleshooting tips.

Edited by airernie

Share this post


Link to post
Share on other sites

Found the cause of the problem (some time ago, but i forgot about that post), it had something to do with Realtek (R) Audio Enhancer being deactivated. Not sure what is causing it to switch to deactivated mode randomly, but when it is reactivated, the problem with fsx is fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this