Jump to content

Sign in to follow this  
slothster

TBM 850 Carenado - Missing textures and condition lever stuck

Recommended Posts

Trying to install the TBM 850 from Carenado as I loved it when playing FSX however with the installation of P3D v4.4 the TBM 850 not only has missing textures but refuses to create any thrust no matter what I try (something that never happened in FSX). I have tried reinstalling multiple times, I'm out of options, my other P3D airplanes work fine (from what I can tell).

Included is an image of the textures: https://imgur.com/a/eWs5aAL

Some other users noted similar issues online but none provide any workarounds or fixes 😢

Share this post


Link to post

About the only thing I can think of - did you download the new installer from your account? I don't believe the FSX version would port cleanly to P3D.

Share this post


Link to post

I purchased this from Flight1. I've just downloaded a fresh installer but the issue still remains. The propellor doesn't spin and having the engine running causes a fire.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...