LesOReilly

Audio Panel Control Conflict Bug

Recommended Posts

Hi,

I have the GTN 750 and also use a GNS 530.....I know I know -- proper way would be to have 2 750 or the 750/650 Combo....BUT I have these on external Controllers and use the 530 still since it is the closer of the two units to the 480 in the plane I fly.  Also I bought the 530 after building a 530 Panel...Then bought the 750 after using the RealityXP GNS530 and deciding to purchase it and the RealSimGear 750.

The Bug....When both units are installed the GTN 750 is not able to control the COM Audio Panel controls....MIC and Monitor do not work.  I made a video to show this...and without Working...Then with again.

Also sorry about the "snarky" sound about the Pop out config -- Just frustrated that every time I add these to a plane I have to go and edit the GTN/GNS INI files plus also edit the Planes Panel Config as well.  Really WBN to get the No Bezel and Second unit selection as part of the Config for the Pop out Panels.

Hope this helps to fix the Audio Panel bug -- I removed another panel that had Audio Panel Controls on it since I was going to have this in all of the planes going forward 😞

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

I thank you for the nice comments and video, as well as the suggestions. We'll see how to introduce maybe these as 'advanced' options so as not to clutter the interface for the first timers.

As for the audio panel, the rule is: you can't have twice _1 or twice _2 units in the same panel.

The issue is most likely related to the workaround we have to implement to make a working 'ID' mode (push the COM volume knob) which works regardless of having a GTN and/or a GNS on the panel.

Have you tried a GTN_750_1 and a GNS_530_2 instead?

 

Share this post


Link to post
Share on other sites

In the A36 I use most of the time — I have the 750 and 530 setup together. 

750 is the _1 and the 530 is the _2. The audio issue was found with that configuration. Basically if both the 750 and 530 are installed together then the audio does not work for the coms any longer  

 

I did it That way so both the GPS external controllers can be independent — but does require that I have to edit both the panel files and the GNS config file. That is another one of those items when using the pop up configuration would be helpful. 

I.e. when adding a pop out I should be able to select the unit to be either _1 or _2 and then if it is NO Bezel. If you want to add that to the configuration menu instead that is fine. 

Anything that keeps me from having to edit the 750, 530 files and panel file in every plane I use 😉

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, LesOReilly said:

750 is the _1 and the 530 is the _2. The audio issue was found with that configuration. Basically if both the 750 and 530 are installed together then the audio does not work for the coms any longer  

at the beginning of the video (~20sec) it shows the contrary: when you open up the 530 settings to check for updates, the top bar shows GNS 530 1

You might want to cross check all instances of the GNS gauge in the panel.cfg file?

Edited by RXP

Share this post


Link to post
Share on other sites
1 minute ago, RXP said:

at the beginning of the video (~20sec) it shows the contrary: when you open up the 530 settings to check for updates, the top bar shows GNS 530 1

You might want to cross check all instances of the GNS gauge in the panel.cfg file?

Yes in that video I was using another plane to do it all from scratch for a couple of videos I am making regarding configuring the GTN and GNS with external controllers. 

I wanted to use a fresh aircraft. I did not bother changing the Panel file and GNS file as the result is the same. I will make another video using the A36 that I have all of this installed in which has the same symptoms. 

I will make sure to show all the files 🙂

just need a couple hours and I will get it done. 

Share this post


Link to post
Share on other sites

No need to make a new video then. It was confusing whether the issue is because of _1 + _1 (the video) while you were thinking you were running _1 + _2 instead. I'll have to cross check this then.

Share this post


Link to post
Share on other sites
3 hours ago, RXP said:

No need to make a new video then. It was confusing whether the issue is because of _1 + _1 (the video) while you were thinking you were running _1 + _2 instead. I'll have to cross check this then.

Doh....Saw this as I cam to post the link....  Part 2 which shows it in the A36 with the appropriate panels and the same result.

 

 

Share this post


Link to post
Share on other sites

Hi,

I confirm this is a bug and it is now fixed in the upcoming update. It was a stupid typo...

  • Like 1

Share this post


Link to post
Share on other sites

Awesome!!!  Looking forward to getting that Resolved!!!!

Do you want these Videos deleted?  I have them as unlisted but don't need to keep them around if you would prefer?

Share this post


Link to post
Share on other sites
3 minutes ago, LesOReilly said:

Looking forward to getting that Resolved!!!!

The update has been released a couple days ago now!

As for the video I'll let you decide the best course of action!

Share this post


Link to post
Share on other sites
1 hour ago, RXP said:

The update has been released a couple days ago now!

As for the video I'll let you decide the best course of action!

HAHA -- Well I was in NYC for Biz and have not been able to be on the sim since last weekend....Finally have the real plane back so spent those extra free hours up in the real skies.

Well if you are going to "close" this thread then I would delete them.  If you are going to keep it then I guess I can leave them so that the page does not end up with broken links.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now