Jump to content

Sign in to follow this  
BigT65

Looking for Saitek X56 users

Recommended Posts

Posted (edited)

I have been using X56 for a little over 6 months now both with FSX and P3Dv4.5. The system is working great for me except for one thing. I cannot fly inverted or do a smooth aileron roll. Surely there are X56 users in the forum that have tried these maneuvers with the X56. If someone could please respond and let me know what happens when you roll your plane over I would really like to hear from you.

Edited by BigT65
Add tags

i7 8700K CPU @ 4.4 GHz, 16 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, Asus GTX 960 OC GPU 4GB GDDR5 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S.

Share this post


Link to post
Share on other sites

The problem has been solved. Someone on the FSX-SE forum suggested that I increase my joystick dead zones to a higher setting like 30. So I did this and sure enough the roll anomaly was fixed. I tried several aircraft and they all worked correctly. WooHoo!


i7 8700K CPU @ 4.4 GHz, 16 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, Asus GTX 960 OC GPU 4GB GDDR5 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S.

Share this post


Link to post
Share on other sites

Today I made a major discovery. It turns out that the problem doesn't have anything to do with Deadzones after all. The problem returned so I tried a few other things. I use EZCA v2 and started using it at almost the same time I got the X56 controller. So today I loaded up the sim without EZCA and I was able to do a normal roll and fly inverted. I loaded up EZCA and the problem returned. I don't know what part of EZCA is causing the problem though. I have tried turning on and off various settings and none of them stopped the roll over problem. I have tried turning EZCA on and off several times and when it's off no roll over problem when it's on problem returns. Now that we know this does anyone have any ideas about what part of EZCA could be causing this? I really like using EZCA and would like to find out if there is a setting causing this problem.


i7 8700K CPU @ 4.4 GHz, 16 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, Asus GTX 960 OC GPU 4GB GDDR5 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S.

Share this post


Link to post
Share on other sites

After further testing it turns out that the dead zone adjustment did not solve the problem.

Problem Solved, Again.  This time I am certain that I'm right. The roll over problem is due to the effects of the Horizon Hold in EZCA. I set a switch on my throttle unit to turn it off If I have the need to toll the aircraft. So far the fix is working great. Apparently no one else has ever experienced this issue, but if they do I hope they find this thread. Thanks for all the replies and suggestions. I hope no one ever has the hear about this issue again.

Edited by BigT65

i7 8700K CPU @ 4.4 GHz, 16 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, Asus GTX 960 OC GPU 4GB GDDR5 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S.

Share this post


Link to post
Share on other sites

What is your opinion on the X56 overall?  


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM750x |  240MM AIO.  Win 10 Home. 

Share this post


Link to post
Share on other sites

I like it. Had a little trouble getting it all setup, but that's because I don't have as much patients as I used to have. It's got plenty of buttons and switches and 3 different modes. It would be hard to run out of options. Now that I figured out how to do a roll and get inverted it's even better.


i7 8700K CPU @ 4.4 GHz, 16 GB DDR4 3000 memory, Gigabyte Aorus Z370 MB, Asus GTX 960 OC GPU 4GB GDDR5 Memory, MasterAir MA610P CPU cooler, 1T PCIe NVMe SSD, 500GB SSD, 2T HDD, 3 Asus 24" monitors, Saitek X56 Rhino H.O.T.A.S.

Share this post


Link to post
Share on other sites

I'm debating between the Thrustmaster warthog and this.  Obviously pro's and cons to each.  For the X56 I like the price, less weight, and twist rudder.  


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM750x |  240MM AIO.  Win 10 Home. 

Share this post


Link to post
Share on other sites

Could you give me dimensions of the X56 - width and depth of both the throttle and joystick? 

Thanks, Jeff Callender


Jeff Callender

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...