richbonneau

P3D does not start after KB4515384 update

Recommended Posts

I just installed the new KB4515384 update and P3D does not start.  I get the splash screen then the app terminates with no error message.  

Uninstalling the Windows update solves the problem.  

Anyone else try this one yet?

-Rich

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had that happen also. I rebooted the computer and then it started normally after 

Share this post


Link to post
Share on other sites

Yeah, I rebooted again, too. Didn’t fix it for me. Tried uninstalling/reinstalling the update and it did not work. Ended up uninstalling that update for now. 

Edited by richbonneau

Share this post


Link to post
Share on other sites

If you are running Rivatuner in the background it will crash P3D since the KB update. Close out of it completely and then try P3D. 

Share this post


Link to post
Share on other sites
8 hours ago, SolRayz said:

If you are running Rivatuner in the background it will crash P3D since the KB update. Close out of it completely and then try P3D. 

Thanks, I saw that somewhere but I'll just sit tight without the update for now.  I also had issues with my Flight1 GTN750 after applying the update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now