Jump to content

Sign in to follow this  
raiven

GNS750 Xplane11.50b9/b6 vulcan blackscreen

Recommended Posts

Posted (edited)

Hi,
I have a problem with GTN 750, when i use vulcan version of Xplane, i have black screen on both popup window and cockpit. If i try to turn off gps/turn off plugin/reload plane/ or change plane to other xplane just crash. I tried in VR and non VR, and also on default cessna 172, and paywares planes like SF260. When i go back to OpenGL version it's works normal, i can turn it on/off, reload and change plane in VR and non VR.
I read posts on forum, and i checked core usage. I use only one graphics card. Separatly trainer works fine.

Thus i have question, its works on vulcan version? Is it known problem?
And if isn't supported, are you planning support for vulcan version?

Edited by RXP

Share this post


Link to post
Share on other sites

Hi,

It is working with XP11B9 Vulkan but since it is a beta version, it can't be officially supported.

Anyhow, there is nothing preventing our GTN from running in XP11 Vulkan, like most existing plugins, because XP11 Vulkan adds an OpenGL layer to make plugin rendering feasible when running in Vulkan.

In other words: whether you're in Vulkan or OpenGL, XP11 plugins can't tell the difference and render their graphics the very same way via OpenGL context.

Such errors could be related generally to either a bug in the Video Card driver (could be best you post your Video card specs/model/driver vers etc...) or a bug in the XP11 Vulkan/OpenGL bridge. The former is most likely because the later is running fine so far for us and others.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for quick answer.
This is my spec:
i7 9700k
32GB RAM
GTX 1080, driver 445.87
actual Windows 10, Xplane 11.50b9

Small update of problem:

I updated graphics driver to the newest 445.87, then restarted pc. After restart, first launch of xplane (vulcan ver), GTN work normaly, changed to other airplane, and GTN didn't work anymore. If i try turn off plugin, xplane crash.
It looks like after restart pc, first launch of xplane it works correctly, but change airplane, reload scenery, or turning off xplane, GTN dont work anymore to next pc restart. I tried to find orphanted process in task manager, but not exist. 
Maybe Garmin simulator shoud have admin rights? I don't have more ideas. I looked to logs and UnsentCrashReports is empty. OpenGL works normaly.

Quote

20/05/17 00:21:10.429 04388 -    ] # rxpGtnSim64.dll version 2.5.25.0
20/05/17 00:21:10.427 04388 INFO ] 
20/05/17 00:22:00.041 04388 INFO ] GTN 750.2 - TRAINER 6623
20/05/17 00:22:00.042 04388 INFO ] C:\Programy\Garmin\Trainers\Packages\GTN\Bin
20/05/17 00:22:00.043 04388 INFO ] C:\Programy\Garmin\Trainers\Packages\GTN\data
20/05/17 00:22:00.044 04388 INFO ] C:\Programy\Garmin\Datatrainers\Databases
20/05/17 00:22:00.044 04388 INFO ] C:\ProgramData\Garmin\Trainers\GTN\nonvol
20/05/17 00:22:37.647 04388 INFO ] using: %LOCAL_APPDATA%\CrashRpt\UnsentCrashReports\GTN Trainer_6.62.3.0RXP

Quote

20/05/17 00:21:08.494 04388 -    ] # win.xpl version 2.5.25.0
20/05/17 00:21:08.493 04388 INFO ] 

 

Edited by RXP

Share this post


Link to post
Share on other sites

Hi,

There is nothing peculiar in this log file. You might want to review the XP11 log file then.

NB: please don't post its content
it is useless as-is and too large. Instead, just look whatever error is detected and reported, usually at the end of the file. Eventually report back the last lines only.

Do you also get a XP11 crash report window and do you submit the crash report to XP11 devs? This will certainly help them.

Last but not least, is it still crashing on your system if you load and change aircraft not equipped with the GTN?


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
Posted (edited)

I compared noncrashed and crashed log file, and only difference is missing few last lines and this at end --=={This application has crashed!}==--. Thats, all.

Quote

[REP 14:38:09] Plugin Disable
[REP 14:38:09] Destroying OpenAL Context...
[REP 14:38:09] Closing OpenAL Device...
1:08:09.339    LT/XPMP2 INFO  XPMPMultiplayer.cpp:184/XPMPMultiplayerCleanup: XPMP2 cleaning up...
--=={This application has crashed!}==--

When i close xplane, its freeze, when i kill GTN_simulator.exe in task manager, xplane unfreeze, but few second later crash.
 

Quote

Last but not least, is it still crashing on your system if you load and change aircraft not equipped with the GTN?

If i restart pc, or kill GTN_simulator.exe, i can load other aircraft non GTN without any problems, i can change reload etc. Also if i turn off RXP in aircraft RealityXP.GTN.ini file, also in works normaly. I made some test yesterday, i tried give admin rights for GTN_simulator but without success. I found this thread https://forums.x-plane.org/index.php?/forums/topic/194035-solved-gtn-650-wont-display-screen/, I have fresh new copy of plane, and maybe, i have something wrong with rxp config file? Can you review it?

Quote

Do you also get a XP11 crash report window and do you submit the crash report to XP11 devs? This will certainly help them.

Yes, always, i describe problem and send report, but sometimes with GTN problem report window doesnt show up.
 

Edited by raiven

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, raiven said:

1:08:09.339    LT/XPMP2 INFO  XPMPMultiplayer.cpp:184/XPMPMultiplayerCleanup: XPMP2 cleaning up...

Are you sure this plugin is compatible with XP11B9 Vulkan...

There are massive changes in the latest B9 especially around MP and TCAS, we're currently working in implementing support for it.

Could it be a conflict between traffic provider (XPMP) and traffic consumer (GTN)?

In order to isolate the sources of errors, I'd suggest the following:

  1. Create a XP11\Resources\Plugins.disabled folder
  2. Move all you plugins there except the XP11 ones, and the RXP GTN
  3. Try changing between default aircraft only equipped with RXP GTN
  4. If it is running alright, try moving back your plugins from the 'disabled' folder one at a time.
Edited by RXP

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry, for long answer - work. 
XPMP - i installed it after problems with GTN. 

Like you wrote, i remove all plugins from xplane. Last only RXP and REP - because is buildin SF260. Problem still exists. 
My friend bought SF260, also have GTN and have the same problem as I. Additionaly he have Carenado's plane and and in this plane everything works. 
Then problem is connected with RXP/REP/SF260. I found some threads(isn't mine) in xplane forum, creator of SF260 wrote, he only created config file, then where find solution?

https://forums.x-plane.org/index.php?/forums/topic/194035-solved-gtn-650-wont-display-screen/

I found temorary workaround, after loading scenery in cold and dark aircraft, minimalize game. Go to task manager and once kill process called GTN_simulator.exe. After that appear new process GTN_simulator.exe, and after that, when i turn avionics i have working GTN.

 

Edited by raiven

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, raiven said:

Go to task manager and once kill process called GTN_simulator.exe.

I'd advise STRONGLY not doing this. You're messing up with the RXP GTN and this can't reliably work.

Instead, I'd strongly suggest you lobby the aircraft vendor who is not complying with the recommended RXP integration best practices...

Javier's decision to make the RXP ini file read-only is a very peculiar aircraft vendor decision IMHO.

To explain in different terms, it is as-if you'd explicitly change "X-Plane.exe" file access right, removing the 'right to execute', then double click and expect it should be running...

Full story:

https://forums.x-plane.org/index.php?/forums/topic/195184-solved-gtn750-wont-drive-hsi/&page=2&tab=comments#comment-1789980

 

On 11/20/2019 at 8:23 AM, JRollon said:

As said, they are write protected because the user or updates could break compatibility of what I made to work with 3 of them, so it is better to not touch the files.

Let me rephrase in simpler terms:

  • The GTN (and the GNS V2) are not designed to work with read-only ini files
     
  • In order to protect the ini file from user changes there is a mechanism already implemented which locks out the user from changing the settings in the GUI (the Settings Panel) if you mark them as such. Hint: locked=
     
  • In order to ensure the ini file is configured with mandatory defaults for some 'key' settings, there is also a mechanism already implemented which 'enforces' default values when the GTN (and the GNS V2) starts up. Hint: RealityXP.GTN.defaults.ini
     
  • In addition, the aforementioned feature also ensures any aircraft update won't erase the user's ini file changes (for example database settings or sound volume).
     
  • This is all clearly explained in the GTN (and the GNS V2) user's manual in the recently added chapter "Integration Guidelines".
Edited by RXP

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

I read this thread, and is unchecked read only atributte in file properties. I restored to original config file attachement in aircraft. Problem still exists.

Share this post


Link to post
Share on other sites

The fact it is working with your Carenado aircraft for example, but still not with the SF360 even if you manually uncheck 'read only' attribute, leads me to think their is something else at play with this aircraft. Are you sure the aircraft is not putting the attribute back to read only when loaded? Can you post the content of the RXP log files after you're tried: manually uncheck the read only attribute on the file, start XP11, load the aircraft.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
On 5/23/2020 at 6:04 PM, RXP said:

Are you sure the aircraft is not putting the attribute back to read only when loaded?

Yes, i'm sure. Double tested.

Logs:

Quote

20/05/25 14:49:34.508 29148 -    ] # rxpGtnSim64.dll version 2.5.25.0
20/05/25 14:49:34.507 29148 INFO ] 
20/05/25 14:51:28.521 29148 INFO ] GTN 750.2 - TRAINER 6623
20/05/25 14:51:28.523 29148 INFO ] C:\Programy\Garmin\Trainers\Packages\GTN\Bin
20/05/25 14:51:28.523 29148 INFO ] C:\Programy\Garmin\Trainers\Packages\GTN\data
20/05/25 14:51:28.524 29148 INFO ] C:\Programy\Garmin\Datatrainers\Databases
20/05/25 14:51:28.525 29148 INFO ] C:\ProgramData\Garmin\Trainers\GTN\nonvol
20/05/25 14:52:36.327 29148 INFO ] using: %LOCAL_APPDATA%\CrashRpt\UnsentCrashReports\GTN Trainer_6.62.3.0RXP
 

Quote

20/05/25 14:49:32.595 29148 -    ] # win.xpl version 2.5.25.0
20/05/25 14:49:32.594 29148 INFO ] 

Folder is empty: CrashRpt\UnsentCrashReports\GTN Trainer_6.62.3.0RXP\


Also i wrote post on SF260 subforum, but without answer.
https://forums.x-plane.org/index.php?/forums/topic/214577-gtn750-xplane1150b9b6-vulcan-blackscreen/
 

Share this post


Link to post
Share on other sites

The RXP GTN crashes XPlane 11.50 beta 9 if you use a new AI traffic package release thats supports the new TCAS system implemented in this beta version of the sim. Active Sky has the same problem too. Hopefully we will see updates soon for my two favourite addons.


Cheers, Andy.

Share this post


Link to post
Share on other sites
Posted (edited)

@raiven Can you please disable the extra 'troubleshooting' settings (LogTrainer, DebubValue)?

These are most usually to be used once or twice to find out a specific error and there is none reported in the log files.

@Andydigital It shouldn't be a problem but this is XP11 BETA.

The new TCAS datarefs are supposed to be populating the MP datarefs in order to ensure backward compatibility. Nevertheless, we're working on it too!

Edited by RXP
  • Like 1

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,145.00 of $25,000.00 Donate Now
×
×
  • Create New...