Sign in to follow this  
Guest CDAhmedEH

Could this really the cause of the blurries.

Recommended Posts

Hello, Many of you, since SP1, have noticed that it was possible to increase your auto-gen scenery density with a very very small performance hit. However, you noticed that, since SP1, the blurries have increased dramatically. Try this, disable your auto gen, watch your terrain textures stay crisp even at the highest speeds of 300 knots. I knew it all along, after all the head banging, the new method of rendering the auto-gen is indeed doing something wrong to the scenery loader. It's as if the auto-gen is being prioritized from the terrain. Hmm.. anyone else has an opinion/useful experience and can comment on this ?Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I suspect that the op may be on to something, which may have been wrongly ignored as an overestimation of current hardware. Geofa, do you lock your frame rate to 30 or below? Did you try the mipbias tweak with negative lod bias? Road traffic, particularly with UTX, encourages blurries on my system, even when frame rates are good (in other words, I don't think it's UTX's fault). If I activate it, I keep it at 5, maybe 7% and no higher. Airline traffic does not have the same obvious blurring effect, even though it hits frame rates. Also, I know you really love tile proxy and before sp1 it worked well for me but now it blurs like crazy. So are you talking about with it or without?

Share this post


Link to post
Share on other sites

I've tried all those combinations. The blurries with Tileproxy I expect.If you search posts when fsx first came out you will see that I posted putting autogen on my system blurred the textures-which is why I left it off. Since sp1 it doesn't seem to matter.I would suspect what Phil Taylor said below:"And note Christian Buchner recently posted that he thinks one part of the blurry problem is a bad config entry that we just havent isolated. "http://mywebpages.comcast.net/geofa/pages/rxp-pilot.jpg

Share this post


Link to post
Share on other sites

Yeah, I've had many problems with blurries, which are more prevalent for me around more vector objects. Keeping antialiasing and aniso application controlled with nhancer helped me after UTX, but it didn't matter before. Try that, if you haven't. I also completely reinstalled fsx (defragmenting and so forth) and reinstalled UTX because the blurries hit me very hard at first. The drastic move actually made things noticeably better. I'll just assume you've tried all the other stuff like new drivers, etc, and that my telling you to do so would be annoying :).

Share this post


Link to post
Share on other sites

Yup I tried everything ! I even discovered that the latest drivers weren't the best for me. I have an ATI AIW X800 XT, and Catalyst 6.2 is the fastest and most stable for me.

Share this post


Link to post
Share on other sites

Just to emphasize for anyone besides Geofa,The first thing you should try, in my experience, is locking the frame rate to 20, then 25, then 30. I get blurries in the city no matter what, but more with a higher lock. In rural areas, I can raise the lock. It's irritating because I if I unlock the frame rate it soars to like 40, but the blurries in the cities don't get too much worse than when locked at 30. That big a difference just doesn't make sense, and as with rtm, locking frame rate seems to come with an automatic frame rate hit. It always averages below your lock unless you set things really conservatively.Way to stay positive Geofa. I, too have high expectations for the future and the directx 10 patch, at least as far as this issue is concerned. In a few years, we'll all have superduper systems and we can just look back and laugh at our present tears.

Share this post


Link to post
Share on other sites

I don't know but it seems that blurries are especially worse with people with single core processors. Also, its true that when I lock my FPS, I lose about 10 FPS, which is not acceptable..

Share this post


Link to post
Share on other sites

Yep I've observed that too.While people with uber dual and quad cores complain - rightly I guess since they spent all that money - their blurries are usually less bad when they've shown them and with higher settings obviously. Given that the threading was changed for dual core it makes sense, and while not all dual core users are happy, I definitely see more unhappy burried single core users. That setting the jobscheduler manually fixes many peoples' problems shows that the new threading protocol strains to accommodate all scenarios. (Again, I say, xbox 360 or later consoles! They're coming out with a new key pad and stick.)Anyway, I must admit I have a little bit of immature resentment for dual core users because of the threading issues which weren't present in rtm (I suspect i'm not alone in this?). The bleeding edge extreme core and quad core types also annoy me when they claim performance is acceptable with certain add ons. In a few years, we will have reached the fsx peak, but I still think further optimization of add ons can sometimes be ignored because a few users are reporting good results. But multi-core is indeed the way of the future and they are not at fault of course. I do think it's funny, though, that people have spent such ridiculous amounts on quad cores recently that won't be truly useful in terms of software coding until the time when they have become much cheaper.

Share this post


Link to post
Share on other sites

On my system, I get more headroom if I disable autogen, so I usually fly without it. But with autogen off, at a nice steady 20 fps, I get situations around Seattle where the detail tiles every once in a while refuse to appear in front of me, and this is not at 300 knots, but at 120 knots in the Cessna 172.It is somewhat repeatable as to location, so there must be something going on in the background that has FSX "taking its eye off the ball" so to speak. I've disabled all weather, but that was not it.Now, I can turn the scenery density to Sparse... but then it is not much fun flying around anymore... and even with Dense scenery, I get good framerates and smooth flying.

Share this post


Link to post
Share on other sites

Something interesting to try. The FIBER_FRAME_TIME_FRACTION seems to be dysfunctional in FSX. Try changing from 0.01 to 0.33 to 0.70 to 0.90. Nor blurries or FPS are going to change. Maybe something in the Fiber Frame Time Fraction was accidentally broken ?

Share this post


Link to post
Share on other sites

>Hello,>> Many of you, since SP1, have noticed that it was possible>to increase your auto-gen scenery density with a very very>small performance hit. However, you noticed that, since SP1,>the blurries have increased dramatically. Try this, disable>your auto gen, watch your terrain textures stay crisp even at>the highest speeds of 300 knots. I knew it all along, after>all the head banging, the new method of rendering the auto-gen>is indeed doing something wrong to the scenery loader. It's as>if the auto-gen is being prioritized from the terrain. Hmm..>anyone else has an opinion/useful experience and can comment>on this ?>>Thanks You're absolutely right. Even autogen on low will bring out the blurries. I found this out right after SP1 and wanted others to confirm. So it's a trade-off. You can turn autogen on full with reasonable framerates but you'll get the blurries. Some days I want my autogen other days I'd rather have the clear terrain textures. But with my system it's not both.P4 3.6 GHz HT 2 gb ddr ram X800XT PCIe 256 mb

Share this post


Link to post
Share on other sites

Well then, lets hope the devs are fixing it. Phil has responded in my other "The blurries are killing me" thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this