Sign in to follow this  
Guest laurent

Is anyone using YAGET in FSX?

Recommended Posts

Folks,I have just tried using yaget 0.94 (yet another google earth tool) in FSX to try and obtain a moving satellite map but I haven't been able to get this program to update the Google Earth kml file successfully. I have followed the author's instructions (including unchecking 'Pause on exit') but although the Google tracking file is created ok it is not updated (have set for 1 second updates), hence no update of the aircraft's position in Google Earth.Has anyone used this program successfully or can advise further?Many thanks.Paul(YPAD)AMD 64 +3800Inno 8600GT (256MB)2G DDR RAM19" Samsung 915NAsus A8N-SLI Deluxe

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi there Paul,As the tracking file is created I would guess on a connection pb between FS and the app.Make sure the reading display on the app. reads something like you're connected and after having used the "loop" button you can read a DMS position in the bottom reading area. As long as there's no DMS position displayed at the bottom of the app. there's no chances you can track your position in GE.The easiest way to be connected is :- launch FS- set a flight- launch YAGET- create an event in FS (i.e. Esc key then "continue")- use the "loop" button in YAGET- then make in yaget what you wish like print a position, save a path or track your positionHope this hels somehow ...laurentcIMO

Share this post


Link to post
Share on other sites

laurentc,Thanks for taking the time to reply.The yaget interface does display the changing coordinates, heading etc as the aircraft moves along and the trackfile is created initially ok (I viewed this in Notepad), it just doesnt seem to update the tracking file every 1 second so Google Earth position is stationary.Yaget, connects fine, I watch the messages about conecting, object data received, co-ordinates are good etc. I guess something else may be interfering but I run FSX on a Windows partition dedicated just to FSX and newly created. The only add-on I have installed is LevelD-767.As this is a new version of yaget I was just wondering if any other folks had used this yaget successfully so I know if its my installtion or something else.Paul

Share this post


Link to post
Share on other sites

Jim,Yes, I am using a laptop to access the yaget folder (shared out) on my main FSX Desktop, so GE refreshes every second ok but because the yaget track file is not being updated, while it is tracking the aircraft in FSX, the GE position doesnt change. Are you using yaget in FSX ok?Paul

Share this post


Link to post
Share on other sites

Hi again,Well, I would suggest two things :1)try yaget on the desktop if you've GE installed on it2)otherwise, in tracking mode - the kml file being narmally updated - try to open the file (notepad) every few seconds to verify whether or not the position is actually changed (bottom page). Take care : the file shouldn't allow to be opened unless you make a "copy" of it ...if it allows to be opened ... well, there's somethis amiss there !Let me know ... when I'm home I'll try to check the files and the zip but I'm pretty sure it all works fine having successfully tested it many times before I uploaded the file to the avsim library. Anyway I'll report here my investigations.BTW are you using XP or Vista ? I personally have made all my tests on a Vista PC (the worse case I think with all the securities involved with this OS)Cheers,laurentc

Share this post


Link to post
Share on other sites

Laurentc,Sorry, I should have mentioned that I am using Win XP SP2 and FSX with SP 1 installed. I dont have GE installed on the desktop at this stage though I will try that if necessary.I can actually open the tracking kml file using notepad (I used the original, not a copy) and the coordinates are there ok, it just doesnt seem to get updated once it is originally created? When I first downloaded the yaget file from Avsim I copied all the files from your zip and placed them into a folder that I then shared out on my internal Network so I could access it with my laptop (which has GE installed). I changed the permission on this folder too for write access (for GE) although that probably isnt necessary.The track.kml file is definitely allowing me to open it though.Thanks for your assistance.Paul

Share this post


Link to post
Share on other sites

I'm not home yet but I can surely say that the kml file being so easily opened indicates that the normal I/O operations aren't processed, otherwise it would refuse any attempt to open it during those operations.Two things can be done right now :- be sure that the "track" button is clicked ... ! I know, you surely have done it, eh, eh !- make a "search" of the kml file on the disks ... maybe your desktop use to put any new created file elsewhere ? I had those problems with yamm and vista who puts files in a specific file.Anyway, as I said, I will check my files at home, but I suppose many (?) other people would have complain about this sort of bug earlier, which never occured, of course.For the sake of precision, when you close yaget your kml file with position (can't even remember how I called it, eh, eh !) is deleted, isn't it ? And when you open a new session calling the "track" feature a new file is generated next to it ? The two others features, "spot" and "route" are working altogether ?Cheers,laurentc

Share this post


Link to post
Share on other sites

Ok : I'm home now and after a little snack (brain energy is needed at this hour) I went in the process of downloading the zip file and installing it.In short, all worked fine : I tried several combination like an install in the desktop folder, then in a disk folder ... I even tried to copy yaget in my second PC (LAN Vista-W98) and launch yaget from Vista ... all I did worked and I could get GE displaying my track.Unfortunally I couldn't try your config. for my W98 can't cope neither with FSX nor Google Earth and I haven't a laptop at hand.At this stage, I'm very sorry to say I can't see what's wrong with your installation. The only thing I'm sure of is that you shouldn't be able to open the kml file directly during the i/o operations.I'm not sure installing GE on your main FSX PC would solve the pb as yaget is a standalone program depending only on FSX data and the write file process is completely independant from it.Let me know for the delete file and the other features ...Sorry again,laurentc

Share this post


Link to post
Share on other sites

>Folks,>>I have just tried using yaget 0.94 (yet another google earth>tool) in FSX to try and obtain a moving satellite map but I>haven't been able to get this program to update the Google>Earth kml file successfully. I have followed the author's>instructions (including unchecking 'Pause on exit') but>although the Google tracking file is created ok it is not>updated (have set for 1 second updates), hence no update of>the aircraft's position in Google Earth.>>Has anyone used this program successfully or can advise>further?>>Many thanks.>>Paul>(YPAD)>AMD 64 +3800>Inno 8600GT (256MB)>2G DDR RAM>19" Samsung 915N>Asus A8N-SLI Deluxe>>Where did you get YAGET? It doesn't show up on Google search for me.

Share this post


Link to post
Share on other sites

... continued ...Here enclosed a debugging app. please install it as yaget and lauch it : it should yield a __DDEBUG.txt file with the operations being involved and a list of position points (like mine below).Let me know, sending your __debug file or reporting here.Mine :testYAGET : 1 flag:1 hr:0OnInitDialog m_user_timer_value : 1000CWriteFileBase::CWriteFileBase : constructor data_1839744CWriteFileBase::OpenFile 270887016CWriteTrackPath : constructor 1840992CWriteFileBase::Write 270887016CWriteFileBase::~CWriteFileBase fclose 270887016CWriteFileBase::~CWriteFileBase delete data_1839744CWriteFileBase::~CWriteFileBase 0CWriteTrackPath : destructor 1840992CFileElementaryOp::OpenFile : 3-123.02610 100048.52353 10-123.02610 100048.52353 10.../...-123.02610 100048.52353 10-123.02610 100048.52353 10253 3CFileElementaryOp::CloseFile : 0CWriteTrackPath : CGoogleEarth_InterfaceDlg : destructor 1839264http://forums.avsim.net/user_files/175703.zip

Share this post


Link to post
Share on other sites

Hi there,Yaget 0.9.4 is in the FSX/utilities avsim library for your convenience.Actually two items for a pb I suppose with the library managers, but identical files !Cheers,laurentc

Share this post


Link to post
Share on other sites

Laurentc,Thanks again for all your effort with this.I definitely have pressed the 'Track' button and immediately after pressing this I checked that the test_track_path.kml is created, which it is. This file is then deleted if you press the 'Track' button again later, which is correct from your description.I searched my Desktop (hidden files selected) and found no other *.kml files other those in the yaget directory and the original yaget zip file. I also verified again that I am able to open the test_track_path.kml file in notepad without creating a copy first.I am not sure what you mean by 'spot' and 'route' as the interface I have with version 0.94 do not have these controls but when I press the 'Print Position' function yaget creates a file called test_.kml which correctly reports the aircraft's current position. I downloaded your debug.exe file and saved that into the folder with the other yaget files but when I try to launch the debug exe I get an error that mfc42d.dll cannot be found. This error is probably because the missing mfc42d.dll is a debug version of mfc42.dll which I don't have on my standard version of Win XP but you probably do as you are debugging/programming, so unfortunately I cant offer a debug output.Everything seems to work correctly except that the test_track_path.kml isnt being updated. If any other user has reported that yaget works ok with Win XP and FSX then the problem is mine. It is odd though, as I said, my Win XP is a fresh install, with virtually nothing added other than FSX.Paul

Share this post


Link to post
Share on other sites

Laurentc and Paul,I am having the same issue with both the v0.93 and v0.94. The only thing I can add is that if I right click the actual network link and hit refresh the position does update in GE. All the other YAGET features work fine.GE 4.1.7087.5048WIN XP SP2FSX SP1Don't know if this helps or not.Mark S

Share this post


Link to post
Share on other sites

>Laurentc and Paul,>>I am having the same issue with both the v0.93 and v0.94. The>only thing I can add is that if I right click the actual>network link and hit refresh the position does update in GE.>All the other YAGET features work fine.Mark,As Jim mentioned in this Topic, you may just need to go to Google Earth and select an option to, 'Fly to new Position'. Right click on the Link for FSX in Google Earth and select 'Properties' to find this option. I dont have GE running at the moment (in Linux right now) but you will find it. Sounds like your yaget is working though, ie it is updating the test_track_path.kml file which is what my problem is.Thanks for your reply.Paul

Share this post


Link to post
Share on other sites

Hi there all, Mark and Paul,Two more questions and a zipped file with the missing dll while I'm searching for a cause of your problem :- have you tried it without any spyware, firewall and antiviruses enabled ?- can you place yaget in your laptop and launch it from your desktop and verify while an instance of yaget is running in your desktop whether or not the culprit klm file is produced and doing well in your laptop ? I did it yesterday and it worked fine with me ...Cheers,laurentchttp://balloon.flightsims.perso.cegetel.ne.../FsX/MFC42D.zip

Share this post


Link to post
Share on other sites

>- have you tried it without any spyware, firewall and>antiviruses enabled ?>- can you place yaget in your laptop and launch it from your>desktop and verify while an instance of yaget is running in>your desktop whether or not the culprit klm file is produced>and doing well in your laptop ? I did it yesterday and it>worked fine with me ...Laurentc,I diabled my Firewall, Anti-spam, Antivirus completely and ran yaget but the test_track_path.kml didnt update.I then copied the yaget files over to my laptop, shared out the folder and accessed that share from my Desktop. I could run yaget ok from my Desktop but the track file did not update again. The yaget gui shows the aircraft speed, changing location etc but doesnt update the kml file on the laptop (Win XP Home).I also ran the yaget debug exe with the mfc42d.dll you provided but receive another error about not having msvcrtd.dll.Thanks for trying anyway.Paul

Share this post


Link to post
Share on other sites

Hum ... I definitely need to see your debug report to see what's going on ...Here the missing dll together with the msvcrt.dll for the release version : verify you've it in the W system folder or simply copy and past it NEXT the yaget exe (and remove it when you're finished with your tests). Being next to the exe it is used instead any other dll elsewhere in the disk.http://balloon.flightsims.perso.cegetel.ne.../FsX/MSVCRT.zip

Share this post


Link to post
Share on other sites

>Hum ... I definitely need to see your debug report to see>what's going on ...>>Here the missing dll together with the msvcrt.dll for the>release version : verify you've it in the W system folder or>simply copy and past it NEXT the yaget exe (and remove it when>you're finished with your tests). Being next to the exe it is>used instead any other dll elsewhere in the disk.>Sorry to say this, but I put the dll files in the folder with the yaget exe and other yaget files and when I execute yaget debug exe there is another dependency file missing, this time its msvcp60d.dllPaul

Share this post


Link to post
Share on other sites

Yes, I should have known ... well right now it's a bit too late for me and I must leave to work, but asap I will post the rest of the dll needed, let's say this late afternoon GMT. The main goal is to get a debug file in the first place, then to make some mods in the exe and see if those changes are compatible with you. So you see there's still a lot to do. Sorry for that.Cheers,laurentc

Share this post


Link to post
Share on other sites

.../... BTW : I would suggets we continue this thread in a private mode until we have get through the trial and error process and a solution can be proposed to those having (if any ?) the same problem.Please email me (readme.txt : subject "yaget" for spam) and we shall continue with the files sharing and tests. http://forums.avsim.net/user_files/175718.zip

Share this post


Link to post
Share on other sites

Tracking not working here, file is not being updated, the data on the screen updates but not the position in GE, just the 1st position is correct ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this