Sign in to follow this  
Bunchy

OOM's are back in XP Please help...

Recommended Posts

After changing my MB and processor and installed a clean XP and FSX installation, my Out Of Memory errors are back. I have patched the FSX.exe file to use more of 2Gb and edit my boot.ini. I have physical 2Gb DDR2 ram on board.This is the content of my boot.ini file[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn /3GB /userva=2560I run at higher settings due the hardware upgrade and stable at 25 FPS and while online with FSINN after 15 to 20 minutes the OOM occurs. It seems to me that it only occurs when connected to VATSIM.FSX have a exclusive XP boot drive and I am also using FS-Autostart so there are is a minimum of back ground programs.Running programs,FSX with SP1Track-IRLive CockpitFsInnFsCoPilotHappy Landings... (as long there is no OOM on route)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Simba,I think you need to modify your FS9 and or FSX exe to enable the >2GB fix. What follows is a previous post on the subject. Hope it helpsStu.I got several Out of memory erros when I fly with the great Alphasim SR71 longer distances. Sometimes the error occured five minutes after takeoff. The error occured under SP1 too.So I tried a solution I found for make STALKER ready for run with Windows Vista. The solution seems to work with FSX too. I got no error on flights which crashed before regulary with OOM.Try this only if you have at least 2 GByte of RAM and at your own risk.First download the explorer from http://www.ntcore.com/exsuite.phpNext make a copy from fsx.exe. Than start "CFF Explorer" and open the orginal fsx.exe file.Now go to NT Header/File Header and click File Header. Ther you find a button labeld "click here". Click it. And select the mark at "App can handle> 2gb adressest "Save the modified EXE, overwrite the orginal one (You have youre copy saved?).If you run Windows Vista 64 or Windows XP 64 youre ready and didnt need to read on. The rest is only for Windows Vista 32 or maybe Windows XP.Now make Windows Vista (32-Bit) ready to support more than 2 GByte.Open a command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt" click right and select "run as administrator".Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command window and press enter.After that restart windowsFor Windows XP there is a similar setting for the boot.ini, but I have no Link to it, should be found be google.For me it solve the problem.Too reset the Increased User Adressspace just start the commandline prompt with Admin right again and enter "bcdedit /set IncreaseUserVA 2048"Please post youre results here, so we can see if this is a solution or a workaround only.ByeMarkusAuthor of GA-Traffic and AI Contrail Generator

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this