Sign in to follow this  
Guest mz-cd

Dramatic reduction in blurries: Texture Bandwidth Mult = 5

Recommended Posts

Hi,I remember reading somewhere that someone got positive results from changing their Texture Bandwidth Mult setting from 120 to 5 and noticed better texture loading performance.As usual I was very skeptical as nothing else I ever tried worked. I went ahead and tried that setting and WOW, the texture loading performance in my FSX seemed much improved and now I can fly up to 250kts quite easily without any blurred textures catching up to my aircraft! The textures load every time well ahead of it!Yes I still get blurries when flying faster, but in general my experience is that much better especially when flying the slower aircraft.Another interesting thing: I seem to now get much less micro-stuttering since the tweak.Whoever mentioned the Texture Bandwidth Mult adjustment I thank you!:)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Very weird...How did you get to 120?Default is 34 or 40 and shouldn't be set below 10 and beyond 40 according to Phil Taylor's blogQUOTEOriginally posted on fsinsider.com[DISPLAY]TEXTURE_BANDWIDTH_MULT=nWhere n can range from 10 to some reasonable value that is related to your frame rate limit.From Rafael Cintron, part of the FS Graphics and Terrain team, comes this description:

Share this post


Link to post
Share on other sites

Things don't work properly when a variable is set too high? Hmm, sounds like ACES got an integer overflow problem in the code that throttles texture throughput.I will try the same thing on mys rig running with Tileproxy, monitoring the "tiles per second" numbers.

Share this post


Link to post
Share on other sites

Yes I read this as well.If you read my post "I have to set the record straight" I said that I let the sim build a new cfg. file which worked well.The only 2 tweaks I have done is to include disable preload=1 ANDreduced the texture bandwidth from the default 40 to 5 [which I had read somewhere].This made a huge difference.HOWEVER I have experimented a lot with this setting and have found the following.I use the task manager a lot to keep an eye on things and one thing I have noticed is that if I have the applications page open and then start the sim it goes into "not responding" mode.NOW if I have the texture bandwidth set to something like 1250 this will only happen once and only for a second BUT the performance is poor.With the bandwidth set to 5 the sim when starting goes into "not responding" 3 times and on two of these occasions for some several seconds BUT the performance is good. Also the opening screen is displayed for some time.However the actual loading of the sim only takes 60/80 seconds.I do not profess to know what this means but what I do know is that with only a few exceptions my FSX with SP2 and Acc. is running well.I am sure that if I were in a position to install a bigger CPU I would be even better off. My Atlon 64 4200 dual core is running flat out most of the time.RegardsRichard

Share this post


Link to post
Share on other sites

UPDATE: I usually have frame rate locked at 20 and tried setting TEXTURE_BANDWIDTH_MULT to 5.I noticed no change in the loading speeds for tiles far from the aircraft (still getting 200 per second on this machine). The tiles closer to the craft seemed to load slower for me.So those people who currently have bad blurries should try this - but otherwise don't touch a running system ;-)

Share this post


Link to post
Share on other sites

That's very interesting Richard.It would be great to hear from others that have the texture bandwidth set to 5.This code line is full of mystery and surprises since FS9!!

Share this post


Link to post
Share on other sites

I was just about to post about this same thing.When I installed SP2, my performance got worse and I had graphics issues (black blocks, slow loading cockpits, green runways). I decided to install the 512 cirrus from FEX(instead of 1024). the cumulus were already 256. This helped quite a bit.Yesterday morning I decided to try the 1024 cirrus again and most of the problems came back. I remembered what someone here had said about deleting FSX.cfg and letting the system build a new one.I decided to just comment out all tweaks and revert TEXTURE BANDWITH MULT back to 30. I had set it to 60 when FSX first came out because it seemed to help.The first thing I noticed was that textures loaded much quicker. My cockpit loaded very quickly and the black squares were nearly instaneously replaced by their correct light textures.My screenshot utility still didnt work though and so I have decided to keep SP2 and just go with lower res FEX textures.please see thread "Chasing and shadowing jets"If you have tweaked your FSX config, then you might want to try commenting out those tweaks and see if that helps.

Share this post


Link to post
Share on other sites

I just tried this with some 1m photoscenery. Was running 40, tried 5. Didn't notice any improvement. No reason not for other people to try it, though.System: Core2Duo E6600, Nvidia 7600GS 512Mb, 2 Gb RAM, WinXP Pro

Share this post


Link to post
Share on other sites

Yes, I did post about this in June:http://forums.avsim.net/dcboard.php?az=sho...ing_type=searchMy feeling is that this continuous experimentation is an ongoing pain in the backside which detracts fron the enjoyment of the sim. Several of the variables mentioned in that post have since changed. However, the Texture_Bandwidth_Mult remains currently at 30 which seems best on my rig. Performance generally is not bad at all with frame rates capped at 20 and with minimal to no ground texture blurring.MikeASRock 939Dual-SATA2, AMD Athlon 64X2 4800+ (2400MHz)(Toledo), 2GB Crucial PC3200 DDR400 Ram 3-3-3-8 (2T)(Dual Channel), (PCI-E)Sapphire ATI Radeon X1950 Pro 512MB (Catalyst 7.10 WHQL), SB Audigy2 ZS Platinum (Drivers version 5.12.0001.1196 WHQL), Windows XP Home Edition (SP2), DirectX 9.0c

Share this post


Link to post
Share on other sites

Wouldn't it make life a whole lot easier if we all had exactly the same setups, then whatever worked for one would work for all.However the point of these discussions is to swap ideas and suggestions so it is always worthwhile telling everyone what works for you so that others can try the same.So if 5 works fine, if some other figure works then thats fine also.Here's another setting that puzzles me.I have always had my "Texture Max Load" [under graphics] set to 1024 but there is something else I change which drops this to 64 HOWEVER a setting of 64 seems to work fine so I have stopped worrying about it,although I am trying to find what it is I do that changes this setting.Ati RX800 TD256E PCI Express graphic cards.Also I have always had the Global setting at max but have now set it to minimum and that has increased my frame rate with no apparent detrimental effect on the visual look of the sim.What does this Global setting do??? and can you uncheck it within the cfg. file.??RegardsRichard.

Share this post


Link to post
Share on other sites

OK,heres an update on my other post.I read today that there was a DXWEBUPDATE [for NOV.] so have downloaded and installed this.The immediate apparent difference to FSX was a reduction in frame rates.SO I have INCREASED my texture bandwidth to 15 [from 5] and I have also introduced [JobScheduler] AffinityMask=3 [for a dual core] and this has returned the frame rates to about 40.I have also discovered [other people may know this already]that the Global texture in the sim IS in fact the texture max load in the cfg. file.I disabled this by placing 2 // in front of the line entry, but on restarting the sim it built a new line so I have left this at 64 which is,I guess the lowest setting [or can you have 32]?? or some other lower number. RegardsRichard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this