Archived

This topic is now archived and is closed to further replies.

Noel

If I install SP2, can I uninstall it with no untoward consequences?

Recommended Posts

Things are going well with SP1, but I would like to use FSWC which is impaired with SP1 only. I really don't want to have to reinstall FSX with SP1 if there are issues with uninstalling SP2 if it becomes problematic. What do you know?Thank you in advance for your insights,Noel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I uninstalled SP2 for FSX once. I didn't have any problems after doing so. I was trying to diagnose a problem that revealed itself while running FSX. Turned out to be a hardware issue. Since, I have gone back to using SP2. The changes from SP1 to SP2 seem to agree with my system and I like the enhancements SP2 implemented. Have you had problems running SP2 in the past? If so, what are your system specs? Just curious.Good Luck,KailFlightSimmer since 1987C2D E6850 3.0GHz 1333FSBXFX Nforce 680i LT SLI2x XFX 8800GT 512MB SLI'd4GB Crucial Ballistix PC6400 800MHzCreative SB Audigy2 ZSUltra Xfinity 600W SLI PSUSeagate 320GB 7200RPM 16MB SATA-3GB/S HDWindows XP SP2 / FSX SP2 / FS9 SP1

Share this post


Link to post
Share on other sites

>I uninstalled SP2 for FSX once. I didn't have any problems>after doing so. I was trying to diagnose a problem that>revealed itself while running FSX. Turned out to be a hardware>issue. Since, I have gone back to using SP2. The changes from>SP1 to SP2 seem to agree with my system and I like the>enhancements SP2 implemented. Have you had problems running>SP2 in the past? If so, what are your system specs? Just>curious.>>Good Luck,>KailThanks Kail. Have never installed SP2. As long as uninstalling SP2 doesn't "derange" SP1, I would be happy to try it. The idea of reinstalling FSX w/ SP1 again doesn't enthrall me, so thus far, we have one, your, testimony of no problems reverting back out of SP2 without a total reinstall.QX9650 w/ Retail HSF|ASUS P5E3 Premium WiFi|4GB Muskin Ascent 7-6-6-18 1T DDR3-1600|EVGA 8800GT|Seagate SATA 2 x 2|Seagate Cheetah 15K.x|XP Pro SP2|Vista 64--maybe never to be installed

Share this post


Link to post
Share on other sites

I have unistalled SP2 a couple of times as the result of reviewing products. I never had any problem with it that I could detect, but then I did not test SP1 very rigorously afterwards, as that was not my intent. Co-incidentally, I ended up re-installing FSX after de-installing SP2 each time anyway. My guess would be that if you have a lot of products that require SP2, you might see a bit of strangeness when you try to use them without SP2. However, things that don't require SP2 should run normally as per SP1. I hope that helps. I just take it as being understood that I will probably end up re-installing FSX periodically anyway, as sometimes that's easier than chasing all of the bugs. Jeff ShylukAssistant Managing EditorSenior Staff ReviewerAVSIM

Share this post


Link to post
Share on other sites

It helps . . . some!Actually, my primary interest is to see if FSX' bloom feature works more efficiently under SP2--on XP. I don't know if that is the case. The bloom HDR may only be something Vista/DX10 handles. Do you know if this is true, that bloom HDR is a Vista/DX10 effect only? I enjoy bloom effect with SP1/XP but as you know it is heavy on performance impact.

Share this post


Link to post
Share on other sites

If you want to uninstall SP2 with the intent of re-installing it, then you should have no issues, like for your test. I would say, just go ahead and try it for yourself. I suppose you could make a Restore Point to be double sure. Some people really hate Restore Points, but I think they are okay. My experience is that if a Restore Point actually made things worse, it was time to re-install XP anyway. Others' experience may vary.Bloom works in FSX from its original state all the way up to SP2 DX10. However, it's a system hog. From what I can tell, there's a marginal gain for bloom on SP2 from SP1 on XP. I'm not totally sure, as I bought a new video card at around the time I made the switch. I also think that the bloom effect is slightly more subtle in terms of the amount of "halo" around lights, which in turn might be the reason there's a mild performance boost.I run XP myself, so I can't comment on Vista DX10 bloom performance. What I have seen of it is that the bloom effects in DX10 are more advanced than in DX9, with a wider range of subtle effects. Apparently, bloom also runs better in DX10 than anywhere else. This boils down to a choice of aesthetics versus money for upgrades and time for working out the kinks in Vista. From what I have read, the actual gains you get in fps are not dramatic. Mostly, you just have room to increase the sliders before you start to lose frame rates.Jeff ShylukAssistant Managing EditorSenior Staff ReviewerAVSIM

Share this post


Link to post
Share on other sites

Thanks for that. I'd trade in a more subtle bloom for an improved performance profile. Maybe one more question: does SP2 take anything away from the typical SP1 user in XP? I've read so many more nays than yahs that this is why I am seeking guidance in this. Thanks again for your time and insights.QX9650 w/ Retail HSF|ASUS P5E3 Premium WiFi|4GB Muskin Ascent 7-6-6-18 1T DDR3-1600|EVGA 8800GT|Seagate SATA 2 x 2|Seagate Cheetah 15K.x|XP Pro SP2|Vista 64--maybe never to be installed

Share this post


Link to post
Share on other sites

I'm running FSX with SP2 in XP. I have no problems at all with it. Like I say I prefer to run SP2. I was testing and upgrading my system about 6 months ago and ran with SP1 for a bit. Then, while weighing the differences btwn the 2 service packs something in particular made me decide I was better off with SP2, but, I can't remember what. Now the add-ons I have are either fine with SP2 or specifically compatible with it. I wish I could remember what it was that sold the deal for me, it was one of those "oh, ok, I definitely want to run SP2" moments. Alas, my memory fails me. Like last night when, after doing a complete format and re-install of everything last week, I start up FSX and load a flight...I realize my toebrakes aren't working, and neither is the button on my yoke for parking brakes...what the heck??? I spent 15 mins testing control axis and assignments and buttons and levers....and then remembered I had added the hideinfotext=1 line to my fsx.cfg. What a Duh! moment. I even looked around to make sure my wife hadn't seen my frantic stupidity. I don't have to worry...she won't read this!!! She starts snoring when I start talking about my Flight Sim install, LOL!Good Luck,KailFlightSimmer since 1987C2D E6850 3.0GHz 1333FSBXFX Nforce 680i LT SLI2x XFX 8800GT 512MB SLI'd4GB Crucial Ballistix PC6400 800MHzCreative SB Audigy2 ZSUltra Xfinity 600W SLI PSUSeagate 320GB 7200RPM 16MB SATA-3GB/S HDWindows XP SP2 / FSX SP2 / FS9 SP1

Share this post


Link to post
Share on other sites

Well, it sounds like it might be worth it, thanks Kail. Do you have any sense about how SP2 affected LIGHT BLOOM performance in your XP installation?

Share this post


Link to post
Share on other sites

I haven't run light bloom yet. I have my scenery sliders and especially traffic turned up pretty high, I like busy skies. Since I hadn't had light bloom previously I figured I wouldn't miss it and I could probably keep performance up at my current settings if I left bloom off. However, since I've just re-installed everything and it's all pretty streamlined at the moment, I can flip it on tonight when I get home from work and see how well it works. I'll post here with my findings on performance and reliability.Until Then,KailFlightSimmer since 1987C2D E6850 3.0GHz 1333FSBXFX Nforce 680i LT SLI2x XFX 8800GT 512MB SLI'd4GB Crucial Ballistix PC6400 800MHzCreative SB Audigy2 ZSUltra Xfinity 600W SLI PSUSeagate 320GB 7200RPM 16MB SATA-3GB/S HDWindows XP SP2 / FSX SP2 / FS9 SP1

Share this post


Link to post
Share on other sites

Thank you Peter. I joke about my wife not being interested in Flight Sim, which she indeed is not, but, she supports me 100% in my enjoyment of it including the money spent on it, so I really am very lucky. Except for the dang frantic stupity. LOLAnd Noel, I just fired up the sim and flipped on bloom. I was panning around in spot view and jeez, I was almost blinded by a reflection of the Sun in a glass front bldg. It was really neat and pretty realistic. I looked around at all the lighting effects and saw no anomalies, no weirdness. I didn't do a long flight or anything, but did view the effects from all the positions I would through the duration of a flight without seeing any problems. It was quite a hit on performance though. Went from mid 30's in my particular testbed situation without bloom to high teens with bloom and no other changes. Hope this info helps in your decision!Blue Skies,KailFlightSimmer since 1987C2D E6850 3.0GHz 1333FSBXFX Nforce 680i LT SLI2x XFX 8800GT 512MB SLI'd4GB Crucial Ballistix PC6400 800MHzCreative SB Audigy2 ZSUltra Xfinity 600W SLI PSUSeagate 320GB 7200RPM 16MB SATA-3GB/S HDWindows XP SP2 / FSX SP2 / FS9 SP1

Share this post


Link to post
Share on other sites

Hope this>info helps in your decision!>>Blue Skies,>KailWell, I went for it, SP2 that is. Here's how they seemed to have increased performance of LIGHT BLOOM: they simply eliminated it from certain views, like VC view. Dunno if this is common among all video cards and drivers and PCs, but when I look at typical effects thru the windshield of the Baron 58, the bloom effects essentially go away. Go to 2D view, and it's back, maybe slightly dampened. I found overall sim performance to be very similar or the same. Since I like bloom so much, and often use it, I much prefer having bloom effects visible as is with SP1/XP/DX9. So, I uninstalled SP2, and don't seem to have any untoward effects. Further, I notice the scenery indices were rebuilt when I first opened FSX, and it seems to me the landclass might have been modified from my SP1 configuration. Fortunately, this seems to have been restored after uninstalling SP2, so, so far, all is cool. Thanks for your words on this issue.The most complex addon aircraft I have is the lovely Cessna 441 Conquest II with beautiful repait. I am able to fly it with bloom with frames about half the time at low to mid-20's, and the other half close to or locked at 30. I have seen as low as 18 with overcast cumulous cover in dense terminals. So far, the 169.19 drivers, XP2, SP1 seems to work the best.NoelQX9650 w/ Retail HSF|ASUS P5E3 Premium WiFi|4GB Muskin Ascent 7-6-6-18 1T DDR3-1600|EVGA 8800GT|Seagate SATA 2 x 2|Seagate Cheetah 15K.x|XP Pro SP2|Vista 64--maybe never to be installed

Share this post


Link to post
Share on other sites