Archived

This topic is now archived and is closed to further replies.

Mace

WOAI parking edits?

Recommended Posts

What needs to be done to fix the woai parking situation under fsx.I know that it is a radius issue, but that's all :) I'm sick of seeing my AI all over when they should be in certain places.Tim

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>What needs to be done to fix the woai parking situation under>fsx.>>I know that it is a radius issue, but that's all :) I'm sick>of seeing my AI all over when they should be in certain>places.>>Timedit the aircraft.cfg of all of your AI aircraft.look for the entry wing_span=(some number)edit this entry to make it match the real-world wing span of the aircraft in question. That's all there is to it.If you have lots of AI aircraft, it can take a little while to do, but it's WORTH IT in my opin. RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

Share this post


Link to post
Share on other sites

This doe snot seem to be working on the KBOS or KPVD that I have. I'm making sure the radius is correct (I"m assuming that wing spam is the full span)It seems that parking codes are being ignored as well. I'm setting UPS and FEDEX to park in RAMP_CARGO and they always end up at gates.Airline codes seem to be ignored too. It's a fluke that a JBU E190 or 320 ends up at a JBU gate :)This is universal not just at ADEf iles I'm tweaking, but even ones that I obtain from Avsim.Tim

Share this post


Link to post
Share on other sites

>This doe snot seem to be working on the KBOS or KPVD that I>have. I'm making sure the radius is correct (I"m assuming that>wing spam is the full span)>hi tim step 1:wing_span must be in FEET. Verify that you are using FEET in your wing_span entries for your AI aircraft.step 2:Tell me what KBOS and KPVD sceneries you are using, and I can see what is going on there.>It seems that parking codes are being ignored as well. I'm>setting UPS and FEDEX to park in RAMP_CARGO and they always>end up at gates.>In your UPS and Fedex AI aircraft's aircraft.cfg file, verify the following:atc_parking_types=CARGOatc_parking_codes=FDX (or UPS, respectively)wing_span=(correct value in FEET)Then, in your sceneries, such as KBOS, verify that the airport has RAMP_CARGO spots (use ADE,FSXPlanner,or AFX to check). Next, verify that these spots are of the correct size to park the aircraft. THIS is where many sceneries fall flat on their face, because designers are using old FS9 habits.For a UPS Boeing 757, you should see:wing_span=124.9...and your KBOS should have a RAMP_CARGO parking spot of 23 meters.If your KBOS has RAMP_CARGO spots of, say, 19m, 36m, 10m, etc. there is a good chance that the UPS 757's will *ignore* those spots (depends on your flight plans). Instead they will go to your GATE spots, if the GATE spots are near the 23m radius that 757's need.>Airline codes seem to be ignored too. It's a fluke that a JBU>E190 or 320 ends up at a JBU gate :)>Then something is amiss in your airport sceneries and aircraft.cfg's because...you can get every JBU E190 to park at the EXACT spots you want, every time. It's all 1's and 0's, the AI system operates with fixed rules and will behave predictably based on what data you send it.The trick is knowing how to config the data you send to the AI system.>This is universal not just at ADEf iles I'm tweaking, but even>ones that I obtain from Avsim.>>TimYes and sadly, many designers do not know how to properly set up parking and also concurrently, AI aircraft, for use in FSX.I will now look in the library for a KBOS and see if I can find the one you are using...unless you tell me, of course. :)RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

Share this post


Link to post
Share on other sites

Tim,I am going to guess here that you are using the only FSX airport scenery I could find of KBOS, and that is Ray Smiths KBOS. I'll go over the two airlines you are having problems with, UPS and JetBlue.-----------------------------------------UPS (United Parcel Service)UPS flies primarily B727,752,763,MD11,742,772, and DC10 aircraft. Here are the parking sizes that fleet uses:B727 = 17.0m parking spotB752 = 20.0m parking spotB763 = 24.0m parking spotB772 = 31.0m spotMD11 = 26.0m spotDC10 = 26.0m spotB742 = 30.0m spot(Reggie Fields has compiled a list of these...)I don't know what your flight plans are like going into KBOS, but lets say, for example, you have UPS 752's flying into there. For those aircraft, they would need atc_parking_types=CARGO. Secondly they would need atc_parking_codes=UPS. Thirdly they would need wing_span=124.9. These entries are all in the aircraft.cfg file for your AI aircraft.Ray's KBOS has two (2) spots designated for UPS. They are 24.0m spots, meaning they will park up to and including 767-size jets, assuming the user's AI aircraft wing_span entries are correct for those aircraft. Provided you have the aircraft.cfg set up properly (see above paragraph), the UPS Boeing 757-200's will park at those two spots if:1) they are not already occupied by other aircraft2) there are no other UPS coded spots that are 20.0m to 24.0m in radiusYou see, the UPS 757's would prefer a parking spot that is 20.0m, or 21.0m, or 22 or 23 meters in size OVER the 24.0m spot Ray has provided. But Ray Smith did this for a reason: he wants to insure that up to Boeing 767's can park there, which is wise in my opinion, since UPS flies a lot of 767's. Having the radius at 24 meters will be no means PRECLUDE any smaller aircraft from parking there--it will simply allow for headroom of larger aircraft.I've seen 727's (radius 17m needed) park in a 33.0m spot, since no others were available.FSX AI parking system works by set rules and a heirarchy about which I am touching on here.Getting back to Ray S's KBOS, he has also set up several overflow spots for cargo aircraft--some at 24.0m and a few at larger size for outsize aircraft. Again, this is all wise stuff to do. If the 3 designated UPS parking spots are filled, then FSX AI engine will look for any other CARGO type spots that are of the proper size. At Ray Smith's KBOS, it will find 3 just north of the UPS spots, and you might see overflow UPS aircraft there, depending on your flight plans that you have installed.--------------------------------------JetBlue (JBU)JetBlue flies A320's and E190's mostly if I recall correctly. Here's the parking those jets like:A320 = 18.0mE190 = 15.0mYour AI A320's will need atc_parking_types=GATE and atc_parking_codes=JBU and finally, wing_span=111.83.Your AI E190's will need atc_parking_types=GATE and atc_parking_codes=JBU and finally, wing_span=94.25In Ray Smith's KBOS, he has 3 spots specifically designated for JetBlue to park. All are 18.0m in size, which means they can park up to A320 size aircraft. Those 18.0m spots will indeed park the E190 as well, provided no other spots exist for JBU between the radius sizes of 15.0-18.0m. If for example, you make a 15.0m size spot coded with JBU, I can guarantee you that your JetBlue E190's would park there FIRST, before the 18.0m spots, if you had your E190's aircraft.cfg set up.Conversely, if you make a parking spot 14.9m in size, E190's will never park there.There are overflow spots for JBU at Mr. Smith's KBOS--one at 24m and one at 18m. I notice an unmarked 15.0m parking spot over at Terminal A. I would have to observe this to see if the JetBlue E190's would go over there. Really a lot of it depends on your flight plans. The only potential problem I see with JBU at this airport would be overflow and where those aircraft might be going. If they didn't go where they were supposed to, this could be fixed by setting up some 15.0m spots with JBU parking codes.And finally...with true FSX content, most of these things I listed above, should have already been done by the AI aircraft makers, and the AI flight plan makers. However, most of us, myself included still must use a lot of aircraft and plans from FS9 days, and that means we have to do extra work to get our AI working the way we want in FSX.Probably with FS11 everyone will be forced to move to new AI aircraft models so in a way that will be good, it will force us to have a common standard, instead of mixing and matching FS9 with FSX stuff, which is the situation we have right now.Hope that helps tim and I also think, if you read all of this, you are dedicated, and you deserve a gold star. :) RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

Share this post


Link to post
Share on other sites

I have a theory that I have not had a chance to try out.That is a situation similar to the AI in that any FS9 files will nullify the FSX ones. I think I have a few WOAI military afcads- FS9 style)I'll remove those tonight to see what happens.Since the issue is global- no matter the ADE file used, codes are ignored.I even tried a new KBOS from the default just changing the gate parking codes, radii are fine across the board both the parking space and the wing_span in the cfg.I used to be an expert at this under fs9 :) I lack the time to dive in with fsx as I once could. Having a baby does that :)Thanks!Tim

Share this post


Link to post
Share on other sites

Ah yes...the baby issue. My wife has a theory that when you are young and in school you learn all kinds of high and idealistic things. The meaning of life, and all that. You get out of school, get married, and have your first baby. All of a sudden you are brought down to earth hard and fast, because now your life revolves around baby c**p. The color and cosistancy of it control what kind of day you have, for both the mom and the dad. Congradulations, by the way.Bob

Share this post


Link to post
Share on other sites

She's 13 months now, but still- no downtime until 10PM on any give night...I seem to have found a rogue file causing the issues- I have just not narrowed it down to the exact rogue file :)Jim Vile's ATL- fine. Aircraft appear where they should, even my FDX and UPS jets.If I make a new KBOS using ADE 1.37 from the default, only changing the proper parking places with the new codes, FDX and UPS park at..... gates!Maybe it's ADE that is the issue? Maybe I'm crazy? Maybe my cat did it. Yeah, that's it. There's three of them and they travel in packs.....:)

Share this post


Link to post
Share on other sites

>She's 13 months now, but still- no downtime until 10PM on any>give night...>>I seem to have found a rogue file causing the issues- I have>just not narrowed it down to the exact rogue file :)>>Jim Vile's ATL- fine. Aircraft appear where they should, even>my FDX and UPS jets.>>If I make a new KBOS using ADE 1.37 from the default, only>changing the proper parking places with the new codes, FDX and>UPS park at..... gates!>Please post the flight plans you are using.Please post the aircraft.cfg files for your AI that you are using.As I said, the AI system only does what it is told to do. Yours is being sent incorrect data.RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

Share this post


Link to post
Share on other sites

An only it appears in Boston :)Go to either MEM or SDF and things are as they should be.I'll upload when able.Tim

Share this post


Link to post
Share on other sites

Another thing I was going to mention, since it only happens at KBOS, it is possible that there is a conflicting scenery with the KBOS you have.This can cause all manner of problems, from odd ILS behavior to parking issues to ...you name it. Without seeing the KBOS you have, I can't rule out something in the KBOS file(s) though, either.RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

Share this post


Link to post
Share on other sites

It's either the default BOS under Acceleration or a newly created file form the default. there is no additional file anywhere- believe me I looked :)

Share this post


Link to post
Share on other sites

You mean to tell me, that you have no add-ons installed at all?Because that's the only way you can be sure that nothing is messing with KBOS.You do realize, that you can have a bad bgl hundreds of miles from Boston, that can affect KBOS, don't you? That was the point I was trying to make.RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

Share this post


Link to post
Share on other sites