Sign in to follow this  
mgh

MINIPANEL PROBLEM

Recommended Posts

I have a problem with my minipanel displaying the default? gauges from MiniPanel.cab instead of the ones I want. The gauges displayed are the ASI, compass, altimeter, and VSI from MiniPanel.cab and not those in my panel.cfg file which follows:// Panel Configuration file// Hawker Cygnet// Copyright © 2004 Gerry Howard. All rights reserved.[Window Titles]Window00=Main PanelWindow01=Mini Panel[Window00]file_1024=Cygnet_Panel.bmpsize_mm=1024,768position=7visible=1ident=MAIN_PANELgauge01=DeHavilland_Comet!Turn_Slip, 465, 550gauge02=DeHavilland_Comet!Altimeter, 642, 458gauge03=Spirit_of_StLouis!spirit_asi, 465, 410gauge04=HG_Trim_dig, 840,700,57,21gauge05=Sopwith!clock, 655,600,92,92gauge06=Spirit_of_StLouis!spirit_rpm, 300, 458gauge07=Spirit_of_StLouis!spirit_oil_pressure, 150, 650gauge08=Spirit_of_StLouis!spirit_oil_temp, 230, 650gauge09=Spirit_of_StLouis!spirit_mag_switch, 180, 530gauge10=Spirit_of_StLouis!spirit_fueltap, 675, 690gauge11=Vickers_Vimy!compass_popup, 465,680,120,90gauge12=Piper_J3Cub!fuel, 513, 191[Window01]position=7size_mm=1024,100child_3d=1background_color=0,0,0ident=MINI_PANELgauge00=Spirit_of_StLouis!spirit_asi,0,0gauge01=DeHavilland_Comet!Turn_Slip,102,0gauge02=DeHavilland_Comet!Altimeter,417,0gauge03=Spirit_of_StLouis!spirit_rpm,500,0[Default View]X=0Y=0SIZE_X=8191SIZE_Y=6143Day=255,255,255Night=233,108,107Luminous=201,64,64Thanks in advanceGerry

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Because the ident is MINIPANEL, not MINI_PANEL :-)Rob Barendregt

Share this post


Link to post
Share on other sites

>Because the ident is MINIPANEL, not MINI_PANEL :-)>>Rob BarendregtI'd tried that. Setting "ident=MINIPANEL" results in no gauges being displayed!!!Gerry

Share this post


Link to post
Share on other sites

Hi,Try ident "SMALL" (read it somewhere) or , more difficult way: 1. rename MiniPanel.cab 2. make a new folder under gauges called MiniPanel3. put in here the gauges you want.(Not tested)Hope it helps.Jan"Beatus Ille Procul Negotiis"

Share this post


Link to post
Share on other sites

Thanks, but SMALL still just shows the MiniPanel.cab gauges.Gerry

Share this post


Link to post
Share on other sites

Hi,Just for curiosity I tried to change the gauges in the minipanel and I succeeded, two ways.What you 'll have to do is (I tested only XML gauges):1. Uncab the Minipanel.cab in a new folder under Gauges and name that folder MiniPanel; give Minipanel.cab another name!2. Put your wanted xml gauge with the proper bitmaps in that folder e.g. PFD.xml.Rename the existing Attitude.xml to something else and lastly,3. Rename PFD.xml to Attitude.xml Back to FS you will see that the attitude indicator is replaced by the wantes gauge.You also can change the panel.cfg in the minipanel section.You find that panel.cfg in the folder:FS/aircraft/default/panel.cfgHope it helps,Jan"Beatus Ille Procul Negotiis"

Share this post


Link to post
Share on other sites

Thanks. It gave me a clue and I've now got the gauges I want displayed.I changed the FS9/Aircraft/Default/Panel.cfg by commenting out the default gauges in [MiniPanel02] and replacing them by the gauges I wanted and set "ident=SMALL".This isn't satisfactory because it's likely to affect other new aircraft.Does anyone know if there is a setting in FS9 to overide using the default panel.cfg?Gerry

Share this post


Link to post
Share on other sites

Gerry,Your original post should work OK (except for the superfluous "_" in MINI_PANEL)No need to edit the default minipanel.What you can try:1. Does the minipanel function work OK in the default B747-400 ?? (you'll see the two square B747 gauges).2. If so: Cut&paste this WIndow06 section from the default B747 panel.cfg into your own panel (replacing your minipanel definition), and see if that works now....Very strange.I've tried it with a few other aircraft (changing the minipanel def. in the original panel.cfg of those aircraft) and there's no problem at all.Rob

Share this post


Link to post
Share on other sites

I'm afraid not of your suggestions actually worked but they led me to try a different value for the window id.I changed:Window01=Mini Panel to Window04=Mini Paneland[Window01] to [Window04]with ident=MiniPanel.I restored Defaultpanel.cfg to its original value and I got the gauges I wanted.Resetting 04 to 01 results in no gauges being displayed.I don't know why this should be but it works!!!Thanks allGerry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this