Sign in to follow this  
n4gix

ADF Standby Freq

Recommended Posts

Having tried using A:ADF STANDBY FREQUENCY in a gauge I found it just mimics the values for the A:ADF ACTIVE FREQUENCY - both values alter when you retune.Has anyone a suggestion for setting and swapping the Active and Standby frequencies? I tried some code posted here some time ago but it didn't work..

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,You need to "build up" the ADF STBY FREQ with custom variables.8 click positions with:(L:adf 0.1,number) 1 - 0 max (>L:adf 0.1,number)(L:adf 0.1,number) 1 + 9 min (>L:adf 0.1,number)(L:adf 1,number) 1 - 0 max (>L:adf 1,number)(L:adf 1,number) 1 + 9 min (>L:adf 1,number)(L:adf 10,number) 1 - 0 max (>L:adf 10,number)(L:adf 10,number) 1 + 9 min (>L:adf 10,number)(L:adf 100,number) 1 - 0 max (>L:adf 100,number)(L:adf 100,number) 1 + 17 min (>L:adf 100,number)etc.Say the end result is:(L:adf 0.1,number) 10 / (L:adf 1,number) + (L:adf 10,number) 10 * + (L:adf 100,number) 100 * + (>L:ADF STBY FREQ,number)Read with:%((L:ADF STBY FREQ,number))%!06.1f!Then in the "transfer" switch: (L:ADF STBY FREQ,number) d 10 * 10000 % int d 10 % r 10 / int d 10 % r 10 / int d 10 % r 10 / int 16 * + 16 * + 16 * + r 1000 < if{ (>K:ADF_LOWRANGE_SET) } els{ (>K:ADF_HIGHRANGE_SET) } Works ok for me.Hope it helps,Jan"Beatus Ille Procul Negotiis"

Share this post


Link to post
Share on other sites

Thank you yet again Jan..I take it that the listed A: variables and K events don't work as intended?

Share this post


Link to post
Share on other sites

HiNot sure if this will helpBut I had a bad time trying to get radios ect to work in FS9and found if you remove the whole radios section from the aircraft.cfg what didnt work would work cheersWozza

Share this post


Link to post
Share on other sites

An interesting comment Wozza.When I made the Tiger Moth for FS2002 I didn't include a Radio section in the aircraft.cfg file because the early aircraft had no electrics or radios. Some time later I had an email from a user asking why the marker sounds came on when flying over some airports.My testing showed that without a Radio section in the cfg file ALL navaids are active by default - even if you have no kit in the aircraft to use them! To disable the radio functions you have to add a Radio section that tells FS that you don't have anything:[Radios]// Radio Type = available, standby frequency, has glide slopeAudio.1 = 0Com.1 = 0, 0Com.2 = 0, 0Nav.1 = 0, 0, 0Nav.2 = 0, 0, 0Adf.1 = 0Transponder.1 = 0Marker.1 = 0

Share this post


Link to post
Share on other sites

Hi BonesYep thats right but when you have the radio section in FS9 locks them down for autotune (Im not sure if this is the case for adf )but the radios cant be mouse or keyboard tuned unless you set up an xml gauge which uses the set command for each possible channel.I found that by removing the radios section all the items can now be manually changed,but autotune still works.This made it much easier to knock up a remote radio panel to tune the radios.As you have found out the only way to disable them is via the radio section,alas as with every thing in FS9 there are compromises.CheersWozza

Share this post


Link to post
Share on other sites

>Hi Bones>Yep thats right but when you have the radio section in >FS9 locks them down for autotune (Im not sure if this is the>case for adf )but the radios cant be mouse or keyboard tuned>unless you set up an xml gauge which uses the set command for>each possible channel.??? I've never found any case where keyboard tuning has been disabled... ???

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this