Sign in to follow this  
slip-stream

Freeware Chinook (fsx) over torque problem... help!!

Recommended Posts

I have a problem with over torque (or so I think). For instance, my collective is fully down and have approx 28 percent torque, which I believe is normal. I am having problems slowing the beast down in order to land. I pull back on the stick but I just gain height. I can fly perfectly with zero collective.If I slow down to a hover with zero collective then it will very, very slowly descend. Would it not be normal for it to freefall out of the sky?I assume something is wrong somewhere. I am using the MRVS copycat controls and have calibrated properly.Everything is fine with the default Jet ranger.Any ideas, tips, perhaps changing some values in the aircraft cfg perhaps. Thanks guys.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You are in the wrong forum.Contact the author for support, or post in the general forums to ask other users for help, this forum is for panel and gauge development.

Share this post


Link to post
Share on other sites

Technically... it's for "Aircraft and Panel Design". *runs before he gets smacked!*

Share this post


Link to post
Share on other sites

>You are in the wrong forum.>>Contact the author for support, or post in the general forums>to ask other users for help, this forum is for panel and gauge>development.>Well, I looked at the AIRCRAFT DESIGN words and put 2 and 2 together. I assumed that meant designing the flight characteristics also.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this