Sign in to follow this  
Guest JoeW

Filling an area with textures

Recommended Posts

Hi all,This is my first post to the forum but I'm here for a couple of weeks and I've learned a lot already.I've started a little project for myself to try all these design techniques discussed here. I thought a virtual island would be best. I've done the mesh terrain and started to create the coast lines with surf etc. , filled the cell with water and some of the area with land.My question is, how can I fill / 'draw' textures for the land areas other than creating lanclass files already? I want to use the landclass feature later for the details like villages and fields etc. I've attached a screenshot of the scenery so far. I used a landclass to test whether the land/water mask works. It does:-) But again, I would like to cover all the mountains in one shot with textures. Is that possible? Is that a VTP matter at all?Thanks in advance,Rainer

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Rainer.It's much easier to just make a landclass file, than to try to use VTP polys. John Cillis' landclass assistant should make quick work of it, and all the autogen will be properly placed, as well. Also, VTP's are not automatically blended as the landclass tiles are.Use a value of 254 for areas in which you don't want to change the default landclass, and fill the rest as you see fit.You can also make a waterclass BGL for reefs surrounding the island, and for inland water. Again, use 254 for unchanged areas.Be sure to use the OLD resampler... the newest version is buggy.Dick

Share this post


Link to post
Share on other sites

Hi DickThanks for your reply.>You can also make a waterclass BGL for reefs surrounding the >island, and for inland water. Again, use 254 for unchanged >areas. I dream to do this, but how? John Cillis' Landclass assistant has only 5 values for water and they seem to follow a different naming convention (?). I've also noticed before that using Landclass assistant for water overwrites the land textures and doesn't blend.I want to get the tropical water textures as in the SDK Water Texture Classification.How do I get those into the raw file for use with resample.exe?Thanks,Rainer

Share this post


Link to post
Share on other sites

Hello Rainer,To make water class with the Cillis Land Class Assistant, do not use the 5 water values in the land class list.Instead, make the raw file using the water class values in the SDK documentation. Please note that one of the values does not have a corresponding texture (in fact, all the series 012 textures seem to be missing.)Also, keep in mind that Land Class Assistant uses a 256x256 array, so all your values will be incorrectly placed by 1 unit in the horizontal and vertical axes. Just correct for this by shifting your values over and up.Then, do not use the inf file that is generated. Modify it to the following:Type=WaterClassU8and compile it. You will get a bgl and better effect.Here, for example, is Santo Domingo default:http://ftp.avsim.com/dcforum/User_files/3e0eee35457d2c65.jpgThe light blue water runs all the way up the rivers.And here is the modified land and water class:http://ftp.avsim.com/dcforum/User_files/3e0eee8e4714d901.jpgA plume of sediment flows out. Modifications of water class can add much detail and realism.Best regards.Luis

Share this post


Link to post
Share on other sites

RainerDo a search here at avsim for Joe Watson, Or catalog.zip. It has all the tiles that are in Fs2002 with pictures and numbers. You can just place 113, or 121 for the cities or 102, or 105 for residential ares. This is a must have for people doing landclass.This was a spin-off from the Florida Landclass that Bob Brown and I did some months back.Joe W.

Share this post


Link to post
Share on other sites

I would like to add some small crop fields very close to my airport as they are important for VFR flying. The landclass assistant way isn't detailed enough to place them correctly. I suppose using method 2 VTP polygons and existing landclass textures for suitable crop areas would be a suitable solution to the problem. Dick mentioned it as a possibility in another thread. I have changed the shape of the airport skirt polygon using edited LWMdraw files (changes earlier explained by Ken) and that works fine - I just can't figure out how to change the textures on polygons to use landclass textures...? Can someone explain how to do this, preferrably with a small example?BamceEFHN

Share this post


Link to post
Share on other sites

Hi Bamce.Here's a rough oval shape in the desert... made using LandClass value #36 ( Rice Paddy And Field ), as listed in the SDK:include TDFMacros.incinclude TDFHeaders.inc; N31* 25.86' E26* 2.97'; VTPm2Poly1BGLHeader 33, 29, 28, 24, TerrainHeaderStart, VTPHeader VTPHeader label word VTPFileHeader 256, VTPIndexStart, TextureStart, VTPEndVTPStart label word datamark_v0 label word VTPDataArea 1, 1, 0, 0 VTPLayer 4, 0 VTPNumTexturesInLayer 1, 0 VTPTextureId 0, 0 VTPPolyCount 1, 0 VTPPolyMethod2 12, 0, 0 VTPPointXY2 8747, 8900 VTPPointXY2 8779, 8908 VTPPointXY2 8797, 8925 VTPPointXY2 8800, 8950 VTPPointXY2 8793, 8974 VTPPointXY2 8775, 8986 VTPPointXY2 8753, 8991 VTPPointXY2 8724, 8985 VTPPointXY2 8708, 8969 VTPPointXY2 8700, 8950 VTPPointXY2 8709, 8920 VTPPointXY2 8730, 8905 datamark_v1 label word; ---------------------------------------------------------------------------------------------------------Cellv_439_166 EQU VTPCellID 0, 439, 166 VTPIndexStart label word VTPIndexHeader 1, VTPIndexData, VTPStart VTPIndexData label word VTPIndexEntry Cellv_439_166, VTPStart, datamark_v0, datamark_v1; ---------------------------------------------------------------------------------------------------------TextureStart label word VTPTextureListHeader 1, TextureIndexStart, TextureDataStart, TextureDataEndTextureIndexStart label word VTPTextureListEntry TextureDataStart, texturemark_0, texturemark_1TextureDataStart label word texturemark_0 label word VTPTextureName "36" ; Rice Paddy And Field VTPTextureType 1, 0, 0, 4 texturemark_1 label wordTextureDataEnd label word; ---------------------------------------------------------------------------------------------------------VTPEnd label wordAny valid landclass number can be used. If #252 ( CUSTOM with seasons ) or #253 ( CUSTOM w/o seasons ), then you must supply the correctly named CUSTOM textures for the groundtiles covered by the poly ( LOD13 Areas ).If you want to supply your own texture, you can name it, but be sure to use 6 texture names for all the seasonal variations plus night, as the SDK indicates ( note, they are separated with semicolons, not commas ):TextureDataStart label word texturemark_0 label word VTPTextureName "Santa.bmp;Santa.bmp;Santa.bmp;Santa.bmp;Santa.bmp;Santa.bmp" VTPTextureType 1, 0, 0, 4 texturemark_1 label wordTextureDataEnd label wordHere's a screenshot of the BGL... Note the 2 autogen buildings supplied by the Landclass texture. The autogen doesn't match the texture, as the texture is vertically flipped when displayed by VTPs.. a bug in the terrain engine. If this is a problem for a small scenery, the best fix, is to use #252 for CUSTOM, then just copy and rename the correct landclass textures to the proper CUSTOM names. Then copy the autogen, and rename properly, then extract the main texture mip with imagetool, vertically flip with a paint program ( or XnView ), remip with imagetool... then place the autogen and flipped textures into the "C:Program FilesMicrosoft GamesFS2002SCENEDBWORLDTexture" folder with all the landclass and autogen.Now it will show the correct texture with the correct autogen. The BGL itself can reside in any valid scenery folder. You can download the latest versions of TDFCalc and LandCalc HERE.Dick

Share this post


Link to post
Share on other sites

Thanks Dick - that did it! I actually had it correct from the beginning, but I had been using the wrong landclass number! I used a number from the terraintextures sdk, and it happened to coincide with the surrounding landclass. Didn't realise I had a texture on a polygon there - thought the polygon didn't show up... As soon as I found Orlandos list of LC numbers i realised my mistake, and now everything works. The fields look ok and my airport skirts and surroundings are almost finnished. Thanks for your kind help! Next, i will try to apply some photoreal textures using the method you described (VTP2 polygon, autogen and then flipped 8bit texture with alpha) to make the nearby town look correct. I've done it using TerraScene for Fly! so I have good pic - I'll just split it up into suitable pieces for this purpose and add the autogen and the alpha channel to it... It will cover a total of some 30+ LOD13 areas. The TDFcalc and Landcalc programs are very, very helpful in this job! Thank you for those utilities!BamceEFHNhttp://fisd.fsnordic.net/

Share this post


Link to post
Share on other sites

Guys,Many thanks to you all for your help and support. This forum is really great and I've learned my first lessons. Mesh Terrain, coastlines, Landclass, Waterclass and more.At the beginning of this thread I had posted a screenshot and here's is one that shows the progress but most of all it shows all the things that you've teached me.Thanks again - I'll stay here for sure.Rainer

Share this post


Link to post
Share on other sites

Luis said, "Instead, make the raw file using the water class values in the SDK documentation. ".I give up! Have looked and looked but cannot find which SDK document discusses water class values.Can anyone tell me?Joe Sumrall[big]B[/bIG]USH [bIG]F[/bIG]LYING [bIG]U[/bIG]NLIMITED ...at home in the wild

Share this post


Link to post
Share on other sites

Dick,Thanks, pal! Never would have figured it out. I have the fs2000 terrain SDK.There is such a mix of 2000 and 2002 SDKs! Some are updated for 2002 and some are not.By the way, the link you kindly provided has one too many http:// in it. I figured it out.Thanks again,Joe Sumrall[big]B[/bIG]USH [bIG]F[/bIG]LYING [bIG]U[/bIG]NLIMITED ...at home in the wild

Share this post


Link to post
Share on other sites

Hi Luis,I tried following your suggestion about modifying the waterclass in my scenery, but I can't get it to show me any difference. I used Landclass Assistant, and changed the inf file to read WaterClassU8 and I drew some landclass areas and then did a find/replace in LCA 1.3 to use the texture number 001 and 007 (I tried both and neither did anything). I put the files in a separate folder from my other scenery and didn't include a "texture" folder like a good boy. I can get landclass changes for this area to show up, but not waterclass. Any idea what I'm doing wrong?thanks,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this