Sign in to follow this  
Adam Szofran

Problem with FSX and default water

Recommended Posts

Hi all!I'm trying to convert my high-resolution sceneries with the FSX resampler and ran into a problem: The water is always darkblue (deep?) although the water in the default-scenery is lightblue (shallow?). Here's two shots:My FS9 scenery used in FSX - here everything is OK and the water is lightblue like the default scenery.http://forums.avsim.net/user_files/161395.jpgAnd here the FSX scenery - obtained from the same data! (water = RGB(0,0,0) and Alpha-Channel 0). The water is there but it is darkblue!?http://forums.avsim.net/user_files/161396.jpgPlease help!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

i saw the same problem, but it wasn't dark blue water texture. No idea so far what is going on.Here is my phototexture with alpha mask (I didn't set the alpha above the freeway area): http://forums.avsim.net/user_files/161570.jpgIt has turned texture to milky white, instead of the default deeper blue.The default is a vector hydro poly set to generic river - perennial. the underlying waterclass is 19.scott s..

Share this post


Link to post
Share on other sites

Did you set the RGB value of the water-bodies to (0,0,0) (Black)?The water works on my side, but the water-class seems to get lost :-(

Share this post


Link to post
Share on other sites

I found a solution!I use a blend-mask (= 5th channel) with the same values as the land/water mask. This preserves the water class :-)

Share this post


Link to post
Share on other sites

That is strange behaviour if you ask me, at least compared to FS9. I use "the GIMP" for images. It could read the 5 channel example off the SDK, but I haven't tried to build the 5th channel yet (I'm not 100% on channels and GIMP at this point -- figuring out how to set the alpha was work enough).scott s..

Share this post


Link to post
Share on other sites

Scott,I think, the 5th channel is not necessary for inland water. Did setting the RGB-color to 0 (additionally to the first land/water alpha channel) work in your case?

Share this post


Link to post
Share on other sites

With the FS9 Resample tool, the water mask punched a hole in your image to reveal default water beneath.With the FSX Resample tool, we wanted to allow more flexibility, so we changed how the water mask works and we also added a blend mask. Now the water mask triggers reflective and specular water effects, but it doesn't punch a hole in your image. The benefit of this is that you can now paint the water any color you want. For example, if your source imagery contains murky brown swamp water, you can now get the muck to show up in FSX with reflections and specular effects. If you'd rather just see the default water colors, you have to use a blend mask to punch a hole in your image to reveal the default textures below. Note, however, that the default textures revealed by the blend mask might not be water; they could very well be land textures! Therefore, if you want to guarantee that the blend mask will expose default water textures, you need to create a water polygon (a big square one will do) that covers the area where you want water to appear. For information about creating water polygons, look for the documentation of the shp2vec tool in the FSX SDK.Good luck,Adam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this