Archived

This topic is now archived and is closed to further replies.

scruffyduck

Rwy12_multple objects

Recommended Posts

I'm new to Rwy12 although familiar with SBuilder. I'm using Rwy12 to place three objects using the 'Add' button to group these (as per the tutorial). I save the .xml file before generating a .bgl. My problem is that the scenery contains only the last object in the group, not all three. I guess I could create separate .bgl files for each object but that can't be right! BTW, I'm running FS9. Any help would be appreciated.John

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You should not need to have them in separate bgl files. Have you looked at the xml? How many objects does it contain?

Share this post


Link to post
Share on other sites

Thanks, Jon. The .xml has three objects. I maybe should have said that I was trying to modify an Addon scenery, not the default scenery. I removed buildings from the Addon scenery by disabling a .bgl in that scenery. I then attempted to place two new buildings at approx the same coordinates as the old ones. A third building, the warehouse, I placed some distance away and this is the one which displays. However....I've now discovered that the coordinates for the original addon scenery which I was trying to modify are are badly out. So, I made a new scenery at the correct location using SBuilder. Now I've got new problems. The default FS9 scenery is showing alongside my new scenery (prototypical grass airfield, corrected river, roads, railways, forest areas). I placed my new scenery in a folder in the Addon scenery directory and I activated it in the usual way in the Scenery Library. It should get priority therefore. I'm not sure what has gone wrong.

Share this post


Link to post
Share on other sites

Your missing objects sound like an exclusion issue. If you have other third party addon scenery then it may contain exclusions to remove stock objects. If you new scenery is at a lower priority than the addon any exclusion rectangles in the addon scenery will remove your new objects from view.Again if you are working with addon scenery and stock scenery there is a great opportunity for things to go wrong. It sounds from what you are saying that there is a stock (default airport), an addon airport and your custom airport all in the Sim - is that right?

Share this post


Link to post
Share on other sites

Sorry Jon, it's not quite so bad as that! Your explanation re exclusions makes sense. However, I've given up my original attempt to replace buildings in the addon third party scenery. I've deleleted that scenery because I found out it was in the wrong place. Since then, I've made a completely new scenery at the correct location using SBuilder. This new scenery has nothing to do with the third party scenery I posted about at the start. So I only have the default scenery and my new scenery. I modified rivers, roads, forests, etc, and made an open area for the new airfield. I used Google Earth as a guide for all this. The problem now is that the default FS9 scenery and my new Sbuilder scenery are both displaying. In other words, where I have moved the course of a river, I now have two rivers, the default one, and my modified one. The same goes for all the other mods I've made! I'm not sure what has happened with this. If you can help again I'd be grateful.John

Share this post


Link to post
Share on other sites

>Sorry Jon, it's not quite so bad as that! Your explanation>re exclusions makes sense. However, I've given up my original>attempt to replace buildings in the addon third party scenery.>I've deleleted that scenery because I found out it was in the>wrong place. >>Since then, I've made a completely new scenery at the correct>location using SBuilder. This new scenery has nothing to do>with the third party scenery I posted about at the start. So I>only have the default scenery and my new scenery. I modified>rivers, roads, forests, etc, and made an open area for the new>airfield. I used Google Earth as a guide for all this. The>problem now is that the default FS9 scenery and my new>Sbuilder scenery are both displaying. In other words, where I>have moved the course of a river, I now have two rivers, the>default one, and my modified one. The same goes for all the>other mods I've made! >>I'm not sure what has happened with this. If you can help>again I'd be grateful.>>JohnDid you create exclusion polys in SBuilder to exclude the original scenery elements? Sound like you may have just created a new scenerry without excluding the old?

Share this post


Link to post
Share on other sites

Exclusion polys? Hmm...no. How stupid of me. What's the best way of doing this at this point? I've around a hundred scenery polys of various kinds. Can I make large exclusion polys over these? Thanks again, Jon.

Share this post


Link to post
Share on other sites

I think it needs someone with a better understanding of this to answer. But as I recall terrain exclusions operate on a specific LOD area and provided that the exclusion poly includes a part of the LOD area then the specific elements will be gone.

Share this post


Link to post
Share on other sites