Sign in to follow this  
Leen3131cs

Need some more help here

Recommended Posts

I just got my computer back from the shop. It's now nicely upgraded and I was anxious to see how much better Fly!2 would run.The program loads up great...... the little "fuel gauge" fills up snappily. Unfortunately, that's as good as it gets! As soon as it loads up, I get a DirectX8 3D Driver Error: "DrawIndexPrimitive SVertex failed" message.I ran DX Diagnostics and everything checks out fine. I'm using the same video card as before the upgrade (GEForce2 Ti), the same Op. System (Win98SE), the same video drivers (ver. 29.32 I think), the same DX 8.1, and Fly!2 was working OK before the upgrade. So now what could the problem be? I upgraded from a P3 700 mhz, 320mg SDRAM to P4 2.4G,512mg DDR RAM with a new 300 watt power supply instead of my old 250 watt power supply.Any suggestions?Thanks in advance.-Lindy :-wave

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Lindy,Disable anti-aliasing and try again.A remember it worked for me once, and after some adjustmentsit could be abled again.greets

Share this post


Link to post
Share on other sites

I also saw the same message when I changed some settings in the ini file. I think the message refers to not having enough texture slots assigned. Maybe this will trigger something for someone else to comment on?Pete

Share this post


Link to post
Share on other sites

Hi Lindy,Are you running the 230 version of Fly II? Try changing the render option to DX 8 instead of DX 8 T&L. If that corrects it, then try re-installing DirectX 8.1 and see what happens. I assume you also had a new mobo installed as part of the upgrade and left the HD with the OS and software installed as it was prior to upgrading? I don't think that is the cause of this problem but I have not had good luck with that approach. I've always done a format and fresh install of OS and drivers anytime I've changed motherboards. On the plus side, Fly II will run great on your system once you get it straightened out. Fly II and "the other sim" both run very smoothly on my current system.Good luck.Athlon 1800+, Gygabyte GA7VRXP512 meg PC2700 Corair ram, Win 98SEVisiontek G3, Nvidia 30.82Soundblaster Live

Share this post


Link to post
Share on other sites

If you have not changed drivers, os or any other software, but the motherboard and cpu, then it might be in your bios. Look at the AGP aperture setting and make sure that it's not too low( try 32 or 64 meg).tony

Share this post


Link to post
Share on other sites

Hi Lindy,You might want to try downloading the latest driver from nvidia 40.72 my frame rate increase significantly from 14fps to 25 fps.here's the link.http://www.evga.com/support/downloads/default.aspchris salviejo rpllsoyo kt400corsair xms256 pc2700140gig hddgforce2 mx400directx 8.1windows mefly2 patch 230ch usb yoke/pedal

Share this post


Link to post
Share on other sites

... so I tried it. I changed my start up to just DX8 (no T&L) and the program runs fine. I then re-installed DX8.1 and tried Fly!2 again. No go. :-( I got the same message.Now I truly am stumped as to what the problem could be.On the bright side however, I CAN run it w/o the T&L enabled, but darn it all I really do like that nice glow during sunset and sunrise! -Lindy :-wave

Share this post


Link to post
Share on other sites

>... so I tried it. I changed my start up to just DX8 (no >T&L) and the program runs fine. I then re-installed DX8.1 >and tried Fly!2 again. No go. :-( I got the same message. Well at least we're making progress! I assume your running Fly version 230? You might try changing the location where the sim starts, then enable DX8 T&L and see if that changes anything. If it does, I would re-install fly II. If it has no effect you might try a different Nvidia driver. I had very good luck with the 30.82 driver before. I just upgraded to the 40.72 driver but have not used it with Fly II yet, just FS2k2 so I can't say whether it is better or not. I did notice my Earthviewer software brings up a "depth buffer error" message since going to 40.72 but I havn't had time to chase this problem down. Good luck tracking it down Lindy, let us know how it goes.

Share this post


Link to post
Share on other sites

Thanks for the encouragement Dean. I'm running a fully patched version of Fly!2 (whichever version that is) :-) And as I said, it was running just fine (WITH T&L enabled) before my upgrade. So maybe the new MB does need a more updated driver. :-hmmmOh! get this -- I e-mailed my computer shop (the place that did the upgrade for me). Their "techie" suggested that this program was not designed to run on such a high end machine!! (Now, granted this dude was trying to troubleshoot based only on a couple of e-mails, but really...... :-lol )At least I CAN use Fly!2, so that's something. I'll let you know if I figure anything out.Uh...... would having V-sync enabled (through my video card) have any effect?-Lindy :-wave

Share this post


Link to post
Share on other sites

Lindy, You should disable v-sync, it makes you loose frames in all games...I would format and reinstall everything, and put WinXP which runs great, no more bluescreen and less errors...cheers

Share this post


Link to post
Share on other sites

Yup, and for the AGP aperture, it should be half of your ram... That's I have and it works great(my favorite magazine said it was best to set the aperture size like that)Cheers

Share this post


Link to post
Share on other sites

>Uh...... would having V-sync enabled (through my video card) >have any effect? Lindy,V-sync might affect performance but I don't think it would create the problem your having. It is a little weird that the problem started after the upgrade but since it works without DX8 T&L I tend to think it is still driver or software. You can see the version level at the Fly II startup options page. When you say you are fully patched, exactly how do you mean? Did you install the video patch?The 230 patch is all inclusive so if you installed the video patch, after the 230 update that may be part of the problem. The video patch installs DX8 dll files that are older than the same files in the 230 patch. Check your Fly II folder for the following two files and make sure they are dated 6/18/01.TRIDX8.DLLTRIDX8TL.DLL

Share this post


Link to post
Share on other sites

I discovered that if I uncheck the "high resolution" area, Fly!2 will run fine with T&L. It seems I can run with high resolution OR with T&L but not with both. I would have thought that a 64 mg DDR RAM video card would be able to handle both, but apparently not. Dean, when I patch up my version, I don't use the all inclusive patch -- I don't even have it. I use the inidividual patches as they were released by TRI (including the video update). However, I shall check the dates on the triDX files you mentioned.Thanks everyone for your suggestions. :-smooch I DO have Fly!2 running now -- and it really runs great! :-yellow1 I should have everything that I want re-installed by the weekend and I intend to do some serious virtual flying. :-hah-Lindy :-beerchug

Share this post


Link to post
Share on other sites

Hi Lindy,This was the solution, first I disabled antialiasing , that didthe problem disappear.After that I found out that AA could work with HR disabled.Have fun , and tell me your framerate.

Share this post


Link to post
Share on other sites

... reply was to wrong post ...But yes, tweaking that AGP Aperture setting up to 256 made Fly2 hum... Art.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this