Sign in to follow this  
Samaritano

Back to Fly!

Recommended Posts

After reading a post in the PMDG forum it convince me to re-install Fly! II. I went into the First time Fly!ers and Fly FAQ post by Ken Salter and did everything as said. I did some tweaking per FAQ to the Fly.ini and render.ini files.Im having a problem with sim crashing with a "DrawIndexedPrimitive SVertex failed" error. Can anyone here help me with this.If I select DirectX 8 T&L in the graphics option this is where it happens. Selecting DirectX 8 the graphics start to flash like crazy.Any ideas. ThanksEd

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yup render.ini in your system folder and change the line vertexIndexFormat=0 I assume you have a 1 instead so put 0 and save the file and try again...cheers

Share this post


Link to post
Share on other sites

Also, on some NVidia cards, if you put one of your textures slots in the RENDER.ini to "999" (meaning, all remaining memory here), then you may get this error. Use the texture calculator (see one of the anchor posts from Ken Salter with the download link) to assign all your slots without leaving any at "999". This will most likely solve your problem if the above solution does not.-DK----David KohlFly! II v2.5.240Dell 8200 P4/1.8G, 1024MB RAM, Nvidia GF4 Ti4600 v41.09, WinXP Home Edition SP1.CH Pro Pedals and Yoke USB.

Share this post


Link to post
Share on other sites

>After reading a post in the PMDG forum it convince me to >re-install Fly! II. I went into the First time Fly!ers and >Fly FAQ post by Ken Salter and did everything as said. I did >some tweaking per FAQ to the Fly.ini and render.ini files. >Im having a problem with sim crashing with a >"DrawIndexedPrimitive SVertex failed" error. Can anyone here >help me with this. >>If I select DirectX 8 T&L in the graphics option this is >where it happens. Selecting DirectX 8 the graphics start to >flash like crazy. This is a fairly common problem. I have had it come and go but changing to just DX8 should settle the problem down at the expense of losing the reflective lighting. Since doing this causes a different problem there may be something else at work here. At this point I would stay with the default render.ini settings until you get things right. What version of DX are you using?What video card and driver are you using?If you updated to the current 240 version did you run the update that takes you to version 210 first?Don't install the video update in the library. These are actually older tridx8 files than the those that are part of the 240 update. Dean Karis

Share this post


Link to post
Share on other sites

Thanks a lot guys. Dean. Going back to DirectX 8 fixed the problem.I downloaded the MemCalc application and copied those values into the render.ini.Im using DirectX V. 8.1. I remeber disabling the AGP Texture Aceleration feature on the Display tab of the DXDiag app. It was a tip from a fellow simmer for FS2K2. I dont know if this has to do something with it running Fly!II.My videocard is a GeForce 2 GTS 64mb with the Detonator 40.72 and running NVHardPage.For the patch I did 210 first then 240...Ed

Share this post


Link to post
Share on other sites

>I remeber disabling the AGP Texture >Aceleration feature on the Display tab of the DXDiag app. It >was a tip from a fellow simmer for FS2K2. I dont know if >this has to do something with it running Fly!II. I tried this as well and then set it back. I don't recall that it had the great impact for me with FS2K2 that others reported but I don't think Fly II like it at all which was why I enabled it again.As I indicated in my first post, I have had this drawindexprimitve Svertex error message come and go so I think it is also related to the Nvidia drivers because that is about the only thing that changes on my system. I am now running version 30.82 drivers as anything higher causes problems with my Earthviewer program. I think I was running version "40 something" the last time I had this error message. I switched to DX8 without T&L to resolve it. A short time later I found out my Earthviewer program wouldn't work so to fix it I had to go back to 30.82 drivers. After that, sometime during all the beta testing, I ended up going back to DX8 T&L and I did not get the crash. Makes me think Nvdia drivers are playing a part in this. Dean

Share this post


Link to post
Share on other sites

Ed,I have a GeForce2 GTS Pro 64mb, quite similar to yours. Here is my render.ini if you want to try. I use it with FSAA 4x (the result is only 2x). If you don't use FSAA, set mipmapFlag to 384 or 512.My settings in the rendering options screen are: (not sure of the words)max visibility: 30 milesdistance for medium textures: 11 milesdistance for detailed textures: 1 mileRender.ini:[Graphics]mipLevelCount=4vertexIndexFormat=0premultiplyColorAndAlpha=0allowAutoMipMapping=0directTextureFlag=0[Textures]maxTextures32=10maxTextures32_565=16maxTextures64=16maxTextures64_565=16maxTextures128=72maxTextures128_565=200maxTextures256=40maxTextures256_565=120 (comment: depends on scenery texures size you use, see Terramodels and FSImport)maxTextures512=8maxTextures512_565=0maxTextures1024=1mipMapFlag=128[NonAGP]maxTextures256_565=0[AGP]maxTextures256_565=0Hope this helps!Regards!Pascal

Share this post


Link to post
Share on other sites

I have a Dimension 700 with a 32 Nividia Card. do not fool around with .ini files or download drivers for my video card. I just install Fly II and it works. I don't try to correct slight stuttering by altering things I don't know anything about.

Share this post


Link to post
Share on other sites

>After reading a post in the PMDG forum it convince me to re-install Fly! II.Which post was that, or what argument was it that won you over?It might come in handy when talking to people, trying to convince them to give Fly! II a chance. :-)And the more people we can get to use Fly! the better for this community.Roy B. :-waveOslo, Norway

Share this post


Link to post
Share on other sites

Thank you for all the help you guys provided me. I updated my nvidia drivers and installed DirectX 9 and now everything works fine. Im even running with DirectX8 T&L option. Now its time to start looking for great addons and tweak the sim a little (sky, clouds, etc.)Roy this is the post that made re install Fly!II http://ftp.avsim.com/dcforum/DCForumID32/550.htmlFor me Fly! does a better job in simulating the speed and the fly dynamics of the aircraft than FS2K and the Rwy are wider too :-)Ed

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this