Sign in to follow this  
Guest GaryB

FSUIPC 2.96 Help

Recommended Posts

I have downloaded FSUIPC 2.96 as recommended and now have a small problem. I am in the habit of using FS ATC in the background (that is changing frequencies to get the chatter, but not making contact). Now I find that it appears not to be recognising the "1" key and I suspect that FSUIPC is "eating" it. Can anybody help!ThanksGary

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Looks like I'm on my own with this one then! I'm going back to 2.94 for now I think - I don't really want to change frequencies manually on COM 2 all of the time...

Share this post


Link to post
Share on other sites

i think if 2.96 was eating the 1, everyone would know about it. do you have any fsuipc hotkeys defined?try this, delete the fsuipc.ini file, and then restrat fs2002 with fsuipc 2.96do you get your 1?

Share this post


Link to post
Share on other sites

Actually, I think Gary is on to something, although I cannot figure out how he makes it work with 2.94 without causing a conflict.Like Gary, I'm guessing, I have configured RC3 to use the number keys in unshifted mode. My keyboard is placed such that it's cumbersome for me to use both hands and therefore also most shifted key combinations.I have just now conducted a quick test comparing FSUIPC 2.94 with 2.96. Here are my findings:With FSUIPC 2.94, if I open the FS2002 ATC window and press a number key matching one of the choices there, both the built-in ATC and RC3 react to it.With FSUIPC 2.96, only RC3 reacts. Furthermore, if I terminate RC3, e.g. by cancelling IFR, I don't get the keys back, so I cannot switch to using the built-in ATC in those cases.What I - and Gary, I'm sure - would like to see was that those keys always went into the FS2002 ATC window when it's open, and to RC3 otherwise. This is how FS2002 works without RC3 installed; you can easily have the number keys assigned to a variety of tasks and still have them pick an option in the ATC.If this should prove impossible, another solution for me would be to support F1-F12 in RC3.

Share this post


Link to post
Share on other sites

never thought of wanting to end rc, and then using the builtin atc.as it stands right now, if you want to use ms atc and rc, you will have to make key combinaitons for rc that does not conflict with ms atc.i will see if i can "unregister" the rc keys when you quit rc.

Share this post


Link to post
Share on other sites

re-download www.jdtllc.com/v3/rcv301.ziphenrik did a quick test, and i'm now unregistering rc's keystrokes when you cancel ifr or quit rcsee if that works for you

Share this post


Link to post
Share on other sites

Yes - that is it exactly! (I never seem to manage to explaing these things properly) AFAIK I have not reconfigured any of the RC keys - its as "out of the box" (although I have a short memory!).What I really wanted was to use the same keys for both (as with 2.94 and as described in the post above). I can see that it could be seen as a bug (sending the keystroke to both), but I liked it! I don't do the cancelling RC and using MS ATC thing...If I am going to stay with 2.96, is my only option to configure the RC keys to something else?ThanksGary

Share this post


Link to post
Share on other sites

I've noticed this issue since 3.0 was released and I've been using FSUIPC v2.95 all along (I think). I simply reassigned Ctl-1 & Ctl-2 to RC so that I can still use 1 & 2 for the MS ATC window which I run on Comm-2. You aren't going to take away the ability to still use 1 & 2 keys for MS ATC window on Comm-2 while RC is running, are you JD? I know you can manually tune comm-2, but it's so much easier to still hit `1 to get the next MS ATC station enroute. Thanks...AL

Share this post


Link to post
Share on other sites

HiExactly the same here and all appls on the default settings (FSUIPC 2.96, FS2002, RC3, PSS Airbus). It definitely was the switch from 2.95 to 2.96.cheers,Stephan

Share this post


Link to post
Share on other sites

I have been running into major problems tonight with RC3.0, which are related to FSUIPC 2.96 and/or WideFS 5.40 (I think). I keep getting many and often "altimeter 0000" and "not receiving transponder" messages from RC3.0. I checked the WideClient.log file and there are many errors and connection reset entries. Hopefully I can find prior versions of these programs to see if moving to the new versions is the cause of my troubles.:-(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this