Sign in to follow this  
Guest tallmike

Hi Guys......Great Proggie......BUT.......

Recommended Posts

I have been trying ever since I received my RC4 disk, to do a flight from LIRF (Rome) to EGLL (Heathrow-London).All goes well at Heathrow until I try to turn off the RWY 27R onto the taxiway, then the screen goes black and I get the message "MS Flightsim has encountered a problem and will close now".I thought it might have been the 4.0.1 update so I uninstalled this and it still happened. I uninstalled all my addon scenery back to default and it still happened. I uninstalled RC4 and alls well again, landing and taxying just fine. I defrag the disks and reinstall RC4 and I get the black screen crash again. This is all rather awkquard as I like to use FS Passengers but until this is sorted its a waste of time. Im using Ultimate traffic at about 35% so its not overtaxing the PC and Active Sky 6. Never had probs like this before and it only happens when RC4 is running.My system is Asus AK8N MB with AMD Athlon(64) 3400. Soundcard is Audgy 2 ZS with Asio drivers and video card is ATI Radeon 9600 Pro 128 MB, with the latest Catalyst drivers.FSUIPC = 3.617Any Ideas would be appreciated.Mike (tallmike)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Mike,This sounds like the dreaded ATC.DLL bug. Pete Dowson did manage to trap some of these but I see you have the latest version of FSUIPC anyway. It's almost certainly down to a clash of frequencies which is why it happens when you switch to GND from TWR.I've had the problem way back but not recently. If you've switched off the default ATC sounds in FS9 try turning the ATC volume to zero but leave the option checked. That seems to minimise the chance of it happening.It's unlikely to be your other programs so you can rest easy.Cheers,

Share this post


Link to post
Share on other sites

Ok,.......I'll try that. I have been reading about these CTD's and it seems like a minefield....lol.Mike.Incidently I have turned down DX sound accel by one notch as I heard this sometimes cures these CTDs as well.

Share this post


Link to post
Share on other sites

<>By all means try that but only after you have established if my tip solves the problem otherwise you won't know which one resolved things assuming the problem does get resolved.Cheers,

Share this post


Link to post
Share on other sites

Ok.....Heres a synopsis of whats been happening.I tried your idea with no sucess.I decided that my system was due a reinstall so I went ahead and while I was at it I formatted the drive which holds Flightsim. Now with a completely fresh virgin system (XP Pro) and a fresh virgin install of Flightsim, I went ahead and installed PMDGs 747 and 737 (in the right order). I setup the same flight LIRF to EGLL. I landed perfectly at 27R Heathrow, cleaned the aircraft up and went to turn off the first available high speed exit. As soon as the nose of the aircraft passed the hold short markers.....Boom.....Blackscreen! with the following report:-A fatal error occuredAppName: fs9.exe AppVer: 9.1.0.40901 ModName: atc.dllModVer: 9.1.0.40901 Offset: 0002d1daSo, now Im thinking its a problem with PMDG + RC4. I setup the same flight again only this time flying the default 747 (YUK). Sure enough....same problem again...same error report.If I dont use RC4, I can takeoff and land anywhere. This suggests to me that there is a fundamental problem with RC4 (Ver 4.01) not wanting to play with ATC.DLL. Turn RC4 off and alls well....start it up and crash. There is a problem with RC4 code that no-one is admitting too! RC4 causes a fatal error in module ATC.DLL. This is RC4's fault, no-one elses!Being as ATC.DLL is part of Flightsim, surely its down to the coders of RC4 to make sure that there program plays ball with this module.Ive seen the posts that some people have no problems at all, but to me this is not an answer. Look through this forum to find all the complaints about CTD's involving this module and a picture starts to develope. There are a lot of people suffering from this problem and all have paid good money for something that isnt delivering the goods.Ive wasted hours and hours of flying time trying to sort this out. As I said before,...this answer of "It cant be RC4, cos lots of people use it with no problems", or "I cant recreate this behaviour on my machine, so it must be alright", just doesnt cut the mustard, when there are so many people having CTD's. Yes I am a bit angry, having paid for something I cant use. Theres no way I should have to do all the detective work to find out why this is happening. Its down to the writers of RC4 to do that. Anyway...rant over, anyone got any other ideas, before I throw this program in the bin.Mike.

Share this post


Link to post
Share on other sites

Mike,Have a read of this thread http://forums.avsim.net/dcboard.php?az=sho...ing_type=searchAs you can see the problem of ATC.DLL is not limited to Radar Contact so i think it's a little unfair of you to suggest it is responsible for this crash. Pete Dowson has contacted the FS9 team regarding this bug and provided them with info on how it can be resolved. They have accepted it is a bug and will ensure it does not port over to FSX. Please ensure you are using the latest FSUIPC 3.617 available here http://forums.simflight.com/viewtopic.php?t=41519 and have followed the installation instructions.Returning to your LIRF-EGLL crash can you please upload your flight plan and I will fly it myself and see if I can replicate the bug. Please confirm if you manually ack and tune or whether you leave it to the co-pilot. It sounds as though the problem happens when you switch from TWR to GND.Does the crash only occur on this flight or all your flights? If it happens only on this one then you have been very unlucky. Presumably all the other flights worked fine?

Share this post


Link to post
Share on other sites

Mike,As a further follow-up to my earlier post have a read of the first post on this thead http://forums.avsim.net/dcboard.php?az=sho...ing_type=searchNote the suggestion that if the Departure ATIS is repeated at any point in the flight it could cause the CTD. I have just created a LIRF-EGLL flightplan and loaded it into RC. I notice the ATIS at LIRF is 121.70 and GND at EGLL is 121.70.If your frequencies are the same then locate the Data sub-folder under the RC4 folder and open F4.csv using NOTEPAD (not Excel) and locate the EGLL entry. The third listed frequency is GND. Change it to another frequency and save the change. Refly your route and I bet you don't get the problem when you exit the active at EGLL.I will fly this route tonight without changing the frequency. Should be interesting.

Share this post


Link to post
Share on other sites

Mike,I've just flown this route and you might be pleased/relieved to hear that I also suffered a crash when manually switching from TWR to GND at EGLL.But RC4 is not the cause of this problem - it's just the messenger. I'm pretty sure that if you flew using the default ATC with the same frequencies you would also get the crash.The good news? Well, make sure your GND fequency at the destination is different to the ATIS at your departure and you should be okay. Edit F4.CSV if necessary and change the ATIS at Rome or GND at EGLL and providing you don't rebuild your scenery database it won't reoccur.The other good news is that this is my first ATC.DLL crash in many months so I'm sure that with all your other flights you won't encounter this problem.The bad news? The bug in FS9 will not be fixed by Microsoft. It's way too far down the road for that but at least it won't happen in FSX.Perhaps in the light of all this you might want to change some of your comments about RC4.Cheers,

Share this post


Link to post
Share on other sites

Well Ray...Sorry to have to tell you this but I never have problems with Heathrow using default ATC. Ive been running XP Pro for years and its never....NEVER......crashed. Since loading this program up, my head is spinning with crashes. Ive tried all the above suggestions and Ive wasted another 4 hrs. Even the addition to FSUIPC.INI (RemoveATC=yes), didnt work. Ive had enough. The program is uninstalled and disk in Bin. Ive just ordered Vox ATC, so I'll see how that works out. Thanks for trying to help anyway Ray.Mike.

Share this post


Link to post
Share on other sites

i re-read your posts, and can't find where you said whether you used the fsuipc 3.617 module.can you tell me whether you tried that or not?jd

Share this post


Link to post
Share on other sites

Yes JD I am using 3617.and one other thing the frequencies Ray mentioned were totally different to the frequencies I had listed. Both ATIS were 118.00, so I changed the Heathrow one to 118.10. There were no other frequency clashes. Didn't make any difference. Still crashed.Mike.

Share this post


Link to post
Share on other sites

send me an email at jd@jdtllc.comjd

Share this post


Link to post
Share on other sites

Hi Mike,<>And were the frequencies identical to those used by RC? I think you've been extremely unlucky with this ATC.DLL crash. Last night's flight was the first crash I've had in ages and I've flown thousands of hours all over Europe and beyond testing RC4.<>Not sure what relevance XP Pro has to this situation.<>But you've only reported problems with LIRF-EGLL. If there are other CTDs which you feel were RC related why didn't you mention those? It's difficult to help without specific information.<>What a pity especially when the problem is related to FS9 and not third-party software. I wish you better luck with your next ATC program.Cheers,

Share this post


Link to post
Share on other sites

Ray,Im assuming that RC4 reads its frequency list from the same place that flightsim reads them from so they should be the same shouldnt they. If I dont start RC4, I can takeoff and land using Heathrow with no problems all day. AS soon as I try and use RC4....I cant!!. I couldnt tell you wether or not its happening at other airports.....Basically if I cant use Heathrow then Im screwed...cos most of my flight time is from or to Heathrow.The relevance of XP Pro is that in 3 years it has never crashed....black screened or bluescreened. I run a lot of different addons and addon sceneries all without problems. RC4 is making crashes happen wether its RC4s fault or not.I didnt mention any other CTDs cos I havent had any others. My main concern was to get Heathrow sorted cos thats my main operating hub and the flight LIRF-EGLL is nearly 2 hrs long.....I have done that flight so many times now, trying to fix this, that I could tell you how many clouds are in the sky at any point (joking :0). Crashed every time....thats why my head was spinning.You say "problem is RELATED to FS9".....I think it should be "problem is RELATED to FS9 and RC4 not playing together". I did order V.. ATC and installed it today.....Guess what...no problems taking off or landing anywhere. It also builds a database by scanning FS9 so Im assuming its picking up the same frequency list.-----------------------------------------------------------------Anyway.....here comes the important part.....I dont like wasting my money so I decided to give it one last shot. I reinstalled RC4 and was just about to install the update when I thought to myself "No....dont update yet....try it first". Well what do you know...I finally managed to land at Heathrow!!Tomorrow I am going to install the 401 update and see if it still works...or wether it was the update that has been causing the problem. I would do it tonight but I really dont fancy flying Rome - Heathrow again today. I'll be in touch.Mike.

Share this post


Link to post
Share on other sites

Mike,Glad to hear you haven't given up on Rc4 yet because it has a lot to offer and so far your entire RC experience seems to revolve around LIRF-EGLL. You still haven't said if you've flown any other routes and whether those were without incident. I think in the interests of fairness you should at least try EHAM-EGLL or EGCC-EGLL and I'm certain you will find those will be just fine.RC4 does build its runway data from BGLs via a program Pete Dowson created - MakeRunways. However, frequencies are not built the same way and there are instances where the frequency for some ATISs are outside the range so JD changes them to 118.0. What I've done is to enter the correct frequency in my f4.csv file using FSNavigator airport info. That's why we probably had different ATIS info.You will be able to use Heathrow for your flights. You've just been very unlucky in choosing one of the few airports (LIRF) that has a clashing frequency and it's this that causes FS9 to crash with the ATC.DLL bug. But I must correct you when you say it's RC4 and FS9 that is causing this problem. As you will have seen from my earlier thread FDC also had this type of problem and the common factor here is not RC4 but FS9. Please remember the bug lies in FS9 and if a program like RC, VoxATC or FDC happens to pass information to FS9 that it doesn't like then FS9 is responsible - not the program passing the data.<>Anywhere?? So have you tested it with all 20,000+ airports? No. You couldn't have. Sooner or later if you run any ATC program with FS9 you will hit that ATC.DLL bug. It's a certainty. VoxATC is no better or worse than any other program when it comes to that problem. You will probably find some flights crash with Vox and don't with RC and vice versa. Only when FSX comes out will the problem go away and if you've dumped RC4 then you won't be able to enjoy it.Anyway, by all means continue to fly with RC4 and try some different routes. I look forward to hearing your report. I don't think installing or not installing 4.01 will make any difference to the crashes - just to the speed of voice delivery.Cheers,

Share this post


Link to post
Share on other sites

4.01 changes nothing with regards to the frequencies.initially, i extracted the frequencies from the .bgl files, but that was a one time sweep, i don't do it each time i rebuild the scenery database.i don't think you've ever sent me a .log, so i really can't check anything out. if you want to do thatlaunch rcv4click debugload the .plnclick start rcif you want to stop rc, right there, i probably have all the information i need. zip up the .log and send it to me.i think one of the beta testers found this, and we can reproduce this crash anywhere in the world. simply use an atis frequency that is going to be use during another part of the flight.fsuipc 3.617 (actually 3.6x i think) fixed this crash.so send me a .logtry a flight from somewhere else, to somewhere else. see if it still happens. send me a .log happy to helpjd

Share this post


Link to post
Share on other sites

Hi Ray, I had the same problem as you are having. 5 flights in all,1 after the other. Sometimes taking off some times during taxi. Now,my solution: Open your case and check your fan blades. My were really dirty and after cleaning no more black screen. Hope this helps. Heat is a PC nightmare.

Share this post


Link to post
Share on other sites

Hi Skyhog,Thanks for the tip but this is definitely a known software bug and not a heat issue. Prior to trying this particular flight I had not had the ATC.DLL bug in ages. I live in England and I have never had any heat issues with my PC.Having said that it's not a bad idea to clean the innards occasionally and I'm pleased that solved your problems :-)Cheers,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this