Sign in to follow this  
Guest

Long Flight - Low Frame Rate

Recommended Posts

I had a problem in FS2K and it appears to occur in FS2K2. When I fly a long flight (hours) the frame rates drop to below 5 FPS. I just flew ATL-Aruba in a FFG 757 with Radar Contact. Hit some clouds (which killed frame rate) toward the end of the flight. Dropped out of the clouds for approach and rates stayed in the 5-8 range. From all view points (spot as well as cockpit)... stayed that way all the way through taxi. Was it the clouds? Are they that big a FR killer? Or is RC? Or is something piling up in RAM? FS2K2 ProWin XP HomeP3 1.0 GHzNVidia GeForce 2 MX - 32MRadar Contact V2.2Ideas? Thanks!Eddie

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had this problem and my cause was ATC (AI aircrafts), they are growing, growing in quantity and in certain moment your RAM if full of AI and the frame rate goes to 1 fps, to check if I

Share this post


Link to post
Share on other sites

Minimize FS, start notepad, close notepad and maximize FS again.Works all the time here. (XP).This is a FPS bug.. have it here too.Johan[A HREF=http://www.phoenix-simulation.co.uk]Phoenix Simulation Software[/A]Unofficial PSS website:www.people.zeelandnet.nl/johdMy help may not me much usefull, or usefull much..eh?http://people.zeelandnet.nl/johd/index2/Ar...s/Leg1/klm5.jpgTrue Blue! K L M!

Share this post


Link to post
Share on other sites

:( Incredible answer from Johan! *:-*What kind of tricks can you think of more to have microsoft products work properly? Incredible, this is the most wierd workaround to have MS Flightsimulator working, opening and closing the notepad... :( As the dutch call: I am not crazy I am an airplane...Regards, Ferry

Share this post


Link to post
Share on other sites

OK. That seems an odd fix initially, but not so much as I think about it. It seems as though something is piling up in memory... opening a different piece of software could "flush" that and start over. But I must ask... how in the world did you come across that solution? And do you have to stand on one leg when you do it? :) I love Microsoft. :)Eddie

Share this post


Link to post
Share on other sites

I've discovered with Windows XP that you need to shut down all programs running in the background. I do so with a program called "end it all", do a search here or via google for the url for that program. Excellent! Also, especially with XP, shut off your screen saver and the automatic monitor shut off. Also, disable, via the msconfig, the automatic backing up that XP does, which drains a lot of resources from the computer.There are sites which will give you more technical aspects of the above, but I do this by rote every time I use FS2002 and it helps a lot.Also XP can never have enough RAM ( I have 512k)Lee

Share this post


Link to post
Share on other sites

I run Windows ME. I do the following in this sequence:Minimize FS2002Run Quicken and enter a purchase with a payee name that begins with M. This purchase must also be at least $70.00 or more. Record the entry and exit quicken.Run Internet Explorer and go to Microsofts spam lists and join at least 3. This alone frees up 20mb of ram with each list joined.Then run Notepad and type "I Love Microsoft." without the quotes or period and press enter. Exit notepad.Uninstall Quicken and purchase Microsoft Money online.When you run it and it says, "You've encountered an error would you like to debug this software free of charge?" Answer yes.The open FS2002 again and press enter to bring up the chat window. Type in the window three times. Blurry Textures are normal. This is the way it looks from a real aircraft. In a few minutes the chat dialogue will open and will say "Are you sure?" Type y and press enter.Thats it! You will now have at least 40 FPS on any machine above 200MHZ.

Share this post


Link to post
Share on other sites

LOL Nealw :DI'm with the flushing memory when changing programs AND the AI building up the longer you play/fly.

Share this post


Link to post
Share on other sites

If you haven't noticed, when you fly with a RC adventure, the AI aircraft taxi to the active and then site there. I've not seen them take off yet.I encountered the same problems on 2 - 3 hour flights.My guess is that you have a load of aircraft stacked up at the arriving airport and frame rates go in the toilet.As suggested, I slip the AI slider to 0. Memory is not an issue.I went from 256 to 512 and it made no difference.With the AI slider at 0, the frame rates stay as they were on take-off.

Share this post


Link to post
Share on other sites

Not the AI slider. I set that to 0 to keep FS from controlling traffic while using RC. Well, hitting the skies again tonight. Will let you know how it goes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this