Sign in to follow this  
Guest

How do I make Ch usb yoke work with Ch pro pedals?

Recommended Posts

Hi guys I received a ch usb yoke for my B-day and can't seem to get the pro pedals and yoke to work to gether. The yoke is pluged into the usb port and the pedals are pluged into the game port of my sb sound card the yoke works fine but pedals won't work at all. The only way so far that I have been able to make the pedals work is to have a joystick pluged into the joystick plug on the pedal cable. this works but, I want to get rid of the joystick any ideas? Thanks Dave.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have the same setup, and I think the only way is to leave the joystick plugged in to the pedals. I just have an old one plugged in and I hide it behind the desk.

Share this post


Link to post
Share on other sites

As Craig has suggested, you will need to leave the gameport joystick plugged in. The only way to get around it that I know of, is to pick up a set of USB pedals. I have the USB yoke and an old F16 flight stick yoke with the pedals plugged in there. Be sure to use an analog joystick, as a digital--such as MS Precision Pro will not work at all.Darrell

Share this post


Link to post
Share on other sites

Hi Dave,There is NO need to buy new pedals; all it needs is a little rewiring of the cable.Download file corrected_chpedbrake.zip from the library; it shows you how to either rewire the existing cable, or how to make a small adapter cable.This way you can connect your pedals directly to the gameport (without the joystick). Even better: you can now use the Toebrakes as well.Rob

Share this post


Link to post
Share on other sites

You don't need rewiring for that matter. Pick up the latest analog drivers from the CH site. Plug the Aux.Port connector into the Joystick Connector. Plug the Gameport Connector into the PC game port. Use the CH drivers and they'll let you calibrate things and you'll have the rudders and the toe brakes. Note that the "Reversed" box in the FS assignments dialog should not be checked for use with the analog toe brakes as they are for the USB toe brakes.- BobThe StickWorkshttp://www.stickworks.com

Share this post


Link to post
Share on other sites

With both the USB yoke and an old gameport joystick, though, you can use either control, depending on aircraft. Also, with a Gameport to USB adapter, the toe brakes will function fine with the gameport pedals.Looks like there are quite a few options available, depending on gear and personal preference.Darrell

Share this post


Link to post
Share on other sites

Hi guys,Wow thanks for all the feed back I think I'm going to try a little of everything here and see what works I'll post to let you guys know what happens :-beerchug thanks again Dave.:-wave

Share this post


Link to post
Share on other sites

Hi! before following your advice my CH pro-Pedals (gameport) would only work with a joystick attached, as mentioned earlier. However, while the rudder works the toe brakes don't. In fact, the foot action on the toe brakes affects my x/y axis i.e. causes alierons and elevator to move and lock until I move my USB joystick. Any ideas?Thanks,Mike

Share this post


Link to post
Share on other sites

Oh Dear!I should have used a bit of the grey matter. I just solved the problem. I went into FScontrolsassignments and deleted the CH Pedals x/y assignments which were elevater and alierons, then assigned x and y to the left and right brake. Works very well now. Also deleted the rudder assignment on my joystick so CH Pedals exclusively control rudder. Only remaining issue is that the 'brakes' sign in the window stays on.Mike

Share this post


Link to post
Share on other sites

Hi Mike,I don't have my analog pedals hooked up right now, I'm using the USB version now, but the problem with them not turning off is likely just a matter of setting the Deadzone. Go to the Sensitivities dialog and click the "Advanced" thing so you can set the Sensitivities and Deadzones independently. Try it with both the Sensitivity and Deadzone sliders full right, it seems to me that gave the maximum deadzone for the analog brakes. For the USB brakes it should be full left. Anyway, see if the "Brakes" indicator will turn off then. You may need to tap the brakes once after you change the settings, they won't update until they move.- BobThe StickWorkshttp://www.stickworks.com

Share this post


Link to post
Share on other sites

Hello Bob.You are spot-on, although I got there myself already. I moved both sensitivity sliders off centre to the right; only a touch, however, and this did the trick.Thank you.Best wishes,Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this