Sign in to follow this  
Bob Familton

Simconnect Connection Help Please

Recommended Posts

I am running WIN XP and can't get any connection to Simconnect on several programs like FSX Planner. How can I check to see if I am setup correctly? I launch FSX and have been told I can minimize it and execute netstat -b from a command prompt and am supposed to see the connection to FSX as 172.0.0.1 or something like that. I am not a programmer so please don't refer me to some technical blog. All I want is a simple step by step method to determine why I cannot connect or see no open port that is being used by FSX, and how to fix it. Thanks, regards, Bob.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>I am running WIN XP and can't get any connection to>Simconnect on several programs like FSX Planner.FSX Planner is very unusual in that it doesn't connect to FSX like any other "normal" SimConnect client, via the SimConnect.DLL, but seems to bypass the standard connection and operate the TCP/IP port directly. This is a great shame, as, for local PC connections, the next version of SimConnect (in SP2 and in the Acceleration pack) can use the much more efficient Named Pipes facility locally, bypassing TCP/IP altogether.So, that gripe said, what other SimConnect clients do you have which won't connect? If these are "normal" ones, which do use the standard methods, like FSUIPC and many DLL add-ins, then the most likely problem you have is a SimConnect.XML file, which is wrong and should probably be deleted.>All I want is a>simple step by step method to determine why I cannot connect>or see no open port that is being used by FSX, and how to fix>it.I don't know of any easy (non-technical) way of using FSXplanner linked to FSX. I use a program called Open Ports Scanner to find out which port FSX SimConnect is using -- it is different each time it loads. But this is technical, I'm afraid. Sorry.RegardsPete

Share this post


Link to post
Share on other sites

Hi Pete. Thanks to the excellent Product Support from FSX Planner and Whisplacer I am now able to connect to FSX Planner. I am also able to connect to Whisplacer. The problem was in my simconnect.xml. I deleted it and let the program automatically connect without having to choose ports, etc. I really do recommend FSX Planner and Whisplacer and their excellent support. It is amazing what a software developer of a free programs will do compared to what we get from MS which we pay $$ for. Thanks and best regards, Bob.

Share this post


Link to post
Share on other sites

>Hi Pete. Thanks to the excellent Product Support from FSX>Planner and Whisplacer I am now able to connect to FSX>Planner. I am also able to connect to Whisplacer.Good. What's Whisplacer?>The problem>was in my simconnect.xml. I deleted it and let the program>automatically connect without having to choose ports, etc.Ah ... does FSXPlanner connect automatically now? That's good. Seems like i should take a look at the latest version!RegardsPete

Share this post


Link to post
Share on other sites

Hi. Yes they both connect automatically now. Just let it do its thing and don't select any address or ports. Make sure you have the R.26 version of FSX Planner. Whisplacer is an excellent freeware graphic object placer. It is at:http://lc0277.nerim.net/Thanks and best regards, Bob.

Share this post


Link to post
Share on other sites

I to am having the same problem, except for Active Sky X. I tried reinstalling SP1, but still not working???

Share this post


Link to post
Share on other sites

Hi. If you have a simconnect.xml in your C:Documents and SettingsUserNameApplication DataMicrosoftFSX folder just remove it and save it somewhere. Then try again but don't select any ports or addresses. Let it do it automatically. Make sure you have the R.26 version of FSX Planner. Best regards, Bob.

Share this post


Link to post
Share on other sites

>Hi. Yes they both connect automatically now. Just let it do>its thing and don't select any address or ports. Make sure you>have the R.26 version of FSX Planner.Hi Bob,No, R.26 isn't connecting either. I have to use "Open Ports Scanner" and enter the correct port for the local connection. It is actually choosing an FSX.EXE port, just the wrong one, every time.There are two TCP ports for FSX (maybe only in the Beta Acceleration release I'm using). They are both for "Local Address" 127.0.0.1 but one has "Remote Address" as 127.0.0.1 as well, whilst the other one, the correct one, has the remote address as 0.0.0.0. FSXPlanner is always choosing the wrong one!The other distinguishing factor between the two is that the wrong one has "connection state" shown as CLOSE_WAIT, which the correct one has LISTEN.Also, I had hoped that FSXplanner would dynamically show the aircraft position from FSX. But it doesn't, you have to keep going into the menu and clicking on "move cursor to aircraft".RegardsPete

Share this post


Link to post
Share on other sites

Hi Pete. I am sorry it did not work for you. Just removing the simconnect.xml allowed me to connect to Whisplacer and FSX Planner. Post a message at the FSX Forum and ask about it. I did not notice that FSX Planner did not dynamically show the aircraft position. Best regards, Bob.

Share this post


Link to post
Share on other sites

>>Hi. Yes they both connect automatically now. Just let it do>>its thing and don't select any address or ports. Make sure>you>>have the R.26 version of FSX Planner.>>Hi Bob,>>No, R.26 isn't connecting either. I have to use "Open Ports>Scanner" and enter the correct port for the local connection.>It is actually choosing an FSX.EXE port, just the wrong one,>every time.>>There are two TCP ports for FSX (maybe only in the Beta>Acceleration release I'm using). They are both for "Local>Address" 127.0.0.1 but one has "Remote Address" as 127.0.0.1>as well, whilst the other one, the correct one, has the remote>address as 0.0.0.0. FSXPlanner is always choosing the wrong>one!>>The other distinguishing factor between the two is that the>wrong one has "connection state" shown as CLOSE_WAIT, which>the correct one has LISTEN.>>Also, I had hoped that FSXplanner would dynamically show the>aircraft position from FSX. But it doesn't, you have to keep>going into the menu and clicking on "move cursor to>aircraft".>>Regards>>Pete>Hi Pete,Did you download release 26 on the 1st or 2nd of October? If so can you redownoad it, as there was a slight bug in that version that caused some problems for some people trying to connect to FSX automatically through FSX Planner.Also, FSX Planner will dynamically show the aircraft position in FSX. There are two checkboxes in the plane properties display. One is "FSX Plane auto follows cursor" If this is checked then the plane if FSX will automatically move to whereever you place the plane icon.The second one "Cursor auto follows FSX plane" will make the plane icon move to whereever the plane is in FSX. So you can move around in Slew mode, or fly around, and have FSX Planner constantly update the position of the plane cursor.-Russell

Share this post


Link to post
Share on other sites

Hi Russell,>Did you download release 26 on the 1st or 2nd of October? If>so can you redownoad it, as there was a slight bug in that>version that caused some problems for some people trying to>connect to FSX automatically through FSX Planner.Ah, I'm not sure of the date. Probably I have the older R.26. I'll get it again. Thanks.>Also, FSX Planner will dynamically show the aircraft position>in FSX. There are two checkboxes in the plane properties>display. Plane properties? Ah ... not found those yet. I was looking in the "SimConnect" menu. Let me look ...... I still can't find "plane properties". I'll have another loook when I've downloaded the later R.26.Thanks,Best RegardsPete

Share this post


Link to post
Share on other sites

Okay, I re-downloaded it. Date still shows 2nd October, but a bit later (17 something), and it is finding the correct port. Thanks. That's good.But:>Also, FSX Planner will dynamically show the aircraft position>in FSX. There are two checkboxes in the plane properties>display.I couldn't find "plane properties" anywhere, but eventually I managed to get a window up called "plane data" which does have the options you mentioned. This seems quite awkward to get displayed -- it occurred when I used the "move cursor to FSX plane" option."Move Cursor to FSX Plane" only seems to do anything if "Show Plane" is NOT selected. I think this is because "Show Plane" seems to be reversed -- with it unchecked there's a little red-cross at the plane position (no orientation shown), with it checked there's no sign of the FSX plane."Move plane to Icon" seems to do nothing also -- not sure what "Icon" this refers to anyway?Still experimenting ...Best RegardsPete

Share this post


Link to post
Share on other sites

Hi Pete,You should see a plane icon in FSX Planner if you zoom in enough. Dy default this plane icon is located at the airport reference point and represents a Cessna. Clicking on the plane displays the Plane Data properties display. You can choose the size of the plane icon to one of the presets plane or helicopter shapes, or you can specify your own dimensions. This plane icon is what represents the FSX plane and it's location within FSX Planner.I hope that helps.We are adding more how to guides about things like this all the time, which you can check out here: http://www.zbluesoftware.com/fsxplanner/features.cfm-Russell

Share this post


Link to post
Share on other sites

>You should see a plane icon in FSX Planner if you zoom in>enough.Hmm. Evidently I haven't yet zoomed in enough. I had the whole of the EGCC terminal area showing, about 1 mile across I suppose (maxed on a 19" scren at 1280x1024). Isn't that enough?I'll try again with a huge zoom.>Clicking on the plane>displays the Plane Data properties display.I managed to get that up by carefully clicking on the centre of the hairline cross representing the position, but if I miss it even slightly it gives the Data for the object underneath (taxiway, gate, whatever).>You can choose>the size of the plane icon to one of the presets plane or>helicopter shapes, or you can specify your own dimensions. >This plane icon is what represents the FSX plane and it's>location within FSX Planner.Well, I will see if I can get it to show. Seems odd that it needs a zoom setting so large though. I'll get back when I've played some more.Thanks & Best RegardsPete

Share this post


Link to post
Share on other sites

We may be taking the meaning of 'zooming in' differently. By zooming in I mean getting closer to the airport, so fewer things are displayed, but they are larger. If you have the entire EGCC terminal displayed at one mile accross then that is very much zoomed out.You really want to zoom in so that the displayed area is not more than 500 feet across or so to see the place, in my opinion.-Russell

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this