Archived

This topic is now archived and is closed to further replies.

TC1

Keyboard Commands

Recommended Posts

Something knocked out all of my default FS9 keyboard commands. What file do I need to replace and is there an easy way to restore the default file? Also is the file that I need save/loaded on the default FS9 CD's?ThanksTom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Your keyboard commands are stored in your fs9.cfg file. Before playing with your fs9.cfg file, make a backup copy of it, then delete it, and let FS2004 rebuild it.Often I make changes to the default keyboard assignments, and after I have made changes, I back up my fs9.cfg file or just the (keyboard_main) section, so I can restore it quick,, later on...Lee

Share this post


Link to post
Share on other sites

Be aware that FS2004 will sometimes "forget" keyboard assignments (usually not all but some of them at least).If the backup file (as suggested in another post) does not restore them, you will need to go to Settings/Assignments and possibly restore the defaults (if they are gone) or at least redo any additional commands you may have set up.I do not think anyone has ever determined why this happens (and fortunately it does not happen very often) but knowing that it can and does may be helpful.

Share this post


Link to post
Share on other sites

>Be aware that FS2004 will sometimes "forget" keyboard>assignments (usually not all but some of them at least).This has never happened to me, and I can assure you,,, a default installation of FS2004 will never "forget" keyboard assignments.That said,,, Have you installed any "add-on" recently?What kind of keyboard do you have? USB?Lee

Share this post


Link to post
Share on other sites

Sorry, Lee, I love ya but you are mis-informed.It does happen and apparently has nothing to do with addons or fooling around with the FS9.cfg file.Too many simmers have experienced it to say it cannot happen.It does not happen often thankfully.

Share this post


Link to post
Share on other sites

>>Sorry, Lee, I love ya but you are mis-informed.Nope>>It does not happen often thankfully.Sorry to hear that,, suggest you re-install FS9R U using a USB keyboard?Lee

Share this post


Link to post
Share on other sites

Lee,You are correct. I did add an add-on recently. I'll go ahead and reload by back-up master copy of the FS9 config file. After that I take a moment and reload the add-on to see if I can rcreate the problem.I'm not going to mention tha add-on until I can determine the root cause of the problem. Those developers who take the time in the development of a product usally have enought problems without me taking guess that their product caused my problem.Thanks for the helpTom

Share this post


Link to post
Share on other sites

Tom,, before re-installing a complete back-up copy of your fs9.cfg file,,, try this first...Copy and past the (keyboard_main) section from your backup fs9.cfg, into your current fs9.cfg file and see what happens..Lee

Share this post


Link to post
Share on other sites

I am not going to get into an endless and fruitless argument over this -Many other simmers (numerous posts on various sites) have seen this happen so I can only guess you have a system which has never incorrectly written or read data to or from your hard drive.Let's call it a day on this. OK ?

Share this post


Link to post
Share on other sites

>I am not going to get into an endless and fruitless argument>over this -Me either,, just wanna help you out, if you are having this "issue", where you lose your "Keyboard assignments",,, I bet you have a USB keyboard!!!!!!>Let's call it a day on this. OK ?DealLee

Share this post


Link to post
Share on other sites

This has happened to me three times over the years - twice with the '.' key for brakes and lately with the folding wing function. They are still assigned but simply do not work - deleting/reassigning restores them. I've never used a usb keyboard.(edit)As you indicated, it is entirely possible this may be due to some addon/module a lot of folks use or have used, but I too have seen several posts about this issue over the years. regards,Mark

Share this post


Link to post
Share on other sites

Good to hear you got things fixed.As for me, this will be my last post.Being a

Share this post


Link to post
Share on other sites

That's unfortunate, clearly you know your way around the back end of fs and would be of great help to other users. As for me I certainly meant no offense, and was indeed affirming your assertion that a default setup would probably never just 'lose' key assignments (but who the heck stays at default :) ) As I said I really do think this rare anomaly is more likely as a result of the myriad of third party addons out there.regards,Mark

Share this post


Link to post
Share on other sites