Archived

This topic is now archived and is closed to further replies.

Guest daftraider

Error when starting fs9

Recommended Posts

Can someone help me please ?Having an issue when starting fs9Error message comes up :The requested flight file is corrupt or can't be foundflight sim will try and load the default flight.then when I try to load a new flight it shuts down,is there anyway I can delete the default flight in the config , and how do I go about it ? thanks in advance.Rich B

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The simplest way is to locate your FS9.cfg file - it is hidden by default.Rename it to something like FS9.cfg.BAKThen when you start FS2004, a new FS9.cfg file will be created automatically and it will not have a reference in it to the problematic flight file.Assuming you are running XP, your FS9.cfg file normally resides in:C:Documents and SettingsYOUR USER NAMEApplication DataMicrosoftFS9Remember, the FS9.cfg file is "hidden" so you will need to tell Windows to display hidden files. That can be done by selecting Tools then Folder Options then the View tab. Simply place a tick mark on the option to Show hidden files and folders.Hope this helps.

Share this post


Link to post
Share on other sites

Hi Rich,It is not recommended that you delete the default flight. A better approach is to open your fs9.cfg file, hit cnrl+f and type in "situation" without the quote marks. You can safely delete that line, save your changes, and restart the sim.As long as you still have the default C172 and haven't nuked Seattle your sim should start. Then if you try and load a specific flight and the sim crashes then you have a problem with that flight. Could be a problem with the plane that flight was saved with, or maybe a change you might have made to the starting location.When you say "then when I try to load a new flight" do you mean load a saved flight or create a new flight?Hope this helps.[edit]Sorry Opa, seems we were typing at the same time.[edit]

Share this post


Link to post
Share on other sites

PS -The most likely reason for the problem is that you had saved a flight and checked the "make this the default flight" box.Then I suspect that sometime later you removed tha aircraft which was used in that flight.FS2004 was trying to locate a non-existant aircraft during the start up and this will almost always trigger a CTD at some point.

Share this post


Link to post
Share on other sites

many thanks lads I have managed to get on to the sim, changed the aircraft and the airport to fokker 100 and EGCCseems to run with these, but I must have a problem my my ATR 72 -500 after the last navigaph cycle. i have to look into that part.still comming up with the message as per 1st post.so here's what i can do now . start up screen still has error message but once clicked on sim starts upafter selecting a flight, from different airport runs ok.i could rollback my pc a few weeks ago. wonder if that will clear it up

Share this post


Link to post
Share on other sites

I am still curious -Did you try either of the suggestions which would have removed any reference to a changed startup situation?One was to edit the sutuation= line in the FS9.cfg file and the other was to back it up (effectively disabling it without deleting it) and allow FS2004 to build a new one?That error message should not be appearing if you have done one of those suggestions.Note: There are two files in the FS9 folder which have very similar names - FS9.cfg AND FS9.cfg.txt. Be very sure you are editing or backing up the one named FS9.cfg and not the other one.

Share this post


Link to post
Share on other sites

Do you get the start up screen error message with the default flight?This is why you want to keep this available, for troubleshooting purposes. If you get the message with the default flight (C172 at KSEA) that eliminates your addons as the problem.Still unclear when you say "after selecting a flight, from different airport" do you mean selecting a flight from your saved flights or creating one from scratch. Trying to determine if the problem lies in a saved flight or not.Whenever you are having problems a good practice is go to the opening screen and click on "select a flight".Under "1.Choose a category" select "other".Highlight "Default flight"Check the box "Make this the default flight""fly now!"Then restart the sim and see what happens.Hope this helps.

Share this post


Link to post
Share on other sites

problem solved now found a config issue with my new Just Flight Airbus Collection Long Hauland Flight 1 ATR 72 -500 , I uninstalled the Atr and reinstalled it.seems to have cleared it up. default flight now runs ok.many thanks Joe and David "Opa" Marshall.

Share this post


Link to post
Share on other sites